Gelöst JTL-Connector "failed to open stream: Permission denied" nach Serverumzug

kevinschoen

Aktives Mitglied
10. April 2017
6
0
Hallo zusammen,

wir sind vor ein paar Tagen mit unserem WooCommerce-Shop auf einen neuen Server umgezogen. Leider funktioniert seitdem die JTL-Connector-Anbindung nicht mehr. Ruft man den Connector direkt auf, erscheint folgende Fehlermeldung:

Code:
Fatal error: Uncaught UnexpectedValueException: The stream or file "/usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/logs/global-2017-04-10.log" could not be opened: failed to open stream: Permission denied in phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/StreamHandler.php:87 Stack trace: #0 phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/RotatingFileHandler.php(88): Monolog\Handler\StreamHandler->write(Array) #1 phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/AbstractProcessingHandler.php(37): Monolog\Handler\RotatingFileHandler->write(Array) #2 phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/mon in phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/StreamHandler.php on line 87

Fatal error: Uncaught UnexpectedValueException: The stream or file "/usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/logs/global-2017-04-10.log" could not be opened: failed to open stream: Permission denied in phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/StreamHandler.php:87 Stack trace: #0 phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/RotatingFileHandler.php(88): Monolog\Handler\StreamHandler->write(Array) #1 phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/AbstractProcessingHandler.php(37): Monolog\Handler\RotatingFileHandler->write(Array) #2 phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/mon in phar:///usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/connector.phar/vendor/monolog/monolog/src/Monolog/Handler/StreamHandler.php on line 87

Die Berechtigungen der "connector.phar"-Datei anzupassen wurde bereits versucht und hat das Problem leider nicht gelöst. Hat jemand eine Idee, woran es liegen könnte?

Schon einmal tausend Dank!
 

elevennerds.de

Sehr aktives Mitglied
23. September 2015
1.235
212
Hallo,

Dein PHP versucht in diese Datei zu schreiben: /usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/logs/global-2017-04-10.log

und das schlägt fehl. Wenn die Datei existiert, hat sie die falschen Berechtigungen (Owner prüfen), wenn sie nicht existiert, hat der Ordner

/usr/local/www/apache24/noexec/zimmer-fahrradtaschen.de/wp-content/plugins/jtlconnector/logs

die falschen Berechtigungen (muss wohl Schreibrechte für Dein PHP-Backend haben)

MfG

Rene
 

kevinschoen

Aktives Mitglied
10. April 2017
6
0
Hallo Rene,

danke für den Hinweis auf den logs-Ordner. Das hat dieses Problem tatsächlich gelöst. Nun taucht leider die folgende Fehlermeldung auf (bei einer Abfrage über JTL hängt sich JTL auf):

{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception: RpcException - File: phar:\/\/\/usr\/local\/www\/apache24\/noexec\/zimmer-fahrradtaschen.de\/wp-content\/plugins\/jtlconnector\/connector.phar\/vendor\/jtl\/connector\/src\/jtl\/Connector\/Core\/Rpc\/RequestPacket.php - Line: 173"},"jtlrpc":"2.0","id":"unknown"}

Hast du eine Idee, woran das liegen könnte?

Vielen Dank
Kevin
 

Sven M.

Gut bekanntes Mitglied
14. September 2015
165
10
Guten Tag @kevinschoen,

dies ist die Standardausgabe des Conenctors im Browser. Wenn du diese siehst, ist es schon einmal ein Zeichen dafür, dass dieser von der Wawi erreicht wird.

Viele Grüße
 

kevinschoen

Aktives Mitglied
10. April 2017
6
0
Hi Sven,

danke für den Hinweis. Haben es nun auch wieder zum Laufen bekommen. War dann wohl nur noch ein Client-Problem.

Danke!
 

Ähnliche Themen