In Diskussion Fehlermeldung nach Abgleich Variationskombinationsartikel JTL Wawi 1.5.13.0 Prestashop 1.7.5.1 Connector 1.6.2.1 Standard Template

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

ROOOOM.com

Aktives Mitglied
5. November 2015
7
1
Hallo, liebe Helferinnen und Helfer!

Ich benötige ein wenige und hoffe auf Unterstützung.

Nachdem ich in der JTL knapp 16000 bestehende Einzelartikel durch Import in Variationskombinationsartikel mit zehn Variationsnamen/Werte umgewandelt hatte, erhielt ich nach dem Abgleich mit dem Prestashop folgende Fehlermeldung:

Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'meinedomain'.
Onlineshop-Abgleich beendet für 'meinedomain'.


Fehler:
Exception: Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 /homepages/3/meins/htdocs/meinedomain/classes/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ungültig
Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 /homepages/3/meins/htdocs/meinedomain/classes/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ungültig
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 /homepages/3/meinedomain/htdocs/meinedomain/classes/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ungültig

Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 /homepages/3/meins/htdocs/meinedomain/classes/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ungültig

Response: {"result":null,"error":{"code":0,"message":"Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 \/homepages\/3\/meins\/htdocs\/meinedomain\/classes\/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ung\u00fcltig","data":null},"jtlrpc":"2.0","id":"29fa9a04cd3744a6b95bfb75c8155d10"}
Exception bei product.push: Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 /homepages/3/meins/htdocs/meinedomain/classes/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ungültig

Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 /homepages/3/meins/htdocs/meinedomain/classes/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ungültig

Response: {"result":null,"error":{"code":0,"message":"Type: Product Host-Id: 22215 SKU: 27.2104.C18.001 \/homepages\/3\/meins\/htdocs\/meinedomain\/classes\/ObjectModel.php (1032):Die Eigenschaft Attribute->name ist ung\u00fcltig","data":null},"jtlrpc":"2.0","id":"ab90892671914bf093b2c3308ca85640"}
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.UUAYT7KlA8N(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.yfgYTgHVobw(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.UUAYT7KlA8N(String , Object , Boolean , NetworkCredential )


Ich tue mich mangels tiefergehender Sachkenntnis schwer, die Fehlermeldung zu interpretieren. Aber ich kann folgendes dazu berichten:

1. In meiner Artikeltabelle in Excel ist dies der erste Artikel in der Tabelle.
2. Der Artikel war mit dieser Artikelnummer in der JTL Wawi korrekt importiert worden und mit dem Prestashop synchronisiert worden. Keine Fehlermeldungen.
3. Nach dem Import der Variationskombinationsnamen und -werte, 10 Namen/Werte insgesamt, ist der Artikel nun in der globalen Suche der JTL nicht mehr zu finden.
4. Öffne ich hingegen den Vater Artikel in der JTL, finde ich die Artikelnummer in der Übersicht der Variationskombinationen im Reiter Var. Kombi. aufgelistet:

1579604794680.png

5. Die Umwandlung von "normalen" Artikeln in Variationskombinationsartikel war durch entsprechende Auswahl in der Ameise beim Import beauftragt, wurde aber nicht bei allen Artikeln korrekt durchgeführt.

Gerne stelle ich weitere Daten zur Verfügung, um das Auffinden des Fehlers und einer Lösung zu erleichtern.

Vielen Dank schon an dieser Stelle!



Andreas
 

Anhänge

adrian.m.jtl

Moderator
Mitarbeiter
25. April 2017
148
16
Hallo ROOOOM.com,

bei der Artikelnummer "27.2104.C18.001" hat er Probleme mit dem Artikelnamen. Hier bitte einmal den Artikelnamen entweder kürzen oder/und prüfen ob Sonderzeichen im Namen enthalten sind.

Man kann auch in den Artikeldetails unter dem Reiter Beschreibung extra nur einen namen für den Angebunden Shop vergeben.

Grüße

Adrian
 

ROOOOM.com

Aktives Mitglied
5. November 2015
7
1
Hallo, Adrian!

Vielen Dank für Deine Rückantwort! Dass es ein Problem mit der Artikelnummer "27.2104.C18.001" hat, konnte ich auch aus dem kryptischen Text herauslesen, aber leider nicht genau, welches Problem besteht.

Da ich sehen konnten, dass die Anlage vieler Variationskombinationsartikel unter einem Vaterartikel beim Import nicht korrekt durchgeführt wurde, habe ich zuerst diesen Umstand näher untersucht. Ich habe dann festgestellt, dass bei den betreffenden Artikeln zwar der Variationsname_1 z.B. "Länge" in der Importdatei vorhanden war, dass es aber bei diesen Artikeln, weil er eben keine "Länge" hatte, keinen Wert im Feld Variationswert_1 gab. Ist der erste Variationswertname und -wert leer, werden scheinbar auch alle nachfolgenden korrekt befüllten Felder nicht importiert.

Mein Frage an Dich, Adrian, ist nun die folgende: Darf ein Variationswert denn Umlaute wie äöü enthalten?

Ich stelle die frage, weil ich aus dem kryptischen Text "Die Eigenschaft Attribute->name ist ungültig" zu lesen glaube, dass es nicht mit der Artikelnummer selbst zusammenhängt, sondern mit dem Namen eines Attributes selbst. Geht es dann in diesem Falle darum, dass es um den Namen eines Variationswertes der Variationskombinationen?

Vielen Dank für Deine kompetente Hilfe und Unterstützung!

Alles Gute aus München!


Andreas
 

ROOOOM.com

Aktives Mitglied
5. November 2015
7
1
Hallo, liebe Helferinnen und Helfer!

Zwischenzeitlich hatte ich nach langer Fehlersuche in den Namen der Attribute ein Ticket bei JTL eröffnet und die Ursache für diese irreführende Fehlermeldung erfahren. Tatsächlich wird die Fehlermeldung durch den sensiblen Umgang mit bestimmten Zeichen im Prestashop verursacht. In vielen Feldern darf ich wohl beliebige Zeichen verwenden, aber in manchen sind zum Beispiel <, > und ; nicht zugelassen. Die kann man im Prestashop durch anlegen eines neuen Artikels mit Sonderzeichen im Namensfeld ausprobieren. Die benannten Zeichen führen dann zur Fehlermeldung:

1583389726923.png

Ich hoffe, die Rückmeldung hilft euch bei passender Gelegenheit!

Alles Gute und bis bald!



Andreas
 
  • Gefällt mir
Reaktionen: Immanuel
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Gelöst Fehlermeldung nach Eingabe der Shopify Connector Zugangsdaten im JTL Kundencenter "es ist ein Fehler aufgetreten" Shopify-Connector 3
Neu Fehlermeldung online Anbindung JTL WaWi zum Shopware 5 Onlineshop-Anbindung 0
Neu Fehlermeldung - Internetmarken Export - The PPL is invalid! JTL-ShippingLabels - Fehler und Bugs 46
Neu admin / cache fehlermeldung JTL-Shop - Fehler und Bugs 1
In Bearbeitung Fehlermeldung bei manuellem ausliefern JTL-Wawi - Fehler und Bugs 1
Neu Fehlermeldung bei Artikelübertragung von Shopware Shopware-Connector 4
In Bearbeitung Fehlermeldung beim Gambio Abgleich Gambio-Connector 1
Neu Paypal-Zahlungen enden mit Fehlermeldung "Duplicate ID" Plugins für JTL-Shop 7
In Bearbeitung Fehlermeldung beim Drucken eines Kassenbons mit einem EPSON TM-T88V JTL-POS - Fehler und Bugs 2
Offen Webrequest Fehlermeldung "zu viele automatische Umleitungen versucht" JTL-Workflows - Ideen, Lob und Kritik 0
Neu (Ausgabe -> Rechnung -> Speichern) Fehlermeldung (Keine Rechte auf Zielpfad...) Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu JTL-Shipping Fehlermeldung auf eigenem Fehleretikett + in WMS Drucker zuweisen? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Servicedesk: Abruf von Emails mit Fehlermeldung Servicedesk (Beta) 4
Neu Email für Fehlermeldung > Shipping JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehlermeldung bei Shop-Abgleich PrestaShop-Connector 1
Neu Fehlermeldung "Keine Exportvorlage" trotz Häckchen "keine Export" JTL-ShippingLabels - Fehler und Bugs 0
Neu UPS Fehlermeldung benötige dringent Hilfe JTL-ShippingLabels - Fehler und Bugs 2
Neu Upload neuer Merkmale -> Fehlermeldung JTL-Ameise - Fehler und Bugs 2
Gelöst Fehlermeldung bei Internetmarke Warenpost International Gelöste Themen in diesem Bereich 1
Neu Fehlermeldung im Kundenbereich JTL-Wawi - Fehler und Bugs 2
Neu Fehlermeldung beim Testlauf Artikelimport via JTL Ameise JTL-Ameise - Fehler und Bugs 1
Gelöst Slider-Ich kann keine Bilder Hochladen/Keine Fehlermeldung etc. Gelöste Themen in diesem Bereich 2
Neu 1.5.18.0 Ameise bringt Fehlermeldung JTL-Ameise - Fehler und Bugs 6
Neu Sortierung nach Variationssortiernummer Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Nach MWST Anpassung werden nur Nettopreise im Shop angezeigt WooCommerce-Connector 1
Gelöst Zahlungsabgleich: Zahlungen doppelt nach Wawi Update JTL-Wawi - Fehler und Bugs 5
In Bearbeitung Nach Umstellung fehlerhafte Nettoberechnung JTL-Wawi - Fehler und Bugs 6
Offen Wie bekommt man die Preise nach der Umstellung auf 16% in den Shop? PrestaShop-Connector 2
Neu Nach der Mwst. Umstellung sind alle festgelegten individuellen Shoppreise umgerechnet worden. JTL-Wawi - Fehler und Bugs 1
Neu Kein Import der Aufträge nach MwSt Umstellung möglich Shopware-Connector 5
Neu Bruttopreise nach Ländern richtig Anzeigen Allgemeine Fragen zu JTL-Shop 13
Neu bevorzugtes Lieferdatum nach JTL übertragen WooCommerce-Connector 1
Neu MwSt-Umstellung - Verkauf vor 1.7.2020 - Rücknahme nach 1.7.2020 Fragen rund um LS-POS 0
Neu 2 Fragen (Priorität Lagerentnahme / Workflow Mindestbestandsabgleich) nach 4 Wochen Umstellung User helfen Usern - Fragen zu JTL-Wawi 3
Neu Versandliste nach Lager filtern User helfen Usern - Fragen zu JTL-Wawi 0
Neu Vorlagen nach Update verschwunden User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Fehler 404 nach Testzeitraum JTL-POS - Fehler und Bugs 2
Offen Workflow wird nicht ausgelöst: Lieferdatum setzen und Rechnung erstellen nach Versand und komplette Auslieferung JTL-Workflows - Fehler und Bugs 4
Neu Versandart mit Workflow nach Länge ändern User helfen Usern - Fragen zu JTL-Wawi 6
Offen Versandart nach Länge ändern JTL-Workflows - Ideen, Lob und Kritik 2
Offen LieferscheinNr. nach Einbuchung Arbeitsabläufe in JTL-WMS 6
Neu nach Bildertausch Fehler inkl. Fehlercode User helfen Usern - Fragen zu JTL-Wawi 3
Neu Nach SSL Verschlüsselung nur noch Backend aufrufbar. User helfen Usern - Fragen zu JTL-Wawi 4
Suche nach Kundennr - Aufträge [Gelöst] User helfen Usern - Fragen zu JTL-Wawi 2
Neu Kunden werden falsch zu uralt anderen Kunden zugeordnet nach Update auf 1.5.19.0 JTL-Wawi - Fehler und Bugs 2
In Bearbeitung Lagerbestandsanzeige ändert sich nur nach nochmaligem Abspeichern des Artikels User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Nach Adresskorrektur eines Auftrags werden 2 leere Etiketten gedruckt Gelöste Themen in diesem Bereich 2
Gelöst DHL Express nach DE: Fehler bei Labelerstellung Gelöste Themen in diesem Bereich 2
Neu Versandetiketten nachdrucken nach Neustart? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Lückenhafte Datenübertragung zum WooCommerce-Shop nach JTL-Update WooCommerce-Connector 2
Ähnliche Themen