Gelöst Fehlermeldung bei Connector Aktivierung in Wordpress

Fischkopf

Aktives Mitglied
8. September 2016
4
0
Moin in die Runde

Wenn ich den JTL Connector in Wordpress aktiviere, wird mir folgende Fehlermeldung angezeigt:

"JTL-Connector: Rewriting is disabled. Please select another permalink setting."


Wenn ich dann ein beliebig anderes Permalinksetting umschalte erscheint mir folgende Fehlermeldung:

"Das Plugin verursachte 414 Zeichen unerwartete Ausgabe während der Aktivierung. Solltest du Fehlermeldungen wie „headers already sent“, Probleme mit der Syndizierung der Feeds oder andere Fehler erhalten, versuche, das Plugin zu deaktivieren oder zu löschen."

Wordpress, Woocommerce und JTL Connector sind in der aktuellsten Version.
Auf meinem Server ist PHP 5.4 installiert (nicht die aktuellste Version).

Kann mir da wer weiterhelfen?

Danke im Voraus!
 

negroyblanco

Aktives Mitglied
4. August 2016
73
4
Hallo,

hast du in der .htaccess

RewriteEngine on

eingetragen? Klingt für mich danach, dass es bei dir deaktiviert ist.
 

Fischkopf

Aktives Mitglied
8. September 2016
4
0
In der .htaccess steht nur folgendes:

# BEGIN WordPress

# END WordPress

Wenn ich dazwischen RewriteEngine on setze ändert das leider nichts und es erscheint wieder obenstehende Permalinkmeldung:

JTL-Connector: Rewriting is disabled. Please select another permalink setting.
 

negroyblanco

Aktives Mitglied
4. August 2016
73
4
Also das hier ist meine Standard - Wordpress .htaccess, welche immer einwandfrei funktioniert:

<IfModule deflate_module>
<IfModule filter_module>
AddOutputFilterByType DEFLATE text/plain text/html
AddOutputFilterByType DEFLATE text/xml application/xml application/xhtml+xml application/xml-dtd
AddOutputFilterByType DEFLATE application/rdf+xml application/rss+xml application/atom+xml image/svg+xml
AddOutputFilterByType DEFLATE text/css text/javascript application/javascript application/x-javascript
AddOutputFilterByType DEFLATE font/otf font/opentype application/font-otf application/x-font-otf
AddOutputFilterByType DEFLATE font/ttf font/truetype application/font-ttf application/x-font-ttf
</IfModule>
</IfModule>


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 4 days"
</IfModule>
## EXPIRES CACHING ##

<filesMatch "\\.(js|js.gz)$">
Header set Cache-Control "max-age=604800, private"
</filesMatch>


Teste doch mal an!
 

Fischkopf

Aktives Mitglied
8. September 2016
4
0
Danke für den Tipp. Habe den obenstehenden Code in die htaccess eingefügt. Leider wird nach wie vor das obenstehende Permalinkproblem angezeigt.

Das Plugin kann nicht aktiviert werden, bevor ich das Permalinksetting nicht änder:

"JTL-Connector: Rewriting is disabled. Please select another permalink setting."

Nachdem ich das änder erscheint wieder:

"Das Plugin verursachte 414 Zeichen unerwartete Ausgabe während der Aktivierung. Solltest du Fehlermeldungen wie „headers already sent“, Probleme mit der Syndizierung der Feeds oder andere Fehler erhalten, versuche, das Plugin zu deaktivieren oder zu löschen."
 

Sven M.

Gut bekanntes Mitglied
14. September 2015
165
10
Guten Morgen,

wurde schon einmal überprüft, ob andere Plugins ebenso auf bestimmte Permalink Einstellungen angewiesen sind? Dadurch kann es dazu kommen, dass die Änderungen der Einstellung entweder das eine oder das andere Plugin deaktivieren,

Viele Grüße
 

Ähnliche Themen