Neu Fehlerhafte bzw. keine Übertragung mehr zu SW

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

tommy1515

Gut bekanntes Mitglied
10. Oktober 2016
264
12
Guten Abend,
folgendes Problem tritt auf, seit dem Update auf die aktuelle WAWI:
Code:
Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()
Kann mir bitte jemand helfen?

Danke im voraus, Sabine
 

tommy1515

Gut bekanntes Mitglied
10. Oktober 2016
264
12
Nun gut, aber das seltsame ist, das alle JTL Shops ohne Probleme übertragen werden, nur der Shopware Shop nicht.
Da liegt es ja auch Nahe, das der SW Connector betroffen ist.

Über den Worker scheint es aber komischerweise auch zu funktionieren, dauert nur ewig und bricht ab und an mal ab bei einer menge von pi mal daumen 4000 Artikeln die aktualisiert werden müssten.

Wird denn daran gearbeitet oder steht es auf der Todo Liste?

Vielen Dank schon mal, Sabine
 

itratosTeam

Gut bekanntes Mitglied
19. April 2007
410
18
Bamberg
Hallo Sabine,

ich vermute eher das hier an der SaaS API gearbeitet wird und der JTL- Shop davon ja eigentlich nicht betroffen ist. Die Schnittstelle zum JTL-Shop ist ja bereits vorhanden und da werden vermutlich erst Anpassungen ab Version 5 nötig. Aber diese sind sicher vor dem goLive der Version 5 bereits erledigt da JTL diese ja für das eigene Testing benötigt.
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
189
5
Hallo Zusammen,

aktuell erhalten wir den identischen Fehler:

Code:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()
In einem Shop wird die aktuellste Wawi-Version 1.5.29.3 mit dem aktuellsten Shopware- Connector verwendet und im anderen Shop die Wawi mit der Version 1.5.29.1 mit dem aktuellsten Shopware-Connector.
Der Fehler tritt bei beiden Wawis im Abgleich auf. Fehler kommt beim ersten Abgleich, wenn man dann den Abgleich nochmals durchführt, kommt der Fehler nicht mehr und der Abgleich scheint zu funktionieren.
 

itratosTeam

Gut bekanntes Mitglied
19. April 2007
410
18
Bamberg
Hallo lohkaes,

ja das ist richtig der Fehler kommt unregelmäßig aber nach dem ersten mal immer mal wieder
Bisher konnten wir das Problem in den Versionen ab 1.5.29.1 erkennen.

Wir haben gerade einen Kunden von einer .28 auf .31 aktualisiert und stellten das Problem bisher nicht fest
 

MarcoH

Aktives Mitglied
26. April 2018
10
1
Hallo,
wir haben den gleichen Fehler. Wir kommen immer so zwischen 100 und 500 Artikel durch und dann bricht der Abgleich ab.

Hat jemand eine Idee?

Lg
Marco
 

redheadman

Gut bekanntes Mitglied
3. August 2016
109
12
Berlin
Wir müssen uns da anschließen! JTL, Shopware 5 und Connector sind auf aktuellen Stand.

Haben gestern 4 Artikel hochladen wollen und nichts ist passiert. Im JTL Log ein Artikel senden Fehler ohne explizite Aussage.
Da wir mit dem Worker arbeiten, habe ich vorhin mal die Log Datei angesehen und da steht der selbe Fehler wie oben angegeben drin.

Jetzt kommt aber das kuriose, habe dann mal den Worker deaktiviert und den normalen Abgleich gestartet.
Der sendet alle Artikel neu hoch (zum Shopware 5 Shop) und deswegen sind die 4 Artikel noch nicht drin. Bei ca. 700 -1200 bricht er dann mit genannten Fehler ab.

Im übrigen ist der Fehler auch bei der Shopware 6 Schnittstelle, allerdings sendet er nicht alle Artikel neu hoch. Es ist also ein JTL Problem

Wir haben gestern das letzte JTL Update gefahren, weil wir nach einem Update mit den Formularen hatten,
allerdings kann ich jetzt nicht sagen ob das schon mit der 1.5.30. so war oder mit der 1.5.30.2, da wir keine so hohe Artikelmengen hochgeladen haben.

Was ist hier los, ich bekomme langsam ne Krise? Mit den letzten Updates haben sich soviele Fehler eingeschlichen,
aber wir mussten Updaten da viele für uns wichtige Änderungen in Bezug auf Buchhaltung etc. vorhanden waren.


1601537148651.png
 

MarcoH

Aktives Mitglied
26. April 2018
10
1
Nach dem neuen Update heute sendet der Online Shop Abgleich ein paar hundert Artikel, dann unterbricht er, um dann Preise und Bestände hochzuladen.
Nachdem er ein paar tausend Preise und Bestände, die es eigentlich gar nicht gibt, hochgeladen hat, macht er die Artikel weiter.

Beim zweiten angeschlossenen Shop kamen wir auf 43.000 von 183 Preisen. Dann haben wir abgebrochen....
Shop Abgleich.PNGShop Abgleich.PNG

Der Grüne Balken unten ist dabei voll bei 100%

Shop Nummer drei geht gleich in die Preise und Bestände. Auch deutlich höher...
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Diskussion WARENPOST 2.0 ... Vorsicht, es werden wohl fehlerhafte Versandetiketten nicht bei Deutschen Post storniert JTL-ShippingLabels - Fehler und Bugs 24
Neu Fehlerhafte Datenübertragung Gambio-Connector 3
Neu Fehlerhafte Zahleneingabe z.B. bei Barentnahme JTL-POS - Fehler und Bugs 4
Neu HTML Textfeld fehlerhafte Darstellung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
In Bearbeitung Inventur- fehlerhafte Bestände JTL-Wawi - Fehler und Bugs 1
Neu Kundenarchiv - frühere Kunden archivieren bzw. deaktivieren JTL-Wawi - Ideen, Lob und Kritik 0
Neu Es werden keine Brutto Verkaufspreise in den Shop übertragen bzw. aktualisiert Shopware-Connector 2
Neu Umbrüche bzw. mehrere Spalten bei Artikeln Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Bug Geschwindigkeit: Export > Rechnungen bzw. Rechnungen (Neu) JTL-Ameise - Fehler und Bugs 2
Neu Pickliste für Rohmaße bzw. Meterware Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Beim Bearbeiten und Einstellen bzw. Listen von Artikeln auf ebay.co.uk tritt ständig eine Fehlermeldung auf. JTL-Wawi - Fehler und Bugs 3
Neu JTL Wawi ODBC Verbindung funktioniert nicht (bzw. nur teilweise) Installation von JTL-Wawi 9
Neu Eingangsrechnungen - Bereits abgerechnete Artikel anzeigen bzw. noch offene Artikel anzeigen Individuelle Listenansichten in der JTL-Wawi 0
Neu SCHON WIEDER: Nichts wird mehr von bzw. zu Amazon übertragen Amazon-Anbindung - Fehler und Bugs 2
Neu EVO-Template Kategorie- und Banner Anzeige bzw. Design Templates für JTL-Shop 0
Neu Shop wird nicht angezeigt - Datenbank ist bei 1&1 bzw. IONOS Einrichtung von JTL-Shop 3
Neu JTL Shipping Labels Server nicht erreichbar - Heute wieder mal keine Versandlabels JTL-ShippingLabels - Fehler und Bugs 18
Neu Wie Variationskombinationen importieren, wenn es keine Väter gibt? JTL-Ameise - Ideen, Lob und Kritik 8
Neu Keine Verbindung zur WAWI möglich. Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration Allgemeines zu den JTL-Connectoren 0
In Bearbeitung Ich bekomme keine Buchungsdaten mehr aus der Ameise User helfen Usern - Fragen zu JTL-Wawi 4
Gelöst JTL Konfigurator zeigt keine Konfigurationen an / kann jemand helfen? User helfen Usern - Fragen zu JTL-Wawi 5
Neu Keine Rückmeldung - Lange Ladezeit JTL-Wawi - Fehler und Bugs 2
Neu Standardsuche findet keine Suchbegriffe, wenn andere als die Standardsprache gewählt ist Allgemeine Fragen zu JTL-Shop 0
Neu Keine Zahlungsart an JTL WaWi übertragen bei bei Nullbon (Umtausch gegen Artikel gleichen Warenwertes) JTL-POS - Fehler und Bugs 1
Neu Keine Verbindung zur TSE möglich über Epson Drucker JTL-POS - Fehler und Bugs 3
In Bearbeitung Nach Windows Update keine Verbindung zur Datenbank JTL-Wawi - Fehler und Bugs 6
Neu Artikel im Shop zurückgesetzt, keine SEO URL´s mehr Betrieb / Pflege von JTL-Shop 8
Gelöst Überkäufe - Artikel wenn nicht lagernd keine Pickliste erzeugen Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Beantwortet Endkunde aus Griechenland , keine Umsatzsteuer JTL-Shop - Fehler und Bugs 6
Neu Nur an Amazon-Kunden soll keine Rechnung gemailt werden - Kommunikations-Richtline Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 8
Neu Kunden erhalten keine Mail für das zurücksetzen des Passworts Allgemeine Fragen zu JTL-Shop 1
In Bearbeitung Seit dem Update ..... keine automatische Rechnung / Versandlabel Erstellung mehr JTL-Wawi - Fehler und Bugs 2
Neu Keine automatische Auslieferung bei Bestellungen über Online Shopanbindung (Connector & Unicorn 2) Onlineshop-Anbindung 0
Neu Abgleich Lagerbestand nicht korrekt / keine neuen Artikel im Online Shop WooCommerce-Connector 1
Neu keine Bilder in JTL-POS Allgemeine Fragen zu JTL-POS 0
Neu Kontaktformular schickt keine Nachrichten (mehr?) Allgemeine Fragen zu JTL-Shop 8
Neu JTL-Packtisch+/WMS-Ausgabe - keine Begrenzung auf Auftragspriorität möglich JTL-Wawi - Ideen, Lob und Kritik 0
Neu Es konnte keine Verbindung zur TSE Einheit hergestellt werden! ErrorCode: 2 (ERR_CONNECT) JTL-POS - Fragen zu Hardware 0
Gelöst JTL-Packtisch+ druckt keine Labels Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 4
In Bearbeitung [WAWI-34505] Wareneingang geht nicht - bringt keine Bestellungsanzeige / - Schleife JTL-Wawi - Fehler und Bugs 5
Neu Wareneingang geht nicht - bring keine Bestellungsanzeige / - Schleife User helfen Usern - Fragen zu JTL-Wawi 4
In Bearbeitung B2B Preis senden kann bei FBA-Artikel nicht verwendet werden - keine Kaufmöglichkeit für Amazon-Businesskunden? Amazon-Anbindung - Ideen, Lob und Kritik 6
Neu es kann keine Verbindung zwischen JTL-WAWI und POS hergestellt werden. Einrichtung / Updates von JTL-POS 6
Gelöst JTL Shop 5 Keine Verbindung zur WAWI möglich. Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration Gelöste Themen in diesem Bereich 6
Neu Achtung vor Update bitte bei PHP die Intl Version prüfen, sonst keine Kunden Registrierung möglich JTL-Shop - BETA - Feedback und Bugmeldungen 9
Neu Keine Swatches bei Variationskombinationen? Allgemeine Fragen zu JTL-Shop 8
Gelöst Packliste - Wenn keine Position vorhanden, dann Menge ausblenden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Verwiesen an Support [1.5.31.0] Kann keine Bilder mehr hinzufuegen. JTL-Wawi - Fehler und Bugs 1
In Bearbeitung Amazon Abgleich verarbeitet keine Bestellungen (WaWi 1.5.30.2) Amazon-Anbindung - Fehler und Bugs 2
In Bearbeitung Bei Auslieferung hängt sich der Hintergrundprozess auf. keine Rechnungen... JTL-Wawi - Fehler und Bugs 4
Ähnliche Themen