Neu Fehlerhafte bzw. keine Übertragung mehr zu SW

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

tommy1515

Gut bekanntes Mitglied
10. Oktober 2016
286
12
Guten Abend,
folgendes Problem tritt auf, seit dem Update auf die aktuelle WAWI:
Code:
Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()
Kann mir bitte jemand helfen?

Danke im voraus, Sabine
 

tommy1515

Gut bekanntes Mitglied
10. Oktober 2016
286
12
Nun gut, aber das seltsame ist, das alle JTL Shops ohne Probleme übertragen werden, nur der Shopware Shop nicht.
Da liegt es ja auch Nahe, das der SW Connector betroffen ist.

Über den Worker scheint es aber komischerweise auch zu funktionieren, dauert nur ewig und bricht ab und an mal ab bei einer menge von pi mal daumen 4000 Artikeln die aktualisiert werden müssten.

Wird denn daran gearbeitet oder steht es auf der Todo Liste?

Vielen Dank schon mal, Sabine
 

itratosTeam

Gut bekanntes Mitglied
19. April 2007
415
20
Bamberg
Hallo Sabine,

ich vermute eher das hier an der SaaS API gearbeitet wird und der JTL- Shop davon ja eigentlich nicht betroffen ist. Die Schnittstelle zum JTL-Shop ist ja bereits vorhanden und da werden vermutlich erst Anpassungen ab Version 5 nötig. Aber diese sind sicher vor dem goLive der Version 5 bereits erledigt da JTL diese ja für das eigene Testing benötigt.
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
194
5
Hallo Zusammen,

aktuell erhalten wir den identischen Fehler:

Code:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()
In einem Shop wird die aktuellste Wawi-Version 1.5.29.3 mit dem aktuellsten Shopware- Connector verwendet und im anderen Shop die Wawi mit der Version 1.5.29.1 mit dem aktuellsten Shopware-Connector.
Der Fehler tritt bei beiden Wawis im Abgleich auf. Fehler kommt beim ersten Abgleich, wenn man dann den Abgleich nochmals durchführt, kommt der Fehler nicht mehr und der Abgleich scheint zu funktionieren.
 

itratosTeam

Gut bekanntes Mitglied
19. April 2007
415
20
Bamberg
Hallo lohkaes,

ja das ist richtig der Fehler kommt unregelmäßig aber nach dem ersten mal immer mal wieder
Bisher konnten wir das Problem in den Versionen ab 1.5.29.1 erkennen.

Wir haben gerade einen Kunden von einer .28 auf .31 aktualisiert und stellten das Problem bisher nicht fest
 

MarcoH

Aktives Mitglied
26. April 2018
10
1
Hallo,
wir haben den gleichen Fehler. Wir kommen immer so zwischen 100 und 500 Artikel durch und dann bricht der Abgleich ab.

Hat jemand eine Idee?

Lg
Marco
 

redheadman

Gut bekanntes Mitglied
3. August 2016
110
13
Berlin
Wir müssen uns da anschließen! JTL, Shopware 5 und Connector sind auf aktuellen Stand.

Haben gestern 4 Artikel hochladen wollen und nichts ist passiert. Im JTL Log ein Artikel senden Fehler ohne explizite Aussage.
Da wir mit dem Worker arbeiten, habe ich vorhin mal die Log Datei angesehen und da steht der selbe Fehler wie oben angegeben drin.

Jetzt kommt aber das kuriose, habe dann mal den Worker deaktiviert und den normalen Abgleich gestartet.
Der sendet alle Artikel neu hoch (zum Shopware 5 Shop) und deswegen sind die 4 Artikel noch nicht drin. Bei ca. 700 -1200 bricht er dann mit genannten Fehler ab.

Im übrigen ist der Fehler auch bei der Shopware 6 Schnittstelle, allerdings sendet er nicht alle Artikel neu hoch. Es ist also ein JTL Problem

Wir haben gestern das letzte JTL Update gefahren, weil wir nach einem Update mit den Formularen hatten,
allerdings kann ich jetzt nicht sagen ob das schon mit der 1.5.30. so war oder mit der 1.5.30.2, da wir keine so hohe Artikelmengen hochgeladen haben.

Was ist hier los, ich bekomme langsam ne Krise? Mit den letzten Updates haben sich soviele Fehler eingeschlichen,
aber wir mussten Updaten da viele für uns wichtige Änderungen in Bezug auf Buchhaltung etc. vorhanden waren.


1601537148651.png
 

MarcoH

Aktives Mitglied
26. April 2018
10
1
Nach dem neuen Update heute sendet der Online Shop Abgleich ein paar hundert Artikel, dann unterbricht er, um dann Preise und Bestände hochzuladen.
Nachdem er ein paar tausend Preise und Bestände, die es eigentlich gar nicht gibt, hochgeladen hat, macht er die Artikel weiter.

Beim zweiten angeschlossenen Shop kamen wir auf 43.000 von 183 Preisen. Dann haben wir abgebrochen....
Shop Abgleich.PNGShop Abgleich.PNG

Der Grüne Balken unten ist dabei voll bei 100%

Shop Nummer drei geht gleich in die Preise und Bestände. Auch deutlich höher...
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Fehlerhafte Anbindung zur Datenbank User helfen Usern - Fragen zu JTL-Wawi 1
Neu Offene/Fehlerhafte Lieferscheine JTL-Wawi - Fehler und Bugs 0
Neu Fehlerhafte Darstellung / Fehler 500 Allgemeine Fragen zu JTL-Shop 2
Neu Fehlermeldung Fehlerhafte Steuereinstellungen JTL-Wawi - Fehler und Bugs 1
In Diskussion WARENPOST 2.0 ... Vorsicht, es werden wohl fehlerhafte Versandetiketten nicht bei Deutschen Post storniert JTL-ShippingLabels - Fehler und Bugs 39
Neu Fehlerhafte Datenübertragung Gambio-Connector 3
Neu Fehlerhafte Zahleneingabe z.B. bei Barentnahme JTL-POS - Fehler und Bugs 4
Neu Irreführende bzw. falsche Anzeige im Artikel (Nächste Lieferung) JTL-Wawi - Fehler und Bugs 0
Neu Trackinglink für DPD Italien bzw. BRT wie aufbauen?!? Arbeitsabläufe in JTL-Wawi 6
Neu JTL Standardtext bzw. Werbung auf NOVA Startseite entfernen Allgemeine Fragen zu JTL-Shop 2
Neu Amazon - Variationen bzw. Varkombis ergänzen funktioniert nicht Amazon-Lister - Fehler und Bugs 5
Neu Amazon bzw. DPD geht auch nicht es liegt an JTL und nicht an DHL JTL-ShippingLabels - Fehler und Bugs 2
Neu Aufträge als Erledigt kennzeichnen bzw aus der Liste offen Aufträge verschwinden lassen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Beantwortet Artikel im Webshop aktiv schalten bzw. deaktivieren JTL-Workflows - Ideen, Lob und Kritik 2
Neu Email Vorlagen in Portrait-Ansicht nicht sichtbar bzw. speicherbar JTL-POS - Fehler und Bugs 0
In Diskussion Retour: Receiver-ID (DHL - Was ist das, und warum kein Inland bzw. Deutschland vorhanden) JTL-ShippingLabels - Ideen, Lob und Kritik 1
In Diskussion Track & Trace Pakete werden nicht angezeigt bzw. erhalten keinen neuen Status JTL-Track&Trace - Fehler und Bugs 25
Neu Connector überträgt keine Kategorien bzw löscht beim Abgleich die Kategorien der bestellten Artikel Shopware-Connector 0
Neu Kundenarchiv - frühere Kunden archivieren bzw. deaktivieren JTL-Wawi - Ideen, Lob und Kritik 0
Neu Es werden keine Brutto Verkaufspreise in den Shop übertragen bzw. aktualisiert Shopware-Connector 2
Neu Umbrüche bzw. mehrere Spalten bei Artikeln Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Bug Geschwindigkeit: Export > Rechnungen bzw. Rechnungen (Neu) JTL-Ameise - Fehler und Bugs 2
Neu Pickliste für Rohmaße bzw. Meterware Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu VK Brutto -> Netto keine Änderung nach Steuerumstellung User helfen Usern - Fragen zu JTL-Wawi 0
In Diskussion ShippingLabel - Versandart ändern nach Ausdruck zeigt keine Wirkung JTL-ShippingLabels - Ideen, Lob und Kritik 1
Neu Onlineshop-Abgleich überträgt keine Artikel User helfen Usern - Fragen zu JTL-Wawi 6
Neu DHL Wunschpaket - keine Anzeige der Services nach Aktivierung des Plugins. Technische Fragen zu Plugins und Templates 1
Neu Google Shopping Plugin - Exportdatei enthält keine Artikel Plugins für JTL-Shop 7
Beantwortet [JTL Shop 5] Nach Update zu JTL Shop 5 keine Abgleiche mehr mit der Wawi JTL-Shop - Fehler und Bugs 29
Neu [JTL Shop 5] Im Footer keine Links mehr JTL-Shop - Fehler und Bugs 3
Neu Komplettabgleich - Markierung „Alles“ setzt keine Hacken bei „Bestände“ und „Preise“ User helfen Usern - Fragen zu JTL-Wawi 1
Neu Keine URL in Sitemap - JTL Shop 5 JTL-Shop - Fehler und Bugs 12
Neu Privatkunden im Ausland beliefert. JTL hat keine Steuern berechnet.!? User helfen Usern - Fragen zu JTL-Wawi 4
Neu JTL Shop 5 - Keine Bilder der Unterkategorie in mobiler Ansicht JTL-Shop - Fehler und Bugs 8
Neu Manueller Zahlungsabgleich - falsche zuweisungen - keine zuweisung JTL-Wawi - Fehler und Bugs 0
Gelöst eBay-Abgleich fehlgeschlagen: Der Server lieferte keine Antwort zurück. heute 16.42Uhr Einrichtung und Installation von JTL-eazyAuction 8
Neu Artikel two-way Sync + keine Kunden/Aufräge WooCommerce-Connector 0
Neu Fehler beim Ausliefern Auftrag wird nicht ausgeliefert: Keine Teillieferung erlaubt JTL-Wawi - Fehler und Bugs 2
Neu Keine Produktbilder Allgemeine Fragen zu JTL-Shop 9
Neu Keine Verbindung zur Datenbank im Netzwerk User helfen Usern - Fragen zu JTL-Wawi 4
Neu Keine Sidebar mehr im Shop5 Desktop-View ??? JTL-Shop - Ideen, Lob und Kritik 9
Neu Keine gültige Multishop Lizenz - Webshop ausgeblendet Onlineshop-Anbindung 2
Neu Retourenscheine International erstellen - es gibt keine Lösung JTL-Track&Trace - Ideen, Lob und Kritik 1
In Bearbeitung Bei "Amazon-Lister->Variationen zuweisen" gibt es keine Auswahlmöglichkeit für "material-size", wieso? Amazon-Lister - Fehler und Bugs 1
Neu DHL Warenpost erzeugt keine Labels JTL-ShippingLabels - Fehler und Bugs 2
Neu Nach löschen aller Artikel im Shop keine Neuanlage der Artikel möglich Shopware-Connector 0
Neu JTL Shop 5 mit Wawi verbinden - Keine Verbindung möglich! JTL-Shop - Fehler und Bugs 9
Neu Keine unterscheidlichen Preise für WAWI und Onlineshop - automatisches Übernehmen vom gleichen Preis Arbeitsabläufe in JTL-Wawi 3
Neu Auftragsexport - Textdatei - feste Abstände - keine Trennzeichen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Kundenbereich>Onlineshop - "Kundengruppe" keine zuordnung möglich (POS) JTL-Wawi - Fehler und Bugs 0
Ähnliche Themen