In Diskussion Fehler beim Übertragen von Bildern

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Tobias G.

Neues Mitglied
22. November 2019
6
0
Seit dem 19.11 erhalten wir Fehlermeldungen im Log vom Connector. Außerdem werden unsere Kategorienbilder nicht mehr übertragen und teilweise sind unsere Artikelbilder mehrfach dem selben Artikel im Shopware hinterlegt.
Wir hatten die meisten unsere Artikel am 18.11 umbenannt.
Laut dem Logbuch in JTL Wawi wurde der letzte Artikel am 19.11 um 9:28 geändert.
Der nächste Eintrag im Logbuch um 9:42 zeigt eine Fehlermeldung mit dem folgenden Fehler:
Exception: Call to undefined method Shopware_Components_Translation::deleteAll() Call to undefined method Shopware_Components_Translation::deleteAll()

Dieselbe Fehlermeldung findet sich auch im JTL Connector Log wieder:
Exception: Call to undefined method Shopware_Components_Translation::deleteAll()
Call to undefined method Shopware_Components_Translation::deleteAll()

Fehlermeldung aus Shopware:
global.ERROR: Exception 'Error' (Code: 0) with message 'Call to undefined method Shopware_Components_Translation::deleteAll()' in phar:///www/htdocs/.../engine/Shopware/Plugins/Local/Frontend/jtlconnector/connector.phar/src/Mapper/MeasurementUnit.php:121 [] []


Wawi: 1.5.10.0
Connector: 2.2.4.2
Shopware: 5.6.2

Sofern noch Informationen fehlen sollte, bitte lasst es mich wissen.

-Tobias G.
 

Tobias G.

Neues Mitglied
22. November 2019
6
0
Hallo @Tobias G.,

da scheint sich ein Bug eingeschlichen zu haben. Wir werden dafür kommende Woche einen Hotfix rausbringen.
Wir haben gestern das Update von dem Connector von Version 2.2.4.2 auf 2.2.4.3 gemacht.
Den Fehler hat es aber anscheinend nicht behoben.

Wir bekommen die selbe Fehlermeldung in den Logs:
Exception: Call to undefined method Shopware_Components_Translation::deleteAll()
Call to undefined method Shopware_Components_Translation::deleteAll()


Wawi: 1.5.10.0
Connector: 2.2.4.3
Shopware: 5.6.2

-Tobias G.

Sofern noch Informationen fehlen sollte, bitte lasst es mich wissen.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
894
191
Hallo Tobias,

da scheint etwas mit den Events bei euch im Shop nicht korrekt zu funktionieren. Bitte setze mal folgende zwei Queries in eurer Shopware Datenbank ab und schicke mir das Ergebnis:

SQL:
SELECT * FROM s_core_subscribes WHERE pluginID = (SELECT id FROM s_core_plugins WHERE name = 'jtlconnector')
SQL:
SELECT * FROM s_core_subscribes WHERE subscribe = 'Enlight_Bootstrap_InitResource_Translation'
 

Tobias G.

Neues Mitglied
22. November 2019
6
0
Hallo Immanuel,

hier die Ausgabe unserer Datenbank.

SQL:
SELECT * FROM s_core_subscribes WHERE pluginID = (SELECT id FROM s_core_plugins WHERE name = 'jtlconnector')
ID2696
subscribeEnlight_Controller_Dispatcher_ControllerPath_Frontend_Jtlconnector
type0
listenerShopware_Plugins_Frontend_jtlconnector_Bootstrap:: onGetControllerPathFrontend
pluginID92
position0

SQL:
SELECT * FROM s_core_subscribes WHERE subscribe = 'Enlight_Bootstrap_InitResource_Translation'
Hat keine Zeile zurück gegeben.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
894
191
Es scheint der Update Vorgang des Connector Plugins nicht komplett durchgeführt worden zu sein. Bei der ersten Abfrage hätte noch ein weiterer Eintrag erscheinen müssen:

subscribeEnlight_Bootstrap_InitResource_Translation
type0
listenerShopware_Plugins_Frontend_jtlconnector_Bootstrap::overrideTranslationService
pluginID92
position0
 

Tobias G.

Neues Mitglied
22. November 2019
6
0
Es scheint der Update Vorgang des Connector Plugins nicht komplett durchgeführt worden zu sein. Bei der ersten Abfrage hätte noch ein weiterer Eintrag erscheinen müssen:

subscribeEnlight_Bootstrap_InitResource_Translation
type0
listenerShopware_Plugins_Frontend_jtlconnector_Bootstrap::overrideTranslationService
pluginID92
position0
Vielen Dank für die Info.

Wir haben jetzt probiert ob der Fehler mit einer Neuinstallation behoben wird. Leider hat weder das automatische Neuinstallieren, als auch das Deinstallieren und danach Installieren nicht geholfen.
Nach der Neuinstallation ist immer nur ein Eintrag in der Datenbank vorhanden.

Wir haben auch überprüft, dass kein jtlconnector Eintrag in der Datenbank nach der Deinstallation ist.

Würde es etwas bringen, wenn wir den fehlenden Eintrag in der Datenbank manuell eintragen, oder kann es sein, dass noch mehr fehlt?

-Tobias G.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
894
191
Wir haben gerade das Release von gestern gecheckt: Es wurde aus welchem Grunde auch immer eine Version hochgeladen, in der der Fix nicht drin war. Den Connector am besten nochmal komplett deinstallieren, löschen und danach neu installieren. Dann sollte der für euch relevante Fix mit drin sein.
 

Tobias G.

Neues Mitglied
22. November 2019
6
0
Wir haben gerade das Release von gestern gecheckt: Es wurde aus welchem Grunde auch immer eine Version hochgeladen, in der der Fix nicht drin war. Den Connector am besten nochmal komplett deinstallieren, löschen und danach neu installieren. Dann sollte der für euch relevante Fix mit drin sein.
Nach dem wir den Connector deinstalliert, gelöscht und neu installiert haben bekommen wir keinen Fehler mehr.
In der Datenbank sind beide Einträge vorhanden.

Vielen Dank für die große Hilfe

-Tobias G.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Fehler beim Scannen von Artikeln - Artikel nicht gefunden! ABER es gibt ihn doch! JTL-POS - Fehler und Bugs 11
Gelöst Fehler beim Erstellen des FBA Anlieferplans - Missing_Dimensions Amazon-Lister - Fehler und Bugs 3
Gelöst [Deutsche Post] UPDATE: 09.10.20 Fehler beim erstellen der Versandetiketten Gelöste Themen in diesem Bereich 1
Neu Fehler beim versenden der Emails über ServiceDesk Servicedesk (Beta) 5
Neu JTL Shopware Connector Fehler beim Import von Kunden und Bestellungen Onlineshop-Anbindung 2
Verwiesen an Support/SP JTL Fehler beim Ausliefern JTL-Wawi - Fehler und Bugs 1
Gelöst Prime by Seller, Fehler beim erstellen des DPD Etiketts Amazon-Anbindung - Fehler und Bugs 1
Neu WAWI Mail-Einstellungen SMTP "Verbindung testen" Fehler beim Versenden der E-Mail JTL-Wawi - Fehler und Bugs 10
Neu Fehler nach Update auf 1.5.30.0 beim Mailen JTL-Wawi - Fehler und Bugs 26
Neu Fehler beim Verbindungsaufbau - Ungültiges Gateway Shopify-Connector 4
Neu Nach Update fehler beim start Installation von JTL-Wawi 3
In Bearbeitung Fehler beim Zugriff auf die Datenbank - meistens bei einer Rechnungskorrektur JTL-Wawi - Fehler und Bugs 15
Gelöst WMS-Fehlernummer: -1 ==> Fehler beim Verpacken JTL-WMS - Fehler und Bugs 7
Gelöst Nach Windows Ruhemodus - Exec Fehler beim Datenbankabruf Gelöste Themen in diesem Bereich 3
Gelöst Fehler beim Connector? bei Komplettabgleich? Modified eCommerce-Connector 0
Gelöst Sendefehler beim Shopabgleich (Shopware 5) - Lieferscheine-Senden-Fehler Gelöste Themen in diesem Bereich 1
Neu Fehler beim erzeugen der Versandbenachrichtigung (Wawi -> FFN) - Die Sequenz enthält keine Elemente. JTL-Wawi - Fehler und Bugs 5
Gelöst 1.5.24.1 - Fehler beim Erstellen eines Retourenlabels Gelöste Themen in diesem Bereich 2
Neu In den Vorlagen (Rechnung) Fehler beim bearbeiten der Exportvorlagen JTL-Wawi - Fehler und Bugs 0
Neu Fehler bei Mahnlauf JTL-Wawi - Fehler und Bugs 0
Neu Nova Auswahlassistent - 2 Fehler gefunden JTL-Shop - BETA - Feedback und Bugmeldungen 0
Neu Worker zeigt oft Fehler bei Ebay Abgleich 1.5.31.0 User helfen Usern - Fragen zu JTL-Wawi 7
Neu Woher kommt der Fehler "CSRF-Warnung fuer Login: 1" in den JTL Logs? Allgemeine Fragen zu JTL-Shop 0
Neu Fehler bei Beendigung Objektname "Timer" nicht gefunden JTL-Wawi - Fehler und Bugs 0
Neu Fehler in Export- CSV der Bons JTL-POS - Fehler und Bugs 1
In Bearbeitung [WAWI-50281] Schwerer Fehler in dot liquid führt zu Fehlberechnungen - Typen Deklaration Problem JTL-Wawi - Fehler und Bugs 17
Neu Versanddaten mit Fehler bei Umlagerungen erneut exportieren User helfen Usern - Fragen zu JTL-Wawi 1
Gelöst Fehler bei Cond(Page() == 1, 110, 10) Gelöste Themen in diesem Bereich 3
Neu Workflow Fehler bat Datei wird nicht ausgeführt User helfen Usern - Fragen zu JTL-Wawi 1
Neu schwerwiegender Fehler nach Buchung Barentnahme nach Tagesabschluß JTL-POS - Fehler und Bugs 6
Neu Fehler bei Sichtbarkeit Kundengruppe(Rabatt) nach Aktivierung von Kategorie für die JTL-POS JTL-POS - Fehler und Bugs 2
In Diskussion TSE1_ERROR_TRANSACTION_NOT_STARTED - unbehebbaren Fehler in 1.0.2.8 JTL-POS - Fehler und Bugs 4
Abgelehnt Fehler bei Update: "SQLSTATE[42S22]: Column not found: 1054 Unknown column 'l.type' in 'field list'" Gelöste Themen in diesem Bereich 4
Neu Datenbank Fehler - tpreise Spalte kKundengruppe in tpreise nicht vorhanden JTL-Shop - Fehler und Bugs 1
Neu Smarty Syntax-Fehler JTL-Shop - BETA - Feedback und Bugmeldungen 1
Neu Fehler im Shop bei Passwort JTL-Shop - Fehler und Bugs 6
Fehler bei Update auf Version>= 1.5.30.x JTL-Wawi - Fehler und Bugs 2
In Bearbeitung JTL 1.5.30.3 Fehler: "Kein gueltiges Bild hinterlegt." User helfen Usern - Fragen zu JTL-Wawi 3
Neu CLS Fehler in Search Console Allgemeine Fragen zu JTL-Shop 3
Neu Wann kommt die nächste Connector Version? Nächster Fehler Modified eCommerce-Connector 0
Neu Onlineshop Abgleich Fehler Woocomerce Connector Onlineshop-Anbindung 6
Gelöst PayPal Express - Fehler im Log Plugins für JTL-Shop 2
In Bearbeitung Leeres Feld "Produktart" führt bei Ebay zu Fehler eBay-Anbindung - Fehler und Bugs 5
Neu Fehler nach öffnen einer E-Mail Servicedesk (Beta) 5
Gelöst Kritischer Fehler - JTL Shop 4 Gutschein + Konfigurator Plugins für JTL-Shop 2
Gelöst 02.10.2020 Ebay Abgleich Fehler Gelöste Themen in diesem Bereich 2
In Bearbeitung Worker ebay Abgleich zeigt heute stets Fehler User helfen Usern - Fragen zu JTL-Wawi 10
In Bearbeitung Fehler bei Artikeleinstellen auf Ebay: "Produktart fehlt" User helfen Usern - Fragen zu JTL-Wawi 4
Neu DHL Versenden 3.0 einrichten - Verursacht Fehler JTL-ShippingLabels - Fehler und Bugs 2
Neu Fehler im Connector 3.0 Modified eCommerce-Connector 1
Ähnliche Themen