Neu Ein "Download" wird beim Aufruf der Startseite ausgeführt

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Hallo liebes Forum,

wir haben aktuell ein merkwürdiges Problem in unserem JTL Shop 4.0.6.16.

Letzte Woche wurde der Shop auf einen neuen Server umgezogen, funktionierte auch alles einwandfrei. Heute habe ich dann erfahren, dass einige Kollegen beim Aufruf der Startseite ein Downloadfenster bekommen, wo eine 0kb Datei heruntergeladen werden soll bzw. automatisch je nach Einstellung heruntergeladen wird. Das Problem tritt im Chrome Browser auf, aber nicht z. B. in Firefox oder dem neuen Edge.

Bei mir funktioniert es im Chrome (Firefox, Edge, Opera, Safari) sowie Chrome auf meinem Smartphone ohne Probleme (seit dem Umzug). Ich habe auch meinen Browsercache gelöscht, aber kann das Problem nicht reproduzieren. Ich habe bereits den Shopcache gelöscht und auch testweise komplett ausgestellt aber der "Fehler" bleibt bei einigen Kollegen bestehen. Komischerweise funktioniert es auf den Unterseiten, nur eben auf der Startseite kommt ein Download. Zu erwarten das jeder seinen Shopcache selber löscht kann ich nicht, denn sollten auch Kunden dieses Problem haben, wird es schwierig denen das mitzuteilen.

Hat jemand vielleicht eine Idee, wo man hier ansetzen könnte? Einen letzten Ansatz habe ich noch, es gibt einige modifzierte Dateien, die inhaltlich aber identisch sind. Könnte es daran liegen? Ich werde es nebenbei noch probieren alle erneut hochzuladen, sollte es das auch nicht sein, gehen mir so langsam die Ideen aus.

Vorab besten Dank!

pluto


JTL Shop 4.0.6.16
PHP 7.3.20
Maximale PHP Ausführungszeit: 180
PHP-Speicherlimit: 256M
Maximale PHP Übertragungsgröße (FILE): 128M
Maximale PHP Übertragungsgröße (POST): 128M
allow_url_fopen aktiviert: ja
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.164
296
Hi,

ich kann mich an so einen Vorfall vor Jahren erinnern. Ich weiss leider nicht mehr genau was es war, aber... wie hier auch der Serverumzug vermuten lässt... war es ein Serverproblem. Da muss der Hoster ran!
Wenn ich vom damaligen Vorfall noch was wiederfinde, schreibe ich nochmal.
 

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Hi Julian,

wir hosten die Seite auf unserem VPS, wir haben da noch 2-3 weitere JTL Shops bei denen es keine Problem gibt. Die wurden allerdings dort frisch installiert. Es ist zum Verzeifeln, da auch nichts im error log oder sonst wo steht. Ich habe den Shop auch nochmal auf 4.0.6.17 geupdated, leider hat dies keine Abhilfe geschafft.

Komisch finde ich es, dass es bei mir funktioniert und bei anderen nicht. Wenn es am Server liegen würde, müsste es dann nicht jeder dieses Problem haben?
 

Karalanta

Aktives Mitglied
18. April 2020
203
58
Lässt sich evtl. über den Dateinamen der runterzuladenden Datei ein Rückschluss ziehen? Vorallem welcher Typ von Datei? Reproduzieren ist heutzutage mit jeder menge Browserversionen und vorallem Add-Ons und Extensions gar nicht mehr so leicht denke ich. Ich hab zum Beispiel ein Add-On das links in neuen Tabs im Hintergrund öffnet. Wenn ich das mal vergesse hat mich das schon sehr viele nerven gekostet.
 

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Leider überhaupt nicht :( Jedenfalls kann ich daraus keine Rückschlüsse ziehen. Das ist ein Screenshot, den ich erhalten habe, beim Aufruf der Seite kam dann dieser "Download" anstatt die Seite zu laden. Sehr merkwürdig alles.
 

Anhänge

Karalanta

Aktives Mitglied
18. April 2020
203
58
Leider überhaupt nicht :( Jedenfalls kann ich daraus keine Rückschlüsse ziehen. Das ist ein Screenshot, den ich erhalten habe, beim Aufruf der Seite kam dann dieser "Download" anstatt die Seite zu laden. Sehr merkwürdig alles.
Schade war zumindest einen Versuch wert mal nachzufragen.
Natürlich nur sofern möglich könnte aber auch die URL des Shop's helfen, dann könnte man sich selbst ein Bild machen.
 

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Ja, ich bin auch aktuell für jeden Denkanstoß dankbar :)
Also z. B. bei der Seite topsteam.de gibt es das Problem auf der Startseite, alles andere scheint zu funktionieren. Ich habe schon alle möglichen Browser getestet, Plugins/adblocker etc. deaktiviert, auch mit dem TOR Browser - keine Chance. Ich bekomme diesen Download nicht. Ich könnte mir maximal noch vorstellen, dass etwas durch den Umzug noch bei gewissen clients im cache hängengeblieben ist - das wäre jedefalls das einzige was irgendwie halbwegs Sinn ergeben würde.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.164
296
Teste mal folgendes:

1. php-version ändern (falls Plugins mitspielen)
2. Prüfe sowohl in der .htaccess vom Shop ob diese dem Standard entspricht oder da evtl. serverspezifische Änderungen vom alten oder neuen Server drin sind; als auch in ggf. übergeordneten Verzeichnissen, ob da .htaccess-Dateien existieren, ggf. mit Inhalt Keyword: "AddHandler"; wenn ja, benenn die bitte testweise mal um
3. In jedem Fall den Hoster weiter bemühen
 

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Guten Morgen, also der Shop wurde im Wartungsmodus umgezogen. DNS dürfte mittlerweile auch durch sein.

Ich habe den handler in der htaccess hinzugefügt (im root folder)
<FilesMatch \.php$>
SetHandler application/x-httpd-php
</FilesMatch>

Seitdem bekomme ich auch das Problem, hab es erst mal wieder entfernt ;)

Die PHP Version habe ich testweise mal auf 7.2 umgestellt, mein Chef bekommt weiterhin den Download.
Ich hatte gestern auch noch ein Ticket über das Kundencenter abgeschickt, Herr Schruff vom Support schrieb, er hätte das Problem nicht und meinte auch, es wäre ein Serverseitiges Problem.
Die .htaccess ist ganz normal, es wurden von unserer Seite aus keine Änderungen vorgenommen.

Ich versuche mal mein Glück beim Hoster. Da es sich um einen unmanaged VPS handelt, befürchte ich, dass es hierzu keinen Support geben wird.
 
  • Gefällt mir
Reaktionen: JulianG

Karalanta

Aktives Mitglied
18. April 2020
203
58
Hallo ich möchte mich auch nochmal melden. Ich hab auch sehr viele mir mögliche Konstellationen durchgespielt und in keiner bekam ich den besagten Download. Interessant ist halt das es ja wohl nur unter Chrome auftaucht. Da müsste man nun wirklich mal dort ansetzen und schauen, ist die Version aktuell, irgendein Downloadmanager der auf irgendetwas triggert. Selbst Google spuckt zu dem Thema nicht sonderlich viel aus. Tut mir leid, da müssen wohl wirklich Experten ran.
 
  • Gefällt mir
Reaktionen: JulianG

Karalanta

Aktives Mitglied
18. April 2020
203
58
Danke dir :) Mit solch einem Problem hatte ich bisher auch noch nicht zu tun.
Nicht dafür, ich finde sowas macht ein Forum aus... Viele Augen sehen meist mehr wie wenn man teils schon Betriebsblind an eine Sache geht. Auch wenn man nicht immer Helfen kann. Wenn ihr die Ursache finden solltet wäre super wenn das mitteilen würdest. Technisch ein echt interessantes Problem.
 
  • Gefällt mir
Reaktionen: JulianG
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Servicepartner/Freelancer gesucht! Ordnung auf dem Webspace herstellen! Änderunden in ein Childtemplate exportieren! Dienstleistung, Jobs und Ähnliches 1
In Bearbeitung CSV Ein Fehler in der Kopfzeile JTL-POS - Fehler und Bugs 2
Neu Merkmalwerte gezielt entfernen, wenn mehr als ein Merkmalwert vorhanden (eBay Problem xxx darf nur einen Wert haben) User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung [Error][Code:21916274] Erfordert Bestandseinheit-Unterstützung, wenn ein Artikel, der bereits über eine Bestandseinheit verwaltet wird, bearbeitet ode eBay-Anbindung - Fehler und Bugs 2
Neu Artikelsuche Leerzeichen und verschiedene Worte durch ein Sonderzeichen ersetzen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Onepage Composer Mehrere Übersetzungsseiten aufwendig, "ein Klick" Erstellung möglich? Templates für JTL-Shop 0
Neu Fehler beim Ausliefern von Aufträgen - Ein ungültiger Längenparameter wurde an die LEFT- oder SUBSTRING-Funktion.... V1.5.38.1 JTL-Wawi - Fehler und Bugs 9
Neu Benötige ein Online Designer Plugin Dienstleistung, Jobs und Ähnliches 11
Neu Eigene Felder ein/ausblenden WooCommerce-Connector 0
Neu wie kann ich ein Eintrag im Footer einfügen Allgemeine Fragen zu JTL-Shop 1
Neu ist ein auslesen tatsächliche Versandkosten über die Ameise möglich Arbeitsabläufe in JTL-Wawi 3
Verwiesen an Support Zahlungsabgleich - Ein Horrofilm mit täglichen Episoden JTL-Wawi - Fehler und Bugs 13
Neu Kann Auftrag nicht stornieren, da schon ein Lieferschein existiert... User helfen Usern - Fragen zu JTL-Wawi 3
In Bearbeitung Wird es ein eBay NOVA-Template geben? eBay-Designvorlagen - Ideen, Lob und Kritik 3
Neu Leider kommt es wieder ein mal zu Problemen beim Abgleich nach der USt Änderung PrestaShop-Connector 2
Neu Hilfe - Ich habe wohl ein inkompatibles Plugin erwischt und nun? JTL-Wawi - Fehler und Bugs 5
Neu Hallo habe gerade ein One Page Analyse über meinen Shop laufen lassen. Allgemeine Fragen zu JTL-Shop 1
Verwiesen an Support DHL Warenpost Fehlermeldung "Bitte geben Sie eine ganze Zahl ein" JTL-ShippingLabels - Fehler und Bugs 1
Neu ein Mandant, zwei Firmen, gemeinsame Lagerverwaltung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Warenbestand pflegen – mehrere Artikel, ein Produkt, ist das möglich? Allgemeine Fragen zu JTL-Shop 6
Neu wo Downloade ich ein Bugfix für JTL Shop 5 ? Installation / Updates von JTL-Shop 2
Neu Wann gilt ein Artikel als Verkauft für JTL Arbeitsabläufe in JTL-Wawi 0
Gelöst Ein Amazon FBA Produkt mehreren ASINs zuordnen Amazon-Anbindung - Ideen, Lob und Kritik 1
Abgelehnt Auftrag nicht vollständig! Woran erkennt der Verpacker, ob die Teillieferung erlaubt ist oder nur ein Fehlbestand existierte? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 8
Neu Pro Artikel ein Versandlabel erstellen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Spalte kBesucher in tbesucher nicht vorhanden - ist das ein Problem JTL-Shop - Fehler und Bugs 3
Neu Wie kann ich ein Massenupdaten oder per Ameise bei ebay den Haken für die "Umsatzsteuer senden" ändern? User helfen Usern - Fragen zu JTL-Wawi 5
Neu JTL WAWI Version 1.5.13.1 nicht zum Download bereit gestellt Installation von JTL-Wawi 2
In Bearbeitung CustomerDisplay APK zum Download Allgemeine Fragen zu JTL-POS 1
Neu JTL 5 - Es wird nur eine Mediendatei angezeigt JTL-Shop - Fehler und Bugs 2
Neu Bon Mail: von $header$ wird nur die erste Zeile ausgegeben JTL-POS - Fehler und Bugs 0
Neu Sendungsnummer wird nicht in Paypal hinzugefügt Allgemeine Fragen zu JTL-Shop 0
Neu WAWI 1.5.40.0: Paket-Status wird nicht abgerufen JTL-Track&Trace - Fehler und Bugs 0
Neu kundenrabatt wird nicht übernommen JTL-Shop - Fehler und Bugs 0
Neu Countdown OPC wird auf Smartphone nicht richtig angezeigt. JTL-Shop - Fehler und Bugs 0
Neu Workflow - Versendet wird 2x ausgeführt User helfen Usern - Fragen zu JTL-Wawi 1
Neu Auftragsimport wird nicht ausgeführt bei fehlender Kundennummer Schnittstellen Import / Export 0
Offen teilbarer Artikel wird bei Reservierung von anderem Lagerplatz als ganzer Artikel reserviert Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 5
Neu Amazon Rechnung wird nicht mehr versendet User helfen Usern - Fragen zu JTL-Wawi 0
Neu Versandart ps_wirepayment wird immer wieder an WaWi übertragen PrestaShop-Connector 1
Neu Sonderpreis an PrestaShop wird unvollständig übertragen PrestaShop-Connector 0
Neu erstellte Kategorie wird im Shop nicht angezeigt JTL-Wawi - Fehler und Bugs 2
Gelöst NOVA Child (default) wird falsch dargestellt Einrichtung JTL-Shop5 1
Neu Falsche Zahlungsart wird übertragen seit Update WooCommerce-Connector 1
Neu Rechnungen wird bei einem Artikel auf zwei Seiten gedruckt statt auf einer JTL-Wawi - Fehler und Bugs 0
Neu Versandbenachrichtigung wird doppelt versandt JTL-Wawi - Fehler und Bugs 1
Neu SHOP5: Composer / Produktseite / Inhalt zwischen Preis und langer Beschreibung wird am Handy nicht angezeigt JTL-Shop - Fehler und Bugs 2
Neu Datenbank kann nicht geöffnet werden. Sie wird zurzeit wiederhergestellt. Installation von JTL-Wawi 0
Bild/Link wird unter eigene Seiten nicht angezeigt Einrichtung JTL-Shop5 1
Neu Abschaltung easylog wo wird der Ausdruck konfiguriert User helfen Usern - Fragen zu JTL-Wawi 0
Ähnliche Themen