E-Mail-Versand nicht möglich, obwohl der Test fehlerfrei verlief?

Kompromittiert

Aktives Mitglied
2. Januar 2021
29
3
Hallo,

ich habe zum ersten Mal einen JTL 5 Shop eingerichtet, daher wird der Fehler wohl bei mir liegen, jedoch kann ich den Fehler nach Abgleich mit dem JTL Guide nicht finden. Der Test bei der Einrichtung sieht gut aus. Zumindest funktioniert dort die Anmeldung mit den Zugangsdaten, der Versand einer Test-E-Mail wird leider nicht getestet. Daher habe ich zum testen dann mal die Passwort-Vergessen-Funktion im Frontend missbraucht. Leider kam keine E-Mail an und es taucht eine neue Fehlermeldung im Logbuch des Shops auf.

Output des Tests, während der Konfiguration:
Code:
2023-11-04 20:11:27    Connection: opening XXXXXX:587, timeout=30, options=array()
2023-11-04 20:11:27    Connection: opened
2023-11-04 20:11:27    SERVER -> CLIENT: 220 XXXXXX ESMTP
2023-11-04 20:11:27    CLIENT -> SERVER: EHLO XXXXXX
2023-11-04 20:11:27    SERVER -> CLIENT: 250-XXXXXX
                                         250-PIPELINING
                                         250-SIZE 10240000
                                         250-ETRN
                                         250-STARTTLS
                                         250-ENHANCEDSTATUSCODES
                                         250-8BITMIME
                                         250-DSN
                                         250-SMTPUTF8
                                         250 CHUNKING
2023-11-04 20:11:27    CLIENT -> SERVER: STARTTLS
2023-11-04 20:11:27    SERVER -> CLIENT: 220 2.0.0 Ready to start TLS
2023-11-04 20:11:27    CLIENT -> SERVER: EHLO XXXXXX
2023-11-04 20:11:27    SERVER -> CLIENT: 250-XXXXXX
                                         250-PIPELINING
                                         250-SIZE 10240000
                                         250-ETRN
                                         250-AUTH PLAIN LOGIN
                                         250-AUTH=PLAIN LOGIN
                                         250-ENHANCEDSTATUSCODES
                                         250-8BITMIME
                                         250-DSN
                                         250-SMTPUTF8
                                         250 CHUNKING
2023-11-04 20:11:27    CLIENT -> SERVER: AUTH LOGIN
2023-11-04 20:11:27    SERVER -> CLIENT: 334 VXNlcm5hbWU6
2023-11-04 20:11:27    CLIENT -> SERVER: [credentials hidden]
2023-11-04 20:11:27    SERVER -> CLIENT: 334 UGFzc3dvcmQ6
2023-11-04 20:11:27    CLIENT -> SERVER: [credentials hidden]
2023-11-04 20:11:27    SERVER -> CLIENT: 235 2.7.0 Authentication successful
Connected ok!2023-11-04 20:11:27    CLIENT -> SERVER: QUIT
2023-11-04 20:11:27    SERVER -> CLIENT: 221 2.0.0 Bye
2023-11-04 20:11:27    Connection: closed

Fehlermeldung im Logbuch:
Error sending mail: Verbindung zum SMTP-Server fehlgeschlagen. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Die Fehlermeldung klingt für mich eher nach einem Layer 3 Problem, dabei ging der Verbindungsaufbau zum E-Mail-Server beim testen wunderbar.

Jemand eine Idee, wo das Problem sein könnte?

p.s. Shop-Version: 5.2.3
PHP: 8.1.25
 

phönix

Gut bekanntes Mitglied
26. Juli 2010
164
3
Schweiz
Hallo,
gab es hier eine Lösung? Ich habe seit 2 Tagen das gleiche Problem. Bis dahin lief der Mailversand mit Port 465, SSL ohne Probleme. Ohne dass ich etwas geändert hätte, seit 2 Tagen plötzlich nicht mehr.
Ich habe nun den Port auf 587, TLS geändert.
Der Konfigurationstest läuft durch, aber Testmails kann ich keine Versenden. Der Fehlerlog ist voll mit der oben gezeigten Fehlermeldung.
Falls es eine Lösung gab, wäre ich dankbar, die zu erfahren!
 

MrS

Neues Mitglied
23. Dezember 2023
19
0
Hallo,

das Problem hatte ich auch. Ich habe mit den Einstellungen TLS/SSL und den Ports 465/587 in verschiedenen Varianten probiert. Der Test lief immer durch aber nicht immer wurden Mails verschickt. Für mich hat TLS und 587 funktioniert. Vielleicht mal SSL mit 465 probieren.

Ergänzung:
Als es bei mir nicht funktioniert hat, waren keine Meldungen im Log zu finden. Es kam einfach keine Mail. Ich habe bei der Versandmethode nicht PHPmail() sondern SMTP ausgewählt

LG
Stephen
 

phönix

Gut bekanntes Mitglied
26. Juli 2010
164
3
Schweiz
Lag am Postfinance Checkout Plugin. Es hat dann den ganzen Shop lahm gelegt. Nachdem ich es deaktiviert hatte, ging der Shop wieder und die Mails kamen plötzlich. Nach Aktivierung des Plugins läuft jetzt immer noch alles.
2 Tage Suche wegen so einem halbfertigen Programm!
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Mail-Versand & Plugin Doku Technische Fragen zu Plugins und Templates 2
Nur noch sporadischer Versand per Mail von Rechnungen, Lieferscheinen und Mahnungen nach Update auf Version 1.8. JTL-Wawi 1.8 0
Neu E-Mail Versand in JTL - Absender ändern User helfen Usern 2
Neu PHP mail() Versand Betrieb / Pflege von JTL-Shop 7
Wie kann ich eine Benachrichtigung bei einem Wareneingang auslösen mit einer Mail über die Artikel die eingebucht wurden JTL-Wawi 1.8 2
Neu WF Mail wenn Amazon Artikel nicht verknüpft ist JTL-Workflows - Ideen, Lob und Kritik 0
Neu E-Mail mit Strato - Fehler normal? Betrieb / Pflege von JTL-Shop 0
Neu E-Mail Vorlagen erweitern: Neue Vorlage à la Header, bzw. Sprachvariable nutzen? Templates für JTL-Shop 3
Ausgabe per E-Mail geht plötzlich nicht mehr, Testmail aus Wawi aber schon JTL-Wawi 1.6 22
Neu E-Mail Versandbenachrichtigung aus JTL Wawi 1.8.10.0 wird doppelt versendet User helfen Usern 0
Neu E-Mail Benachrichtigung, wenn Artikel einen bestimmten Lagerbestand unterschreitet User helfen Usern - Fragen zu JTL-Wawi 0
Neu Plugin Mail senden - Cc / Bcc Technische Fragen zu Plugins und Templates 4
Neu SMTP Mail einrichten JTL-Shop 5 User helfen Usern - Fragen zu JTL-Wawi 4
Neu Formatierung der E-Mail Bestätigung User helfen Usern - Fragen zu JTL-Wawi 2
Firmen- und E-Mail Einstellungen: Wie einrichten, wenn Firmenname (Impressum) anders ist als Shopname/Marke? JTL-Wawi 1.8 0
Neu Bestellbestätigung E-Mail Überweisungsbetrag falsch JTL-Shop - Fehler und Bugs 4
WaWi 1.8.9.1 Rechnung mail Fehler JTL-Wawi 1.8 0
Inhalt von "Eigenem Feld" in E-Mail Template übernehmen?! JTL-Wawi 1.7 2
Neu Suche dringend die "englischen Variablen" für position.bild und position.ArtikelbeschreibungKurz (Mail-Vorlage Template JTL) Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Finde Lieferschein Vorlage (E-Mail) nicht ! - GELÖST JTL-Wawi 1.6 0
Neu Schweiz: Die Gewichtsangabe ist kleiner als im CN23-Formular > kein Versand möglich JTL-ShippingLabels - Fehler und Bugs 13
Neu Nach Update von 1.5 auf 1.8 Versand in die Schweiz nicht mehr möglich JTL-ShippingLabels - Fehler und Bugs 2
Neu ebay Versanddatum / Versandfrist "Versand bis..." in die Wawi holen, um Aufträge zu priorisieren eBay-Anbindung - Ideen, Lob und Kritik 0
Auftragspositionen - Erfolgter Versand Artikel - Teilieferung Welche Tabelle JTL-Wawi 1.7 2
Versand Großbritannien JTL-Wawi 1.7 1
JTL-WaWi eBay Angebotsvorlage Versand/Zahlung fehlerhaft JTL-Wawi 1.8 0
V1.8.11: "Versand" / "Lieferscheine versendet" - Wo ist das Suchfeld für Sendungsnummer geblieben? JTL-Wawi 1.8 2
Versand: Paketmenge pro Mitarbeiter am Tag - pro Monat - pro Jahr JTL-Wawi 1.8 0
Neu DHL Internationaler Versand JTL-ShippingLabels - Fehler und Bugs 7
Neu Amazon Versand kostenlos oder extra ausgewiesen Smalltalk 4
Neu Artikelmengen zusammengefasst von Versand-Aufträge-Lieferbar JTL Ameise - Eigene Exporte 0
Auftrag ohne Versand abschließen -> wieder rückgängig geht nicht JTL-Wawi 1.8 1
Neu Email Versand über OAuth JTL-Wawi - Ideen, Lob und Kritik 2
JTL-WMS und JTL-Packtisch+ Es können nun einzelne Artikel im Versand gewogen werden Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Versand mit DPD / Retoure GLS Otto.de - Anbindung (SCX) 0
Neu Rechnungsempfänger im EU-Ausland und Versand nach DE - Anwendung Mwst JTL-Wawi 1.7 1
Neu Ebay International kostenloser Versand, Preise je Land Einrichtung und Installation von JTL-eazyAuction 0
Neu Wird der Status (Versand und Abgeschlossen) nicht an Woocommerce übermittelt? Modified eCommerce-Connector 0
Neu 1 Versand Lager 3 Nachschub Läger Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu Kaufland Carriercode Fehler- Rechnung wird übertragen - Versand nicht kaufland.de - Anbindung (SCX) 1
Neu Hardware Empfehlung Drucker Versand Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Bestellung nicht auf Versand gesetzt JTL-Shop - Fehler und Bugs 0
Neu Sendungsnummern / Versandetiketten schon vor dem Versand generieren? Arbeitsabläufe in JTL-Wawi 0
Neu Jugendschutzgesetz - Versand von Alkohol User helfen Usern 1
Gelöst Versand: Anzahl Pakete pro Mitarbeiter und Zeitraum Eigene Übersichten in der JTL-Wawi 1
Auftrag splitten in Dropshipping-Artikel und "Eigener Versand"-Artikel JTL-Wawi 1.8 1
Nur noch sporadische Rechungserstellung nach Versand JTL-Wawi 1.8 26
Neu Kein DPD Versand/Abholung am 27.12 deutschlandweit - Wie vorgehen bei Amazon ? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shop nicht mehr erreichbar HTTP 500 Error Betrieb / Pflege von JTL-Shop 0
Artikel wurden über Weclapp über FFN-Connect an JTL FFN übermittelt jedoch leider nicht an Wawi & WMS JTL-Wawi 1.8 0

Ähnliche Themen