Neu DHL Versenden trotz Fehler landet Auftrag unter "Versendet"

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
8. Januar 2018
16
1
#1
Hallo liebe Forenmitglieder,

wir haben seit einigen Wochen vereinzelt das Problem, dass teilweise DHL Labels aufgrund des unten aufgeführten Fehlers nicht gedruckt werden, aber unter Versand -> Lieferscheine -> Versendet landen.
Das ärgerliche ist wir arbeiten viel mit Workflows und die waren so konfiguriert, dass es bei einem Fehler abgebrochen wird. Die Rechnungen wurden natürlich nach dem Ausliefern ausgedruckt. So sind einige Fehler gar nicht erst rechtzeitig aufgefallen und der Kunde hat ewig auf seine Sendung gewartet. Das haben wir mittlerweile umgestellt, sodass die Rechnung auf jeden Fall ausgedruckt wird.

Ich vermute, dass es sich um einen Bug handelt, oder das Handling für bestimmte Fehler vergessen wurde.

Unsere Aufstellung:
JTL- Wawi: Version 1.4.30.2
Server: Windows Server 2012 R2
Clients: Windows 7

Fehlermeldung:
---------------------------------------------------------------------------------------------------
07.08.2019 19:40:15
Originalmeldung
Meldung: Export mit Versandart "Versand (DHL Paket)"
Typ: Unknown
Source: JTLWawi
---------------------------------------------------------------------------------------------------
07.08.2019 19:40:16
Originalmeldung
Meldung: Der Remoteserver hat eine unerwartete Antwort zurückgegeben: (502) Bad Gateway.
Typ: Error
Source: JTLWawi
---------------------------------------------------------------------------------------------------


Habt Ihr so etwas auch schon gehabt?
 

Uwe Jaksties

Sehr aktives Mitglied
13. Mai 2014
569
107
#2
Hallo,

also das wäre mir neu, dass JTL- Shipping den Versand setzt, wenn der Versanddatenexport nicht erfolgreich war.
Die Ursache liegt so ziemlich ausnahmslos immer daran, dass an irgendeiner Stelle der Haken bei "Versanddatum setzen" gesetzt ist.
 
Zustimmungen: netgmbh
8. Januar 2018
16
1
#3
Hallo vielen Dank für den Beitrag,

sprich würde man den Haken bei "Versanddatum setzen" weglassen, dann würde der Versand nur bei erfolgreichem Versand gesetzt werden?
Oder führt das dazu, dass in keinem Fall ein Versand gesetzt wird?

NACHTRAG:
Es ist ja nicht so, dass garnichts in "Offen" oder "Fehlerhaft" landet. Das tuen einige Lieferscheine in der Tat. Beispielsweise fehlende Hausnummer, falscher Ort, nicht leitcodierbarkeit, usw.
Lediglich wenn kein Request Code zurück gegeben wird, wird der Versand trotz Fehler gesetzt
 
Zuletzt bearbeitet:

Uwe Jaksties

Sehr aktives Mitglied
13. Mai 2014
569
107
#4
sprich würde man den Haken bei "Versanddatum setzen" weglassen, dann würde der Versand nur bei erfolgreichem Versand gesetzt werden?
Korrekt!
Oder führt das dazu, dass in keinem Fall ein Versand gesetzt wird?
Nein.
NACHTRAG:
Es ist ja nicht so, dass garnichts in "Offen" oder "Fehlerhaft" landet. Das tuen einige Lieferscheine in der Tat. Beispielsweise fehlende Hausnummer, falscher Ort, nicht leitcodierbarkeit, usw.
Lediglich wenn kein Request Code zurück gegeben wird, wird der Versand trotz Fehler gesetzt
Ich kann natürlich nicht ausschließen, dass in diesem besonderen Fall ein Bug vorliegt, aber das habe ich in der Form zumindest noch nicht erlebt.
Es ist auch manchmal schwierig nachvollziehbar, vor allem wenn mehrere Personen den Versand durchführen. Jeder User kann die Häkchen anders gespeichert haben, wodurch nicht immer gleich ersichtlich ist, wo der Hund begraben ist.
 
Zustimmungen: Jan Weber und netgmbh