Neu Bestände werden nur noch nach Löschen des Cache richtig angezeigt!

Rayblaster

Sehr aktives Mitglied
31. Juli 2015
350
32
Hallo,
wir haben immer wieder das Problem, dass die in der WaWi aktualisierten Bestände nicht richtig im Shop 4.05 (Build: 6) angezeigt werden.
Wenn z.B. ein Artikel auf Bestand 0 gesetzt wird (keine Überverkäufe möglich) und danach der Shopabgleich durchgeführt wird (ganz egal ob im Komplettabgleich "Bestände" aktiviert ist), erscheinen die Artikel immer noch als "grün" sofort lieferbar!
Immer erst wenn wir den Cache im Backend löschen, werden die Bestände richtig dargestellt. Das kann doch nicht sein dass man immer erst den Cache leeren muss!
 

Rektor

Sehr aktives Mitglied
22. November 2011
411
92
Versuch mal eine andere Cache-Methode, wie etwa Redis, dann sollte nach Shopabgleich alles sofort sichtbar sein. Hatten das gleiche Problem mit Artikel bzw. Änderungen, welche bei der Cache-Methode "beste" erst Stunden später sichbar waren, auch bei Shopversion 4.06 (Build 17), wenn nicht der Cache manuell geleert wurde. Redis müsste meistens allerdings vom Hoster freigeschaltet werden.
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.361
778
Hallo, 4.05.6 ist mittlerweile 3 Jahre alt! Hier würde ich erstmal empfehlen auf eine aktuelle Version upzugraden!
Bei der Entwicklungs und Realisierungszeit von Shop 5 ist so eine Aussage schon ein wenig Hohn... :D

Du brauchst nicht auf die B17 oder so updaten (abgesehen von einem security patch, den kannst selbst einspielen).
Wir haben auch die B5...


liegt vermutlich eher an deiner Cache Methode, was verwendest denn?
 
Zuletzt bearbeitet:

Rayblaster

Sehr aktives Mitglied
31. Juli 2015
350
32
Vielen Dank für die Antworten.
Zum Thema Update! Eigentlich wollte ich dann lieber gleich auf Version 5 updaten und der war ja schon vor zwei Jahren angekündigt😂. Nun nach ein bisschen Verspätung endlich da!
Da ich nun nicht noch ein Zwischenupdate mache (wer weiß ob durch ein Update das Problem behoben ist) warte ich noch bis auch die PlugIn´s für Vers. 5 verfügbar sind.
Ich nutze als Cache Methode "Dateien"
 

Rayblaster

Sehr aktives Mitglied
31. Juli 2015
350
32
Ich nutze das Webhosting von All-Inkl und habe hier gelesen dass Redis nur für Serverpakete freigeschaltet wird.
Dann bleibt wohl nur die Variante Dateien (erweitert)
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Ameise Preise / Bestände QuickSync Artikel arbeitet angeblich nicht mit Lagerbestand User helfen Usern - Fragen zu JTL-Wawi 1
Neu FBA Bestände lassen sich nicht von WaWi Artikel entfernen Amazon-Anbindung - Fehler und Bugs 0
Neu Amazon bestände mit Dropshipping artikel + Lagerartikel (Stückliste) Onlineshop-Anbindung 0
Neu Kommentare aus Artikel Bestände auf Liste Drucken User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Bestände in WMS zurücksetzen Installation von JTL-WMS / JTL-Packtisch+ 1
Neu Keine Artikeldaten an Shopware übermitteln? Nur Bestellungen und Bestände Shopware-Connector 0
Neu Bestände Reservieren User helfen Usern - Fragen zu JTL-Wawi 3
Neu WORM_ERROR_AUT HENTICATION_PIN_BLOCKED - Beleg konnte nicht signiert werden. JTL-POS - Fehler und Bugs 0
Neu Artikel werden nicht auf eBay entfernt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 Bilder werden nicht aktualisiert bzw. falsche zugeordnet Shopware-Connector 0
Neu Lister gibt Daten falsch nach Amazon, Nakommaproblem und werden nicht gelistet Amazon-Lister - Fehler und Bugs 0
Neu Lieferscheine werden nicht gedruckt bei Auslieferung User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung "JTL-POS muss beendet werden!" JTL-POS - Fehler und Bugs 2
Neu Kundengruppen werden vom Connector nicht mehr in die Wawi übertragen JTL-Wawi - Fehler und Bugs 0
Neu Kategorie Metadaten werden nicht übertragen WooCommerce-Connector 0
Neu Wawi 1.6 Freipositionen mit Menge 0 werden nicht mehr in der Rechnung ausgegeben JTL-Wawi - Fehler und Bugs 0
Beantwortet WAWI 1.6.32.0 Rechnungsänderungen werden in der Rechnung nicht übernommen JTL-Wawi - Fehler und Bugs 23
Neu Editierte OPC inhalte werden nicht angezeigt Installation / Updates von JTL-Shop 1
Neu Plugin Migrations werden beim deinstallieren nicht zurück gesetzt JTL-Shop - Fehler und Bugs 0
Neu FBA Aufträge werden mehrfach erstellt. Amazon-Anbindung - Fehler und Bugs 2
Neu Maßeinheiten / Verkaufseinheiten werden übertragen aber nicht am Produkt hinterlegt Modified eCommerce-Connector 0
Gelöst Im Warenkorb werden "alle" Versandarten angezeigt und auswählbar Einrichtung JTL-Shop5 1
Neu WAWI 1.6.32.0 Das Feld "Anmerkung" un Aufträgen kann bei VCS Bestellungen nicht mehr genutzt werden User helfen Usern - Fragen zu JTL-Wawi 2
Neu Kasse druckt Bon + Lieferschein, Lieferschein soll nicht an dem Bondrucker ausgegeben werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Willkürlich werden keine Rechnungen mehr gedruckt Arbeitsabläufe in JTL-Wawi 1
Neu Preise werden nicht angeglichen Shopware-Connector 0
Neu Einzelne Produkte in der Wawi können nicht bearbeitet werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu EU-Steuereinstellungen für Lieferschwelle werden bei Produkten nach Abgleich in Gambio wieder zurück gesetzt. Gambio-Connector 0
Neu JTL Shop 5 Filter werden im Inhaltsbereich nicht angezeigt Allgemeine Fragen zu JTL-Shop 2
In Bearbeitung Hersteller werden nicht angezeigt WooCommerce-Connector 1
Neu Werden Stornierungen in WaWi übertragen? Allgemeine Fragen zu JTL-Shop 6
Neu Vorlagen werden bearbeitet nicht angezeigt!? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Lieferzeiten werden nicht mehr angezeigt (German Market) WooCommerce-Connector 0
Neu WaWi 1.6.31.2 - Aufträge können nicht gespeichert werden da er Schreingeschützt ist JTL-Wawi - Fehler und Bugs 2
Neu Fehler bei der Auftragserstellung: Für die aktuelle Transaktion kann kein Commit ausgeführt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Amazon-Gutschriften werden nicht mehr eingelesen Amazon-Anbindung - Fehler und Bugs 1
Neu Artikel in Konfigurationsgruppen werden nicht ausgeliefert JTL-Wawi - Fehler und Bugs 0
Neu Kinderartikel werden nicht Angezeigt unter Vaterartikel Onlineshop-Anbindung 0
Neu Bilder aus Auktionsvorlage werden willkürlich nicht übertragen eBay-Anbindung - Fehler und Bugs 15
Neu Kundengruppen werden nicht an JTL Shop übermittelt JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Standarteinstellungen Drucker werden nicht übernommen JTL-POS - Fehler und Bugs 5
Neu Merkmale - Eingaben beim HTML-Editor werden nicht gespeichert - übernommen JTL-Wawi - Fehler und Bugs 2
Neu Meldung: Der Nutzer des Webservice konnte nicht authentifiziert werden. JTL-ShippingLabels - Fehler und Bugs 2
Neu Kundengruppen Preise werden über JTL Ameise / Import nicht übernommen Schnittstellen Import / Export 0
Neu Sonderpreise werden gelöscht Gambio-Connector 7
Neu Änderungen werden nicht übernommen? JTL-Wawi - Fehler und Bugs 1
Neu Gratisgeschenk Versandklasse wird nicht berücksichtigt, daher Warenbrief-Porto berechnet obwohl Paket berechnet werden müsste Betrieb / Pflege von JTL-Shop 0
Neu WMS - Pickliste → Artikel soll von 2 verschiedenen Lagerplätzen genommen werden, obwohl der Bestand auf dem ersten Lagerplatz ausreicht User helfen Usern - Fragen zu JTL-Wawi 4
Neu Individuelle Metafelder für Quadratmeter Funktion werden nicht korrekt verknüpft Shopify-Connector 5
Verwiesen an Support Kann es sein, dass einige Workflows zwar verarbeitet werden, diese dann aber final nicht gesetzt werden? JTL-Workflows - Fehler und Bugs 1

Ähnliche Themen