Offen Artikel lässt sich nicht löschen

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.075
521
Hier sind die betroffenen Artikel ohne Kategorie.
Folgende Vorgehensweisen sind möglich:
A) Das Problem ist nicht sehr gravierend. Mit der 1.6 kommt im Datenbanktool eine Reparaturmöglichkeit für solche Artikel. Dann das Thema bis dahin ignorieren und dann fixen.
B) Das Problem ist schon sehr störend: Dann exportier Dir die betreffenden Artikel mit der JTL-Ameise und importiere sie wieder, nachdem Du eine Spalte mit einem Kategorienamen befüllt hast. Stell die Einstellung "Aktualisierung von Kategorien" auf "Vorhandene vorher löschen.
Nach dem Import kannst Du dann die Artikel löschen.
 
  • Gefällt mir
Reaktionen: Rico Giesler

John

Sehr aktives Mitglied
3. März 2012
1.128
37
...das Problem mit der fehlenden Kategorie kann man auch ohne Ameise lösen. Falls an darin nicht so fit ist.

Dazu einen Auftrag erstellen und den Artikel anhand der Artikelnummer direkt hinzufügen.
Den Auftrag speichern.
In der Auftragsübersicht den Auftrag anwählen. Unten in der Positionsliste wird der enthalte Problemartikel angezeigt.
Rechtsklick auf den Artikel > Öffnen.
Der artikel öffnet sich. Ihm eine Kategorie zuweisen und er ist "repariert"
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.075
521
Damit hast du aber Aufträge in der Wawi, die du nie brauchst bzw. die du dann im Zweifelsfall auch noch stornieren musst. Wenn es zu diesem Artikel bereits einen Auftrag gibt, dann wäre ich bei Dir, dann kann man diesen Weg gehen.
Allerdings auch nur, wenn das wirklich gaaaaaaaaaanz vereinzelt auftritt.
Wer auf Nummer sicher gehen möchte wählt den Weg über die Ameise. Da sieht man gleich alle Artikel, die keine Kategoriezuordnung haben und kann sie sicher alle auf einmal reparieren.
 

CHESSBASE

Mitglied
28. Februar 2020
42
3
Hallo!
Habe auch so ein Problem. Kann einen angeblich vorhandenen Artikel nicht löschen.
Mit Export wurde der Artikel in der Datei angezeigt. Nach dem Import aber das gleiche Problem.
Rechts Maustaste auf den Artikel klicken zeigt 0 Artikel an.
Wie werde ich den nun erst mal los?
Gruß
CHESSBASE
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.075
521
Es liegt die Vermutung nahe, dass du zwar den Import mit der Ameise durchgeführt hast und nun entweder keine Kategorie in der CSV benannt hattest (das ist zwingend notwendig!) oder du hast die Einstellung "Aktualisierung von Kategorien" auf "Vorhandene vorher löschen nicht umgestellt.
Wenn du bei beidem absolut sicher bist, dann mach bitte ein Supportticket auf, damit sich die Kollegen das ansehen können.
 
Zuletzt bearbeitet:

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.075
521
Bitte nicht Themen hier wiederholen. Lass das Thema dort, wo es ist - im Idealfall im Modified- Shop-Bereich. Da kann Dir am ehesten geholfen werden.