Gelöst Artikel-Abgleich nicht möglich

ekoprint

Mitglied
4. September 2018
4
0
Hallo Community,
ich komme leider nicht weiter.
https://presta.flyerondo.de/neue-artikel wurde als Test angelegt. Anbindung zum WaWi funktioniert.
Kategorien und Artikel werden auch übertragen.
Es gibt aber immer ein Abbruch. Mit der Fehler Meldung
Fehler:
Exception: /xxxx/classes/ObjectModel.php (1000)😀ie Eigenschaft Product->name ist ungültig
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models, Boolean checkForOrderPull)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass6_1.<Run>b__0(List`1 models)
bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
bei JTL.Connector.Business.SyncRunner.Run()

Controller Log zeigt immer gleiche Meldung:
[2018-09-04 22:56:42] controller.WARNING: Exception 'PrestaShopException' (Code: 0) with message 'Die Eigenschaft Product->name ist ungültig' in /xxxx/classes/ObjectModel.php:1000 [] []

Hat jemand ein Lösungsvorschlag?
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Hallo,
es scheint als würde die Wawi die Artikelnamen nicht richtig übertragen. Ich würde dich bitten das Developer_Logging zu aktivieren, erneut einen Abgleich zu starten und mir die dadurch entstandenen Logdateien per PN zukommen zu lassen.
Hier steht beschrieben wie du das Developer_Logging aktivierst: http://jtl-url.de/-kdiq
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Wie aus den Logs ersichtlich ist schlägt hier die Shopvalidierung für Produktnamen fehl. Diese sagt das angeblich alle Produktnamen 130 Zeichen hätten und nur 0-128 zulässig wären.
Hast du die aktuellste Prestashopversion? Wenn nicht könnte vielleicht ein Update helfen.
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Bei einer zweiten Analyse haben wir festgestellt dass du tatsächlich ein Produkt hast das einen Produktnamen von mehr als 130 Zeichen hat: "Manometer-Anschlussschlauch mit 1/4" Schlauchanschluss zur universellen Verwendung mit 3/8" und 5/16" Hochdruckschlauchanschlüssen"
Wie gesagt unterstützt Prestashop nur Produktnamen mit einer Länge von 0-128 Zeichen.
 

Ähnliche Themen