Gelöst Admin-Login nicht mehr möglich wegen Session-Problem

countryhase

Aktives Mitglied
1. August 2013
28
2
Hallo,

ich brauche mal eure Hilfe.

Nach einem Datencrash musste ich den Shop (v3.17) aus der Datensicherung rekonstruieren. Soweit läuft alles wieder ganz gut.

Allerdings kann ich mich jetzt nicht mehr als Admin anmelden. Es kommt folgende Meldung, schon wenn ich die Adminseite nur öffne:

Warning: Unknown: open(/var/lib/php/session/sess_98clc6lvqr0451qo7kg4j238b3, O_RDWR) failed: Permission denied (13) in Unknown on line 0
Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0
Wenn ich den Admin mit den richtigen Werten anmelden will, passiert nichts außer erneut vorstehende^ Fehlermeldung.

Ich habe folgendes untersucht:
  • Rechte des session-Verzeichnisses (/var/lib/php/session): ok, 770
  • Einstellungen der php.ini: ok, session.save_path = /var/lib/php/session
  • angeforderte Session nicht in session-Verzeichnis vorhanden (wohl schon vom gc gelöscht)
  • Cookies auf meinem Rechner: alle gelöscht
  • Tabellen tadminsession und tsession in der DB: beide leer
  • Gegoogelt und im Forum gesucht wie ein Irrer, leider ohne erfolgreiche Tipps

Hängt da vielleicht noch irgendwo ein Wert aus einer wegen des Datencrashs abgebrochenen Session herum?

Ich bin nun völlig ratlos ... und dankbar für jeden Hinweis, der das Problem zu lösen hilft.

LG C.H.
 

countryhase

Aktives Mitglied
1. August 2013
28
2
AW: Admin-Login nicht mehr möglich wegen Session-Problem

Nachtrag:

Ein zweiter JTL-Shop auf dem gleichen Webspace läuft einwandfrei, da taucht dieses Problem nicht auf. Also gehe ich davon aus, dass es nur diesen einen Shop betrifft und das Problem irgendwo dort zu suchen ist.
 

countryhase

Aktives Mitglied
1. August 2013
28
2
AW: Admin-Login nicht mehr möglich wegen Session-Problem

Danke, ist erledigt.
Es hat jemand per PM geholfen.
 

Matchy

Gut bekanntes Mitglied
4. Januar 2011
108
18
Spreewald
Hallo zusammen,

ich hatte bis eben das gleiche Problem. Nach dem Update von JTL Shop 3.17 auf 3.20 war kein Admin-Login im Backend des Shops möglich. Frontend lief, allerdings im Wartungsmodus.

Die Lösung war:

Löschen aller Dateien im Cache-Ordner des Admins.

Also unter: /Shopverzeichnis/admin/templates_c/

Den Ordner templates_c einfach komplett leeren. Dann ging das Login wieder, Wochenende gerettet.

Viele Grüße,
Matze
 

Ähnliche Themen