Gelöst Abgleich von bestehenden Artikeln nicht mehr möglich - Jede Änderung am Artikel erzeugt ein neuer

rusc shop

Aktives Mitglied
26. August 2017
23
2
Hallo
Ich hatte vor einiger Zeit mein Prestashop total zerschossen und musste neu installieren.
Nun habe ich das Problem, dass bei jedem synchro von JTl zu Presta ein neuer Artikel in Presta generiert wird.
Hinzu kommt, dass die neu angelegten Artikel keine Kategorien und keine Bilder haben.
Ein Beispiel:
Ich habe den Artikel 35010449 Ford Cap früher synchronisiert. Nun möchte ich den Titel anpassen (zusätzlich 123 im Artikelname. Dies funktioniert auch, nur leider als neuer Artikel in Presta und nicht der bestehende wird angepasst. Wenn ich den Artikelname zu Ford Cap 456 tauschen möchte überträgt er die Daten aber generiert wieder einen neuen Artikel. Auch wenn ich im Titel die Zahlen wieder löschen und synchronisiere generiert Presta einen neuen Artikel.
Woran liegt das?
Verwendetes System:
JTL 1.3.17.1
PrestaShop-Version 1.7.3.2
connector 1.5.0 (1.7.0 bis 1.7.4.1)

Danke für euer Feedback.
 

Anhänge

  • Unbenannt.JPG
    Unbenannt.JPG
    35,2 KB · Aufrufe: 13

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Hallo rusc shop,
das Problem wird von einer Fehlerhaften Linkingtabelle die noch vom vorherigen Versuch übrig geblieben ist verursacht.
Um das Problem zu lösen muss der Prestashop und der Connector in der Wawi resetet werden.

Die Datenbank des Prestashops sollte komplett gelöscht werden um danach den Prestashop neu zu installieren.

Um den Connector zurückzusetzen gehen Sie in der Wawi wie folgt vor:

1. Klicken Sie oben in der Wawi auf den Tab Onlineshop.
2. Danach wählen Sie im nun offenen Dropdownmenü den Punkt Onlineshop-Anbindung.
3. Nun öffnet sich ein neues Fenster in dem Sie ihren Onlineshop auswählen, danach drücken Sie rechts in der Leiste auf Bearbeiten.
4. Nun drücken Sie in dem neu geöffneten Fenster auf Connector konfigurieren.
5. Es öffnet sich ein neues Fenster mit dem Namen „Shopkonfiguration“. Dieses hat oben unter anderem den Tab „Zurücksetzen/Hilfen“ welches Sie nun anklicken.
6. Drücken Sie hier nun auf "Zurücksetzen".
 

rusc shop

Aktives Mitglied
26. August 2017
23
2
Hallo Benjamin
Soweit hat dies funktioniert - Artikel, Kategorie. Alles so weit da...
Aber nun habe ich wieder Fehler 400 (Der Remoteserver hat einen Fehler zurückgegeben: (400) Ungültige Anforderung. ) sobald ich die Bilder anklicke...
Vor Monaten hatte ich mal den Post geschrieben(Bilder an Prestashop senden nicht möglich). Da kamen wir leider auch nicht weiter...
Ich habe dann einfach alle Bilder manuel hinzugefügt. Nun bei 300 Artikeln macht das keinen Spass.
Any Ideas?
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Hallo rusc shop,
Das Problem welches du in dem Thread "Bilder an Prestashop senden nicht möglich" deutet auf eine Fehlkonfiguration des Servers hin.
Ich vermute dass hier die Einstellungen "upload_max_filesize" und "post_max_size" in der php.ini erhöht werden müssen.
Falls das nicht helfen sollte wäre auch eine Prüfung der Firewall nützlich da diese die maximale Größe von hochgeladenen Dateien auch beschränken können.

Wie groß sind denn die Bilder die du hochladen möchtest?
 

rusc shop

Aktives Mitglied
26. August 2017
23
2
Hallo nochmals
Ich habe die Einstellungen kontrolliert. Die 256MB sind bereits hinterlegt und mehr geht nicht mehr. Wir benutzen php 7.2. Ist dies vielleicht zu neu?
Auch meine lokale Firewall (windows eigene) habe ich testweise komplette deaktiviert. leider auch hier ohne nennenswerten Erfolg.
Spannend finde ich aber die Tatsache, dass nach einem versuchten Upload aller Daten die Webseite mehrere Minuten off ist.
 

Anhänge

  • auszug jtl.JPG
    auszug jtl.JPG
    21,1 KB · Aufrufe: 9
  • php.JPG
    php.JPG
    76,2 KB · Aufrufe: 9

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Ich hab das ganze gerade einmal nachgestellt und habe Testweise einen Prestashop mit der Version 1.7.4.2 auf einem Server mit PHP 7.2 installiert.
Der Shopabgleich mit meiner Test- Wawi lief problemlos und alle Bilder werden korrekt angezeigt.

Hat dein Server zufällig eine Firewall die Dateiuploads beschränken könnte?
Wie groß sind denn die Bilder die du hochladen möchtest?
 

rusc shop

Aktives Mitglied
26. August 2017
23
2
hallo nochmals.
Die Files sind nicht mehr als 4mb gross. der hoster hat mir versichert dass 256mb standartmässig eingestellt ist. das serverprotokoll speichert nach dem versuchten upload folgender fehler...
---------------------------------------------------------------------------------------------------------------------------------------------------------
03-Aug-2018 09:32:38 Europe/Zurich] PHP Fatal error: Uncaught --> Smarty:
Missing template name <--
thrown in /data/web/e34272/html/apps/store/vendor/ prestashop/smarty/sysplugins/smarty_internal_template.php
on line 678
[03-Aug-2018 09:33:13 Europe/Zurich] PHP Notice: Undefined index: category in
/data/web/e34272/html/apps/store/vendor/prestashop/smarty/sysplugins/smarty_internal_templatebase.php(157)
: eval()'d code on line 580
[03-Aug-2018 09:33:13 Europe/Zurich] PHP Notice: Trying to get property of
non-object in
/data/web/e34272/html/apps/store/vendor/prestashop/smarty/sysplugins/smarty_internal_templatebase.php(157)
: eval()'d code on line 580

hilft dies weiter?
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Hallo rusc shop,
Es scheint so als hättest du ein Custom Theme im Einsatz welches die Fehler hervorruft.
Ich würde dich bitten das ganze mit dem standard Theme einmal zu testen um zu sehen ob der gleiche Fehler weiterhin auftritt.
 

rusc shop

Aktives Mitglied
26. August 2017
23
2
Hallo nochmals
Ich habe nun eine andere Template (leo_bestserve) installiert. Leider auch da Fehler 400. Anschliessend wieder back zu classic und nochmals versucht. Wieder Fehler 400.
Danke für deine Hilfe.
Pascal
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Ich würde dich bitten deinen Hoster zu fragen ob er die SSL bzw. Redirect Konfiguration überprüfen kann.
Es scheint als kommt der Request nicht richtig beim Connector an.
 

rusc shop

Aktives Mitglied
26. August 2017
23
2
Hallo Benjamin.
Anbei die Antwort vom Hoster:
das error. log ist derzeit bei Ihnen leer da die Protokollierung der Server-Fehler bei Ihnen nicht aktiviert ist.
Ich habe dies für Sie soeben aktiviert. Bitte führen Sie den Vorgang jetzt nochmals aus und geben Sie uns anschließend bescheid sobald der Fehler wieder auftritt.
Wenn es zu einem 400 Fehler kommt müsste dies im error Log nun ersichtlich sein.
Dass es sich um einen PHP Fehler handelt glaube ich eher nicht.
Für weitere Fragen stehen wir Ihnen gerne zur Verfügung!
Ihr easyname Support Team

Zusätzlich gebe ich dir das aktuelle log mit. Natürlich wieder mit Fehler 400.
 

Anhänge

  • error.pdf
    226,9 KB · Aufrufe: 8

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Hallo rusc shop,
aus dem error log ist ersichtlich dass doch eine Firewall den Bilder Upload blockiert.
Falls du die Firewall "ModSecurity" nicht selber eingerichtet hast sondern diese vom Hoster kommt bitte ihn den Fehler zu überprüfen.
 

rusc shop

Aktives Mitglied
26. August 2017
23
2
Hallo Benjamin.
Vielen, vielen Dank für deine Hilfe. Es funktioniert! Ich glaubs noch nicht... ABER...
... es funktioniert...

Es wurde von mir, wie auch vom Hoster easyname nie eine Firewall installiert. Aber bei der Einrichtung einer subdomain wird seit der SSL-Pflicht auch die Application Firewall standartmässig aktiviert. Dies war der Fehler und auf den ersten Blick nicht zu erkennen, da ich selber auch nicht die Einstellungen der Subdomain überprüft habe.
Nochmals vielen, vielen Dank für deinen Einsatz!
Pascal
 

Anhänge

  • Subdomain.JPG
    Subdomain.JPG
    27,1 KB · Aufrufe: 5
Ähnliche Themen
Titel Forum Antworten Datum
Neu Amazon Abgleich 02.09.2026 Amazon-Anbindung - Fehler und Bugs 49
Neu Amazon Störung Abgleich Amazon-Anbindung - Fehler und Bugs 20
Neu Versandprofile trotz eBay-Abgleich nicht vorhanden JTL-Wawi 2.0 2
Plattform Abgleich nicht möglich JTL-Wawi 1.11 2
Neu Amazon.com - kein Abgleich der Bestände Wawi 1.11.9 Amazon-Anbindung - Fehler und Bugs 0
Wroker macht keinen abgleich für Kaufland JTL-Wawi 2.0 8
Beantwortet Shop Abgleich nach Update auf 5.7.2 nicht mehr möglich JTL-Shop - Fehler und Bugs 4
Update von WaWi 1.11.11 auf 2.1.1 JTL-Wawi 2.1 4
Neu Erstellen von eBay-Vorlagen nach Update auf 2.1.1 nicht mehr möglich eBay-Anbindung - Fehler und Bugs 7
Neu Preise von JTL Shipping 2.0 für JTL Start Nutzer JTL-ShippingLabels - Ideen, Lob und Kritik 12
Fehler beim Speichern von Bildern per Drag and Drop JTL-Wawi 1.11 0
TikTok Shop: Mapping von Varkombi (286 Kinder) über identische SKUs zeigt keine Reaktion / Artikel werden nicht verknüpft JTL-Wawi 1.11 0
Neu Problem beim upload von Bildern Gambio-Connector 2
Neu JTL-POS auf ELO Kasse "Elo 23C3" bzw weg von Plenty-POS Allgemeine Fragen zu JTL-POS 2
Positionen von Fehlbeständen sind im Auftrag trotzdem grün JTL-Wawi 1.11 0
Neu Track & Trace - Verfolgung von Retoure JTL-Track&Trace - Ideen, Lob und Kritik 12
Neu von Version zu Version unzufriedener... Arbeitsabläufe in JTL-Wawi 3
In Wawi 2.0.6 Kommentar 1 und Kommentar 2 für Lagerbestände von Kindartikeln desselben Vaterartikels nicht mehr über Vaterartikel pflegbar JTL-Wawi 2.0 4
Neu Biete: Automatisierung von Artikelanlage, Datenpflege und Schnittstellen Dienstleistung, Jobs und Ähnliches 2
Extern angehängte pdf Rechnungen und GS von Otto wie speichern ? JTL-Wawi 1.11 0
Neu Nach Update von POS ist alles groß dargestellt Sunmi t2 Allgemeine Fragen zu JTL-POS 8
Neu Seit heute früh kein Start von JTL-Wawi möglich - Datenbank nicht erreichbar User helfen Usern - Fragen zu JTL-Wawi 7
Neu Fehler beim öffnen von JTL Hub JTL-ShippingLabels - Fehler und Bugs 2
Neu Ausgabe von Artikelbeschreibung: Stückliste + Artikel-Bild JTL-Wawi 2.0 5
Neu GLS in Shipping 2.0: Neue ShipIT-Anbindung & zentrale Tarife jetzt live – Migration von der alten WebAPI bis zum 30. September News, Events und Umfragen 5
Weiter gehts....Kein Anlegen von Artikel mit Fotos mehr möglich, seit Update auf 2.06 JTL-Wawi 2.0 14
Neu css Einstellungen Paypal Plugin von JTL JTL-Shop - Fehler und Bugs 1
Neu Anzeige von Rabatt obwohl nicht eingestellt. Allgemeine Fragen zu JTL-Shop 1
Wichtig JTL-ShippingLabels 1.0: Support-Ende GLS/DPD und Migration von JTL-Start-Kunden nach dem 30. September News, Events und Umfragen 16
Neu Amazonpay Fehler nach Anbindung von Datev - bitte helfen Schnittstellen Import / Export 0
Lexware Office von Kunden meldet Arithmetik Fehler in Zugferd 2 XRechnung JTL-Wawi 1.11 12
Neu Wie bedenklich wäre es, den Vorgangsstatus von Aufträgen über einen direkten Datenbankbefehl zu aktualisieren? User helfen Usern - Fragen zu JTL-Wawi 5
Neu Auszahlungen von Amazon prüfen Arbeitsabläufe in JTL-Wawi 2
Neu KI Kennzeichnung von Bildern Betrieb / Pflege von JTL-Shop 9
Die Suche von Stücklistenartikeln/Bundles funktioniert nicht Allgemeine Fragen zu JTL-Shop 0
Neu Update von 1.8.12.4 auf 2.0.5 - Kostenfreie Version - Registrierung erforderlich? User helfen Usern - Fragen zu JTL-Wawi 1
Wie übernehme ich Artikelnamen von JTL in den neuen Kaufland Niederlande-Verkaufskanal? JTL-Wawi 1.11 1
Neu JTL Shop Plugin - BD Automatisierter Widerruf (Von Händler für Händler - Schluss mit Mail-Chaos & Spam-Sorgen!) Plugins für JTL-Shop 0
Neu Installieren von Plugins schlägt fehl "Unable to authenticate using a password." Plugins für JTL-Shop 3
Neu "alte" Bankverbindung beim Duplizieren von älteren Aufträgen User helfen Usern - Fragen zu JTL-Wawi 3
nach Update von 5.3 auf 5.7 neue Position im Warenkorb "Gebühr" die auch in den Auftrag übernommen werden Einrichtung JTL-Shop5 2
Neu E-Rechnungen werden von DATEV nicht akzeptiert JTL-Wawi 2.0 1
In Diskussion Tool für Abrechnung von Fulfillment Dienstleistungen Arbeitsabläufe im Fulfillment Network 0
Neu JTL-Wawi 2.0.6: eBay-Rahmenbedingungen bei bestehenden Angeboten/Vorlagen nicht mehr änderbar eBay-Anbindung - Fehler und Bugs 14

Ähnliche Themen