Beantwortet Fehlermeldung "JTL-Worker ist nicht gestartet" obwohl Worker läuft

AlexR17

Aktives Mitglied
23. Juli 2021
14
5
Hi zusammen,

wir haben das Problem mit der aktuellen Version 1.7.13.0, dass uns angezeigt wird: "JTL-Worker ist nicht gestartet, bitte starten Sie den JTL-Worker um Status-Informationen einsehen zu können".

Wir haben bereits folgendes getestet:
- Server neu gestartet
- Dienst neu installiert
- Worker manuell gestartet
- Virenscanner deaktiviert

hatte schonmal jemand diese Problem oder kann uns helfen?

Viele Grüße!
 

Anhänge

  • Bildschirmfoto 2023-07-26 um 10.54.46.png
    Bildschirmfoto 2023-07-26 um 10.54.46.png
    375,7 KB · Aufrufe: 61

AlexR17

Aktives Mitglied
23. Juli 2021
14
5
Wir haben eine Rückmeldung vom Support bekommen und es lag an der Zeit vom MSSQL-Server. Falls jemand das Problem auch haben sollte, auf dem MSSQL-Server folgende Query ausführen:
select * from dbo.tUniqueSession

Wenn dort im last-callback eine andere Zeit drin steht, hängt der Worker.
 

kiu

Aktives Mitglied
5. Juli 2008
75
4
Wir haben das gleiche Problem. Was hast du im Anschluss gemacht?
 

AlexR17

Aktives Mitglied
23. Juli 2021
14
5
Hallo zusammen,
interessanterweise ist der Fehler nach dem Update auf die JTL 1.8 wieder da. TimeZone ist richtig konfiguriert und wird von MSSQL auch zurückgegebn mit SELECT CURRENT_TIMEZONE().

Wir haben die UniqueSessions wie oben selektiert und bekommen dann !nur für den Worker! die falsche Uhrzeit (16:58 anstatt 17:58).

Nach einigen Tests haben wir es hinbekommen:

1. JTL-Worker Dienst beenden
2. in der Wawi: Admin -> JTL-Worker -> Status -> und dann auf den Button zurücksetzen
3. JTL-Worker Dienst starten

Bei uns geht es jetzt wieder..
 
  • Gefällt mir
Reaktionen: Arne Janson

Ähnliche Themen