Neu Update nach 5.7.1 hängt bei Mirgation

  • Ersteller des Themas Ersteller des Themas _jb_
  • Erstellungsdatum Erstellungsdatum

_jb_

Aktives Mitglied
2. Dezember 2020
38
9
Hallo Allerseits,
ich habe versucht den Shop nach 5.7.1 upzudaten, aber lief nicht sauber durch. Beim Schritt der Datenbank-Migration hing es in der Hälfte. Habe dann die Migration per CLI ausgeführt, was auch ging. Allerdings zeigte mir der Shop nach dem Login an, dass die Shop- und Template-Version 5.6.1 ist und die DB Version 5.7.1. Unter Diagnose wurde angezeigt, dass 444 Dateien modifiziert seien.

Habe Backup wieder zurück gespielt und jetzt bin ich wieder sauber auf 5.6.1.

Beim Versuch des Updates im Frontend zeigt die Browser Console einen 500 Fehler bei dem Aufruf von ".../io" an.

Was würdet Ihr hier raten? Gibt es eine Möglichkeit statt im Frontend, das Shop-Update+Migration komplett per CLI anzustoßen?

LG
Jonathan
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
hast du auch die Datenbank zu 100% wieder zurückgespielt, also die Tabellen die drin waren vorher alle gekillt und dann erst die Datenbank zurückgesetzt?
Sonst wirst du mit dem nächsten Update Probleme haben.

Ich würde nie wieder zurück gehen wenn etwas klemmt, man sollte das immer durchziehen und sich im Notfall Hilfe holen.
 

_jb_

Aktives Mitglied
2. Dezember 2020
38
9
hast du auch die Datenbank zu 100% wieder zurückgespielt, also die Tabellen die drin waren vorher alle gekillt und dann erst die Datenbank zurückgesetzt?
Sonst wirst du mit dem nächsten Update Probleme haben.
Ja das habe ich, zuerst DB gedropped, neu angelegt und Dump zurückgespielt.
Ich würde nie wieder zurück gehen wenn etwas klemmt, man sollte das immer durchziehen und sich im Notfall Hilfe holen.
Dafür war der Zeitpunkt etwas ungünstig.

Was wäre denn wenn ich, vor dem Update im Frontend anstoßen, per CLI die Migration ausführe? Macht das einen Unterschied?
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
Ja das habe ich, zuerst DB gedropped, neu angelegt und Dump zurückgespielt.
Perfekt, das vergessen die meisten.

man kann das auch nur über das cli machen, ich mache es grundsätzlich über das Frontend da ich dann auch sehe wo es klemmt und das nach und nach abarbeiten kann.
Bei den meisten ist es über die shell eh nicht möglich.

wichtig ist das du wenn es übers Frontend geht, du die wichtigsten Sachen, vorab machst.
alle Plugins deaktivieren
aufs NOVA Template umschalten
cache am besten deaktivieren
wenn du dich eingeloggt hast und der dir anzeigt das er updaten möchte einmal strg-F5 drücken
Browser Console aufmachen und dir bei Netzwerk -> fetch/XHR anzeigen lassen, dann siehst du ob es da 500er Fehler gibt oder ob der eben etwas länger braucht.
 
  • Gefällt mir
Reaktionen: _jb_

_jb_

Aktives Mitglied
2. Dezember 2020
38
9
Ok, ich konnte das Problem lösen. Bei mir ist dieser Fehler aufgetreten:

Code:
[Thu Jun 04 08:51:18.320208 2026] [proxy_fcgi:error] [pid 9412:tid 9439] [remote 10.30.3.210:59694] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Undefined constant "LINKTYP_ACCESSIBILITY" in /var/www/shop/includes/src/Migrations/Migration20251020131307.php:141\nStack trace:\n#0 /var/www/shop/includes/src/Update/MigrationManager.php(124): JTL\\Migrations\\Migration20251020131307->up()\n#1 /var/www/shop/includes/src/Update/Updater.php(361): JTL\\Update\\MigrationManager->executeMigration()\n#2 /var/www/shop/includes/src/Update/Updater.php(296): JTL\\Update\\Updater->updateByMigration()\n#3 /var/www/shop/includes/src/Update/Updater.php(226): JTL\\Update\\Updater->updateToNextVersion()\n#4 /var/www/shop/includes/src/Update/UpdateIO.php(50): JTL\\Update\\Updater->update()\n#5 /var/www/shop/includes/src/IO/IO.php(185): JTL\\Update\\UpdateIO->update()\n#6 /var/www/shop/includes/src/Backend/AdminIO.php(60): JTL\\IO\\IO->execute()\n#7 /var/www/shop/includes/src/IO/IO.php(92): JTL\\Backend\\AdminIO->execute()\n#8 /var/www/shop/includes/src/Router/Controller/Backend/IOController.php(111): JTL\\IO\\IO->handleRequest()\n#9 /var/www/sh...', referer: https://daswort.media/admin/dbupdater


Da LINKTYP_ACCESSIBILITY in der ./includes/defines_inc.php vorhanden war, lag der Fehler höchstwahrscheinlich am OPcache, auf jeden Fall hat ein systemctl restart php8.4-fpm und systemctl reload apache2 das Problem gelöst - anschließend lief alles normal durch.
 

Ähnliche Themen