Neu Shopware 6 Abgleich Problem Bilder

concet

Aktives Mitglied
22. Juli 2019
11
6
Hallo zusammen,

aktuell haben wir einen Problem mit der Migration eines (bereits von Shopware 5 Migriertes) Shopware 6 Shops.

Nachdem der Import der Daten erfolgreich verlaufen ist, haben wir den Connector auf den Bidirektionale Übertragung umgestellt.

Wir haben uns entschieden die Artikel nocheinmal für den Kompletten Onlineshop zu deaktivieren um es anschliessen "frisch" in den zu importieren.
Hier gabs zunächst viele Anlaufschwierigkeiten mit den Abgleich welche wir stückweise abgearbeitet haben - Hauptsächlich aufgrund von Artikeln die keiner Kategorie zugewiesen sind, die haben entsprechend angepasst.

Kurz vor dem Ziel des Abgleich für das entfernen der Artikel aus dem Shop - möchte der Connector Bilder hochladen und wirft folgende Fehlermeldung:


Fehler:
Exception: Controller = Image | Action = push | JTL-Wawi PK = 191 | Related type SpecificValue (JTL-Wawi PK = 135) | [66cc555c-468e-4b2c-b7c6-8f652beb77b9] The Shopware 6 Admin API responded with an error:
Code = CONTENT__MEDIA_NOT_FOUND | Status = 404 | Detail = Media for id aaa835717bbb43aaba60ec42b753ef66 not found.
Controller = Image | Action = push | JTL-Wawi PK = 191 | Related type SpecificValue (JTL-Wawi PK = 135) | [a01abb23-af27-4306-a1b9-2846fad6a98c] The Shopware 6 Admin API responded with an error:
Code = CONTENT__MEDIA_NOT_FOUND | Status = 404 | Detail = Media for id aaa835717bbb43aaba60ec42b753ef66 not found.
Abschlussinfo-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Controller = Image | Action = push | JTL-Wawi PK = 191 | Related type SpecificValue (JTL-Wawi PK = 135) | [66cc555c-468e-4b2c-b7c6-8f652beb77b9] The Shopware 6 Admin API responded with an error:
Code = CONTENT__MEDIA_NOT_FOUND | Status = 404 | Detail = Media for id aaa835717bbb43aaba60ec42b753ef66 not found.
Controller = Image | Action = push | JTL-Wawi PK = 191 | Related type SpecificValue (JTL-Wawi PK = 135) | [a01abb23-af27-4306-a1b9-2846fad6a98c] The Shopware 6 Admin API responded with an error:
Code = CONTENT__MEDIA_NOT_FOUND | Status = 404 | Detail = Media for id aaa835717bbb43aaba60ec42b753ef66 not found.
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.JjBcpY291ir(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.FinishCall()
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.ConnectorFinishCallTask.Run()
bei JTL.Connector.Business.SyncRunner.Run()


Leider weiß ich nicht was mit "SpecificValue" gemeint ist um in der Datenbank anhand des PK's den richtigen Bezug finden zu können um den Fehler evtl. zu beheben.


Hat jemand vielleicht eine Ahnung wie man am besten hier vorgehen kann?

Vielen Dank vorab und viele Grüße,

Aziz
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.352
282
Hallo Aziz,

bei SpecificValue handelt es sich um Merkmalwerte. Hier geht es also um ein Merkmalwertbild. Meine Vermutung wäre, dass es sich bei JTL-Wawi PK = 135 um einen Eintrag aus der Tabelle tMerkmalwertBildPlatform handelt.
 

concet

Aktives Mitglied
22. Juli 2019
11
6
Hallo Immanuel,

Danke für die schnelle Rückmeldung.

Ich denke mit der Vermutung lags du nicht verkehrt ich habe das betroffene Merkmalwertbild über die GUI einmal gelöscht.

Leider hat sich jetzt nur die Fehlermeldung abgeändert:

Fehler:
Exception: Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [946bba14-d35b-400a-b864-a22a220490e3] The Shopware 6 Admin API responded with an error:
Code = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)
Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [4c9f4199-9685-4c66-8531-7c6310fd7c24] The Shopware 6 Admin API responded with an error:
Code = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)
Bilder-Löschen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei image.delete: Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [946bba14-d35b-400a-b864-a22a220490e3] The Shopware 6 Admin API responded with an error:
Code = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)

Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [4c9f4199-9685-4c66-8531-7c6310fd7c24] The Shopware 6 Admin API responded with an error:
Code = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)

Response: {"jtlrpc":"2.0","id":"899e6ccd13c745aa810bedc0e867b28d","result":null,"error":{"code":404,"message":"Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [151bf380-2aa7-4364-bda7-383d918df030] The Shopware 6 Admin API responded with an error: \nCode = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 404) in ...\/ClientException.php:98"}}
Exception bei image.delete: Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [946bba14-d35b-400a-b864-a22a220490e3] The Shopware 6 Admin API responded with an error:
Code = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)

Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [4c9f4199-9685-4c66-8531-7c6310fd7c24] The Shopware 6 Admin API responded with an error:
Code = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)

Response: {"jtlrpc":"2.0","id":"350e345b3d624210aa0e0904cd94f25a","result":null,"error":{"code":404,"message":"Controller = Image | Action = delete | JTL-Wawi PK = 135 | Related type SpecificValue (JTL-Wawi PK = 228) | [946bba14-d35b-400a-b864-a22a220490e3] The Shopware 6 Admin API responded with an error: \nCode = FRAMEWORK__RESOURCE_NOT_FOUND | Status = 404 | Detail = The property_group_option resource with the following primary key was not found: id(ea2b4d7ae372442587975db027347b6a)","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 404) in ...\/ClientException.php:98"}}
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.JjBcpY291ir(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.c4WcpsWvf6k(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.JjBcpY291ir(String , Object , Boolean , NetworkCredential )



Warnungen:
Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.


Anscheinend findet der connector nicht die betroffene Merkmalgruppe im Shop. Was ich sehr merkwürdig finde im Shopbackend wurde seit der Anbindung nichts verändert.
 

concet

Aktives Mitglied
22. Juli 2019
11
6
Hallo,

Ok wir konnten das Problem lösen indem wir die Anbindung des Onlineshops gelöscht und neu angelegt haben.

Die Artikel, Kategorie und Merkmal Synchronisation wurden soweit getestet und scheinen zu funktionieren.

Viele Grüße
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Hilfe! WAWI abgleich mit Shopware 6 geht nicht. Shopware-Connector 1
Neu Shopware 6 abgleich mit vielen Errors wegen zu langen metaDescription Shopware-Connector 6
Neu Shopware 5 URL-Pfad passt sich nicht dem Sub-Shop an Shopware-Connector 0
Neu Shopware 6 Connector schmeißt ständig Fehlermeldung Shopware-Connector 2
Neu Shopware 6 - Probleme bei Produktbildern Shopware-Connector 1
Neu Shopware 5 Connector anmeldung nicht möglich nach Update Shopware-Connector 2
Neu Übernahme von Produktnamen aus Shopware 6 Shopware-Connector 0
Neu Shopware 6: HTML-Tags in Attributen werden nicht übertragen? Shopware-Connector 0
Neu Shopware 6 - Connector Error: Malformed UTF-8 characters Shopware-Connector 3
Gelöst Auslandsversand und Shopware Shop JTL-ShippingLabels - Fehler und Bugs 1
Neu Shopware & JTL-Wawi - Welche Aufgaben übernimmt wer? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Shopware 6 - Streichpreise funktionieren nicht. Shopware-Connector 2
Neu Shopware 6 Connector Erscheinungs Datum Exportieren Shopware-Connector 0
Neu Shopware 6 - kryptische URL's für Varianten Shopware-Connector 2
Neu Shopware 6 - Thumbnail Dateinamen Shopware-Connector 6
Neu JTL Ware überschreibt Inhalte von Shopware 6 Plugin Shopware-Connector 5
Neu Shopware PayPal Plugin & Zahlungsarten in JTL Shopware-Connector 2
Neu Shopware 6: Malformed UTF-8 characters, possibly incorrectly encoded Shopware-Connector 2
Neu Shopware 6 - Preise Nachkommastellen Shopware-Connector 1
Beantwortet JTL Workflow für Bestellungen aus Shopware JTL-Workflows - Fehler und Bugs 1
Neu Shopware 6 Artikelbezeichnug nicht aus dem Shop nehmen Shopware-Connector 2
Neu Attributtyp und Datentyp nach Shopware Import Shopware-Connector 0
Neu Shopware Parent+Childs Shopware-Connector 8
In Bearbeitung Seit Connector Update: Wenn Versand gesetzt, wird kein Lieferschein über den Connector an Shopware 5 übertragen Shopware-Connector 1
Neu Aufträge aus Onlineshop (Shopware) nicht im Filter für Versandart vorhanden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 alle Artikelbilder sind doppelt vorhanden Shopware-Connector 1
Gelöst Fehler bei Shopware 6 Connector Übertragung von Artikelbildern durch den Shopabgleich Shopware-Connector 17
Neu Shopware 5: Paypal Kauf auf Rechnung -> Retouren Shopware-Connector 2
Neu Kundenattribute aus JTL zu Shopware senden Shopware-Connector 1
Neu Worker Probleme Amazon Abgleich - Keine Hintergrunddienst aktiven Mandanten gefunden JTL-Wawi - Fehler und Bugs 0
Neu Bilder werden beim Abgleich gelöscht seit 6 Tagen WooCommerce-Connector 0
Neu HILFE Abgleich funktioniert nicht mehr. WooCommerce-Connector 0
Php.ini im Rootverzeichnis wird beim Wawi Abgleich überschrieben Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Wawi überträgt bei jedem Abgleich alle Artikel. JTL-Shop - Fehler und Bugs 4
Neu Onlineshop-Abgleich automatisiert starten/stoppen Shopware-Connector 3
Gelöst ebay Abgleich funktioniert nicht mehr eBay-Anbindung - Ideen, Lob und Kritik 5
Neu Fehlerhafter Ebay-Abgleich eBay-Anbindung - Fehler und Bugs 0
Neu Fehlende Bestellungen eBay-Abgleich eBay-Anbindung - Fehler und Bugs 8
Neu Artikelbeschreibungen für den Abgleich zu lang Shopware-Connector 1
Neu Amazon Preise international per Ameise geändert. Automatischer Abgleich!? Preise werden nur auf .de übernommen Amazon-Anbindung - Fehler und Bugs 3
Neu Fehler beim Abgleich WooCommerce-Connector 0
Neu Fehler beim Abgleich des Shops Shopware-Connector 0
Neu OTTO Anbindung - Dauer Abgleich zur Artikelanlage Schnittstellen Import / Export 0
Neu Abgleich mit Woocommerce führt zu falschen Übertragungen JTL-Wawi - Fehler und Bugs 0
Neu Ebay: Abgleich funktioniert nicht, holt keine Bestellungen ab. eBay-Anbindung - Fehler und Bugs 14
Gelöst ebay Abgleich zeigt keinen Bestelleingang eBay-Designvorlagen - Fehler und Bugs 5
Gelöst Fehlermeldung "Datediff Funktion" beim ersten eBay Abgleich eBay-Anbindung - Fehler und Bugs 4
JTL Shop 5.0.1 - Kein richtiger Abgleich der Artikel-Fotos zwischen WAWI und Shop Einrichtung JTL-Shop5 5
Neu Abgleich dauert Wochenlang WooCommerce-Connector 6
Neu automatischer Abgleich mit dem Onlineshop Onlineshop-Anbindung 0

Ähnliche Themen