1. Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
    Information ausblenden

In Bearbeitung Rollende Kommissionierung - Versand Umlagerung wird mit ?falscher? Buchungsart gemappt [WAWI-23520]

Dieses Thema im Forum "Fehler und Bugs in JTL-WMS" wurde erstellt von SebiW, 4. Dezember 2017.

  1. SebiW

    SebiW Aktives Mitglied

    Registriert seit:
    2. September 2015
    Beiträge:
    343
    Zustimmungen:
    71
    Punkte für Erfolge:
    28
    Ich arbeite derzeit an einem Workflow, der beim identifizieren von neuen Artikeln, die nach einem gewissen Zeitraum noch keine Verkäufe hatten, helfen soll.

    Dabei ist mir aufgefallen, dass bei der rollenden Kommissionierung das legen von Artikeln in die Versandbox als "Wareneingang" gehandelt wird.

    Abgesehen davon, dass es mir meinen Workflow zerschießt: Ist das so gewollt? Eigentlich wäre dass doch "Umlagerung WMS" oder alternativ "Versandprozess WMS"?
     
    Zuletzt bearbeitet: 4. Dezember 2017
  2. Stephan H.

    Stephan H. Super-Moderator Mitarbeiter

    Registriert seit:
    2. Juli 2009
    Beiträge:
    2.489
    Zustimmungen:
    59
    Punkte für Erfolge:
    48
    Beruf:
    JTL-Software - Product Owner JTL-WMS
    Ort:
    Hürth
    Hi, bitte noch kurz die verwendete Version ergänzen.
     
  3. SebiW

    SebiW Aktives Mitglied

    Registriert seit:
    2. September 2015
    Beiträge:
    343
    Zustimmungen:
    71
    Punkte für Erfolge:
    28
    Hi Stephan,
    wir verwenden derzeit noch die 1.3.11.0. und hoffen auf eine baldige 1.3.13.
    Ich kann das gleiche Verhalten aber auch auf meiner Testumgebung mit 1.2.3.7 nachstellen.
     
    Zuletzt bearbeitet: 4. Dezember 2017
  4. Stephan H.

    Stephan H. Super-Moderator Mitarbeiter

    Registriert seit:
    2. Juli 2009
    Beiträge:
    2.489
    Zustimmungen:
    59
    Punkte für Erfolge:
    48
    Beruf:
    JTL-Software - Product Owner JTL-WMS
    Ort:
    Hürth
    Ok, danke. Ich konnte es spontan nicht nachstellen. Kannst du mir noch einen Screenshot nachliefern??

    Ist es in der Bewegungshistorie falsch? Oder in der Artikelhistorie von JTL-Wawi?
     
  5. SebiW

    SebiW Aktives Mitglied

    Registriert seit:
    2. September 2015
    Beiträge:
    343
    Zustimmungen:
    71
    Punkte für Erfolge:
    28
    Der Fehler ist mir beim Versuch aufgefallen einen Workflow anzulegen.
    Prüfe ich auf die Aktion "Wareneingang" werden Einlagerungen in den Pickwagen genauso als korrekt geflagged wie normale Wareneingänge.
    Der Workflow prüft auf Artikel - Warenlagereingang - Plusbuchung den Wert "Buchungsart Name gleich Wareneingang"

    In Bild 1 sieht man mehrere Buchungsvorgänge. Buchungsvorgänge auf PW- Plätze sind Buchungsvorgänge beim kommissionieren auf Pickwägen.
    In Bild 2 prüfe ich einen solchen Buchungsvorgang auf einen Pickwagen auf die Bedingungen. Die Bedingung Buchungsartname gleich Wareneingang wird als zutreffend durchgewunken.

    Schaue ich mir nun die History des betroffenen Artikels an sehe ich hier, dass die Lieferantenbestellnummer dadurch irgendwie auf diese Versandprozesse vererbt wird.

    Wie man an der Liste in Bild 3 sieht passiert das aber nicht bei allen. Ich konnte das auf Vorgänge eingrenzen, bei denen die Bestellung noch im Status teilgeliefert steht.
     

    Anhänge:

  6. SebiW

    SebiW Aktives Mitglied

    Registriert seit:
    2. September 2015
    Beiträge:
    343
    Zustimmungen:
    71
    Punkte für Erfolge:
    28
    Ich vermute mal anhand meines rudimentären SQL Wissens, dass da beim Einlagern in die Box schlicht die falsche oder keine Buchungsart gesetzt wird.
    An sich müsste da vermute ich die 120 Umlagerung WMS oder die 130 Versandprozess gesetzt werden was aber wohl nicht geschieht.
     
  7. Stephan H.

    Stephan H. Super-Moderator Mitarbeiter

    Registriert seit:
    2. Juli 2009
    Beiträge:
    2.489
    Zustimmungen:
    59
    Punkte für Erfolge:
    48
    Beruf:
    JTL-Software - Product Owner JTL-WMS
    Ort:
    Hürth
    Huhu,

    ich kann das weiterhin nicht nachstellen. Getestet mit 1.3.12.0

    RoKoPick.png

    Siehe Screenshot. Mit der Rollenden Kommissionierung einen Artikel gepickt. Dieser liegt nun auf dem Lagerplatz / Pickwagen P1 in Box 2001.

    Die Warenbewegung ist korrekt als "Umlagerung WMS" geflagged. Siehe Bewegungshistorie JTL-WMS.

    Im "Vorschau-Element-Explorer" wird diese Buchung nicht angezeigt. Ebenfalls ist die Buchung nicht als Wareneingang in der Artikelhistorie zu sehen.

    Alles bestens. Dein beschriebenen Szenario passt also nicht. Kannst du das 1:1 in dieser Reihenfolge reproduzieren, damit du den Fehler bei dir bekommst?

    --

    An deinen Screenshots kann ich ebenfalls nichts Ungewöhnliches erkennen. Die bemängelten Buchungen sehen für mich wie "Boxen füllen aus dem Wareneingang" aus.

    Da wäre also eine Buchung vom Typ Wareneingang korrekt.
     
  8. SebiW

    SebiW Aktives Mitglied

    Registriert seit:
    2. September 2015
    Beiträge:
    343
    Zustimmungen:
    71
    Punkte für Erfolge:
    28
    Hallo Stephan,
    zuerst einmal: Wir verwenden den Prozess Boxen füllen aus dem Wareneingang nicht. Die Buchungen können also nicht auf diesem Weg entstanden sein.
    Auch im WMS ist bei uns die Warenbewegung korrekt als Umlagerung geflagged.
    Lediglich in der Wawi tauchen diese Artikelbewegungen mit dem falschen Status auf und werden bei oben beschriebenem Workflow falsch interpretiert.

    Ich kann den Fehler mit Artikeln, die auf einer noch nicht abgeschlossenen Lieferantenbestellung stehen, beliebig provozieren.
    Voraussetzung:

    Artikel ist auf Lieferantenbestellung.
    Lieferantenbestellung ist im Status teilgeliefert (also nicht abgeschlossen).

    Erstelle ich dann einen neuen Sofortauftrag mit einem solchen Artikel und spiele den Versand normal durch erhalte ich immer A. die fehlerhaft zum Versandprozess zugeordnete Lieferantenbestellnummer in der Artikelhistorie und B. wird der Einlagerungsprozess auf den Pickwagen als Wareneingang in meinem oben beschriebenen Workflow angezeigt. Und zwar mit dem Datum des tatsächlichen Wareneingangs dieses Artikels vom 6.11.

    Da ist doch was ganz faul.

    Bilder dazu im Anhang. Bild 1 WMS History. Bild 2 Artikelhistory. Bild 3 auswertbare Wareneingänge des Workflows, eingekreist meine beiden heutigen Testversandsvorgänge. Das Eingebucht Datum entspricht dem Datum des letzten realen, noch nicht abgeschlossenen Wareneingangs.
     

    Anhänge:

  9. Stephan H.

    Stephan H. Super-Moderator Mitarbeiter

    Registriert seit:
    2. Juli 2009
    Beiträge:
    2.489
    Zustimmungen:
    59
    Punkte für Erfolge:
    48
    Beruf:
    JTL-Software - Product Owner JTL-WMS
    Ort:
    Hürth
    Ah ok - viele neue Informationen. Muss ich mir dann in dieser Form nochmal ansehen.
     
  10. SebiW

    SebiW Aktives Mitglied

    Registriert seit:
    2. September 2015
    Beiträge:
    343
    Zustimmungen:
    71
    Punkte für Erfolge:
    28
    Hallo Stephan,
    konntest Du den Fehler nachstellen? Alternativ kannst Du Dir das auch gerne mal auf unserer DB ansehen.
    Die zusätzlichen falsch verknüpften Wareneingänge machen mir doch etwas Sorgen, auch wenn die Statistik z.b. selbige nicht auszuwerten scheint...
     
  11. M. Hadgu

    M. Hadgu Moderator Mitarbeiter

    Registriert seit:
    4. Mai 2016
    Beiträge:
    10
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    Beruf:
    JTL-Software - WMS Support und Integration
    Ort:
    Hürth
    Hallo Sebastian,

    wir hatten ja heute das vergnügen :) Ja ich konnte es nun nachstellen.
    Dazu wird es auch ein Ticket geben, sobald es intern besprochen wurde.

    Vielen Dank
     

Diese Seite empfehlen

Verstanden Weitere Informationen

JTL-Software benutzt Cookies, teilweise von Drittanbietern, um Funktionalitäten auf unseren Webseiten zu ermöglichen.