Neu Probleme mit dem JTL-Wawi Connector für Gambio Connector 2.13.0

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

michael08

Aktives Mitglied
7. Juli 2016
46
0
Leider kann ich meinen PHP Einstellung am Managed Server nicht auf Version 7.4 umstellen.
Die Homepages und Gambio Shops Version 4.2.0.0 bis und auch 4.3.1.0 laufen problemlos, aber leider ist ein Shopabgleich von JTL Wawi Version 1.5.36.0 nicht möglich und wird mit dem folgenden Fehler abgeprochen:
"Class ZipArchive not found. PHP 5 >= 5.2.0, PECL zip >= 1.1.0 installed?"
Diese ZIP Erweiterung ist aber ab PHP 7.4 nicht mehr vorgesehen.
Zitat aus php.net :
( Von PHP 7.3.0 an wird die Kompilierung mit der gebündelten libzip nicht mehr empfohlen, ist aber noch immer möglich, indem --without-libzip zur Konfiguration hinzugefügt wird. Von PHP 7.4.0 an ist die gebündelte libzip nicht mehr vorhanden. )
Stelle ich die PHP Version wieder auf 7.3 (security updates only) = demzufolge eigentlich nicht mehr zeitgemäß weil neuere Versionen mitlerweilen Standard sind, so funktioniert das mit dem Abgleich wie gehabt einwandfrei.

Somit erwartet JTL Wawi bzw. der entsprechende Connector für Gambio die "libzip Erweiterung" die aber bei PHP 7.4 wohl icht mehr vorgesehen ist.

Ist halt nicht so schön wenn man wegen dem Shopabgleich nicht die aktuelle PHP Version nutzen kann die aus Performancegründen für den Shop und hier für den Shopkunden shon wichtig wäre.

Hoffe einmal das dieses Problem ggf. einmal in Angriff genommen wird und muß halt, da ich auf das super Warenwirtschaftsystem der JTL-Wawi nicht verzichten möchte solange mit der veranlten PHP Version leben.

Ich wünsche allen ein Frohes Fest und vor allem viel Gesundheit
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.106
234
Hallo @michael08,

libzip ist eine externe Library, welche ab PHP 7.4 für die Kompilierung von der Zip Extension zusätzlich eingebunden werden muss. Diese kann man bei Debian oder RHEL (Derivaten) meistens über den Paketmanager installieren. ZipArchive ist also in PHP7.4 enthalten und auch nicht als Deprecated gekennzeichnet. Sage am besten deinem Hoster, dass du PHP7.4 mit der Zip Extension benötigst.
 

michael08

Aktives Mitglied
7. Juli 2016
46
0
Hallo @michael08,

libzip ist eine externe Library, welche ab PHP 7.4 für die Kompilierung von der Zip Extension zusätzlich eingebunden werden muss. Diese kann man bei Debian oder RHEL (Derivaten) meistens über den Paketmanager installieren. ZipArchive ist also in PHP7.4 enthalten und auch nicht als Deprecated gekennzeichnet. Sage am besten deinem Hoster, dass du PHP7.4 mit der Zip Extension benötigst.
Hallo Immanuel
Danke für die Rückmeldung.
Dann muß ich mich mal mit dem Hoster auseinander setzen.
Hatte halt nur dies wie oben gefunden:

Zitat aus php.net :
( Von PHP 7.3.0 an wird die Kompilierung mit der gebündelten libzip nicht mehr empfohlen, ist aber noch immer möglich, indem --without-libzip zur Konfiguration hinzugefügt wird. Von PHP 7.4.0 an ist die gebündelte libzip nicht mehr vorhanden. )

Muß ich halt sehen das der Hoster mir das mit einbindet.

Ich wünsche Frohe Weihnachten und vor allem viel Gesundheit!
 

michael08

Aktives Mitglied
7. Juli 2016
46
0
Hallo Immanuel

Habe mich mit dem Hoster auseinander gesetzt und dieser teilte mir mit das die zlip Erweiterung wohl am Server auch unter PHP 7.4 bereitgestellt ist.
Dies mußte ich auch nach Überprüfung der PHP Einstellungen in der Wawi beim auslesen der Server Info bestätigen.
Scheint daran wohl nicht zu liegen.

Hier noch einmal eine Kopie der Fehlermeldung wie sie beim Shopabgleich unter PHP 7.4 Aktivierung am Server erscheint:

"
Abgleich-Protokoll:
Es ist ein Fehler bei der Initialisierung aufgetreten. Für nähere Informationen schauen Sie bitte in das Fehlerprotokoll.
Exception bei core. connector.init: Class ZipArchive not found. PHP 5 >= 5.2.0, PECL zip >= 1.1.0 installed?

Class ZipArchive not found. PHP 5 >= 5.2.0, PECL zip >= 1.1.0 installed?

Response: {"result":null,"error":{"code":0,"message":"Class ZipArchive not found. PHP 5 >= 5.2.0, PECL zip >= 1.1.0 installed?","data":null},"jtlrpc":"2.0","id":"15bb291215264e0fa6f981edf219a1e5"}
Onlineshop-Abgleich beendet für 'xxxxxshop'.

"
Nach zurück stellen auf PHP Version 7.3 funktioniert es alles Fehlerfrei.

Hier die Kopie der unter PHP 7.4 dargestellten Erweiterungen (Teilausschnitt)

"phpversion":"7.4.11",
"mysqlversion":"5.5.65-MariaDB",
"SERVER_SOFTWARE":"Apache",
................................
"json_support":"json support is On",
"mysql_client_api_version":"mysql extension not loaded yet!",
"openssl_version":"NSS/3.44",
"installed_extensions":
[
"Core",
"date",
"libxml",
"openssl",
"pcre",
"zlib",
"bz2",
"calendar",

Hänge jetzt natürlich irgendwie bisschen in der Luft. Benutze halt erst einmal PHP 7.3 weiter damit ich meine Kundenbestellungen in die Wawi importieren kann.

Vielleicht hat ja jemand noch eine Idee was ich ggf. versuchen kann damit ich das aktuelle PHP 7.4 nutzen kann.

Noch meine allerbesten Wünsche für das neue Jahr und allen viel Gesundheit.

mit besten Grüßen

Michael
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.106
234
Hallo Michael,

dir auch ein frohes neues Jahr!

Ich habe es gerade auf einem Entwicklungsrechner getestet: Sobald die Zip Extension in PHP nicht aktiv ist, erscheint dieser Fehler. Es muss also mit der Konstellation PHP7.4 und der Zip Erweiterung für PHP bei deinem Hoster zusammenhängen.
 

michael08

Aktives Mitglied
7. Juli 2016
46
0
Hallo Immanuel

Danke für das schnelle Feedback. werde dann wohl meinem Hoster noch mal auf die Füsse treten müssen... ob es was hilft muß sich zeigen. Die Hoster sind da ja auch immer ganz schnell mit der Behauptung das der Fehler wohl nicht bei Ihnen liegen kann. Schuld sind immer die anderen. Schauen wir mal.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Bearbeitung Verschiedene Probleme mit dem Kundendisplay JTL-POS - Fehler und Bugs 2
Neu Probleme mit dem Auftrag ausliefern Arbeitsabläufe in JTL-Wawi 0
Neu Einige Probleme mit dem Shop 5 Allgemeine Fragen zu JTL-Shop 7
Neu Probleme mit Retoure bei JTL 1.5.38.1 User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 6 - Probleme mit Attributen Shopware-Connector 1
Neu JTLShop5 mit PHP8 probleme mit Paypal JTL-Shop - Fehler und Bugs 3
Neu Probleme mit Aktualisierung der Lieferzeiten WooCommerce-Connector 0
Neu Probleme mit Fake Anmeldungen in unserem Shop Betrieb / Pflege von JTL-Shop 3
Beantwortet Probleme mit EAN´s bei Artikeletiketten JTL-Wawi - Fehler und Bugs 2
Neu Probleme mit Brother QL-700 Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 4
Neu Probleme mit "JTL Händlerbund Plugin für Rechtstexte" Plugins für JTL-Shop 3
Neu Seit zwei Tagen Probleme mit Sofortüberweisung Allgemeine Fragen zu JTL-Shop 1
Neu Probleme mit bestehenden Angeboten und Variationen beim Import eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Shop 5 - Probleme mit Postleitzahlen JTL-Shop - Fehler und Bugs 0
Neu Inventur Probleme bei Artikel mit Seriennummer. JTL-Wawi - Fehler und Bugs 1
Neu Probleme mit JTL-Shop- und RDP-Hosting vom 9.12. auf 10.12.2020 News, Events und Umfragen 0
Neu Probleme mit Lizenzen JTL-Wawi - Fehler und Bugs 0
Offen Stücklisten produzieren und Probleme mit Nachkommastellen JTL-Plan&Produce - Ideen, Lob und Kritik 1
Beantwortet Google Shopping Export Feed Probleme mit GTIN Nummer Plugins für JTL-Shop 6
Neu Neue Warenpost mit DHL Probleme bei Einbindung "Produkt ungültig" JTL-ShippingLabels - Fehler und Bugs 1
Neu Massive Probleme NOVA 5 Template Anzeige Templates für JTL-Shop 1
Neu Probleme seit Update auf 1.5.38.1 : keine Amazon FBA Bestellungen mehr und Fehler beim Zugriff auf Wawi Logbuch Amazon-Anbindung - Fehler und Bugs 1
Neu Gibt es aktuell Probleme beim Bestandsabgleich Ebay? Einrichtung und Installation von JTL-eazyAuction 2
Neu Probleme bei Hinzufügen von Bildern in JTL-Wawi JTL-Wawi - Fehler und Bugs 16
Gelöst NOVA Template - Slick Slider macht Probleme - Geladen wird nach 'mouseenter' & 'touchstart' Templates für JTL-Shop 7
Neu Link Probleme JTL-Shop - Fehler und Bugs 2
Neu Shop5 Update: Probleme im Backend/Versandarten JTL-Shop - Fehler und Bugs 7
Neu Probleme Zahlungsabgleich GBP / Brexit / Mwst Abzug User helfen Usern - Fragen zu JTL-Wawi 0
Neu Probleme bei der Erstellung der Druckvorlage User helfen Usern - Fragen zu JTL-Wawi 0
Neu jetzt brennt hier aber alles. wawi Probleme User helfen Usern - Fragen zu JTL-Wawi 14
Neu Probleme bei Upgrade auf jtl shop 5 - adminseiten teilweise nicht aufrufbar Installation / Updates von JTL-Shop 15
Neu JTL Shop 5 Probleme Allgemeine Fragen zu JTL-Shop 4
Neu Probleme Backend Shop 5.0 / http 500 Fehler Installation / Updates von JTL-Shop 1
Neu Probleme nach Upgrade 4.06 auf 5.0 - SQL Query blockiert Datenbank Installation / Updates von JTL-Shop 13
Neu Viele Fragen und Probleme zu List&Label Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Connector Probleme Session invalid Shopify-Connector 0
Neu Probleme beim Upload von Shop 5.0 Installation / Updates von JTL-Shop 12
Neu Probleme beim Warenversand durch Überverkauf... User helfen Usern - Fragen zu JTL-Wawi 1
Neu Nach Update 4.06 auf 5 JTL-Shop (Community Free Edition) Probleme Installation / Updates von JTL-Shop 12
Neu JTL Shop 4 auf JTL Shop 5 - Probleme beim Update Installation / Updates von JTL-Shop 35
Neu Probleme beim Update von Version 1.5.34.1 auf 1.5.35 JTL-Wawi - Fehler und Bugs 23
Neu Gibt es evtl. Probleme beim Zahlungsabgleich? JTL-Wawi - Fehler und Bugs 31
In Bearbeitung Ebay: Artikel automatisch einstellen Probleme eBay-Anbindung - Fehler und Bugs 2
Neu Problem mit der Auswahl an Lieferländern. Wie begränzen auf Länder die man beliefert? JTL-Shop - Fehler und Bugs 9
Neu JTL Shop 5 Hosting mit Miete wo? User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Chargen mit JTL-POS JTL-POS - Fehler und Bugs 4
Neu Lieferanten-Artikelnummern mit Ameise aktualisieren? User helfen Usern - Fragen zu JTL-Wawi 2
Beantwortet Export csv erstellen mit Header. JTL-Workflows - Fehler und Bugs 4
Neu Bin gerade am verzweifeln...Problem mit Test-Demo-Shop Onlineshop-Anbindung 12
Neu Lieferzeitermittlung bei Stüli-Artikeln mit "Im Zulauf" User helfen Usern - Fragen zu JTL-Wawi 0
Ähnliche Themen