Probleme bei der Erstinstallation des WAWI Connectors

sm-startup2008

Aktives Mitglied
4. Januar 2008
95
0
Ich nutze XTCommerce in der Version 304SP2.1

Aufgrund htacess habe ich den Connector ins folgende Verzeichnis kopiert:

www.meinedomain.de/jtlwawi_connector/

(gleiches Verzeichnis wie "admin")

Beim Aufrufen der Ersteinrichtung kommt folgende Fehlermeldung:

Warning: main(/kunden/195944_72581/webseiten/includes/functions/database.php) [function.main]: failed to open stream: No such file or directory in /kunden/195944_72581/webseiten/jtlwawi_connector/admin/admininclude.php on line 22

Warning: main(/kunden/195944_72581/webseiten/includes/functions/database.php) [function.main]: failed to open stream: No such file or directory in /kunden/195944_72581/webseiten/jtlwawi_connector/admin/admininclude.php on line 22

Fatal error: main() [function.require]: Failed opening required '/kunden/195944_72581/webseiten/includes/functions/database.php' (include_path='.:/usr/local/lib/php') in /kunden/195944_72581/webseiten/jtlwawi_connector/admin/admininclude.php on line 22

Brauche dringend Unterstützung
 

Thomas Lisson

Administrator
Mitarbeiter
24. März 2006
15.574
300
Köln
Hi,

schau mit dem FTP, ob Du soeine Datei hast: /kunden/195944_72581/webseiten/jtlwawi_connector/admin/admininclude.php
 

sm-startup2008

Aktives Mitglied
4. Januar 2008
95
0
Die Ersteinrichtung geht immer noch nicht. HILFE!!!

Leider geht die Installation immer noch nicht. Kann mir denn hier keiner helfen?!?! 🙁
 

soulwarrior

Aktives Mitglied
29. Dezember 2010
4
0
AW: Probleme bei der Erstinstallation des WAWI Connectors

Ich habe das Modul auch korrekt nach Anleitung installiert, allerdings gibt es bei meiner Installation schlichtweg keine database.php im includes/functions Ordner, wodurch die manuelle Installation scheitert (die automatische scheiterte daran, dass die Pfade nicht richtig ausgelesen werden konnten, wie ich in einem anderen Thread gelesen hatte, könnte dies etwas mit Encoding zu tun haben).
Ich habe mich nun auch mal an meinen Provider gewendet, da das XT:Commerce von diesem per vorgegebener Installation eingerichtet wurde, allerdings habe ich auch bei mehreren aus dem Netz gezogenen XT:Commerce Varianten keine database.php gefunden. Offenbar ist diese Datei also nicht bei jeder Installation von XT:Commerce vorhanden.

Gibt es einen Workaround?

Danke.
 

andi1970

Sehr aktives Mitglied
17. April 2007
3.380
1
Deutschland
AW: Probleme bei der Erstinstallation des WAWI Connectors

der installpfad für einen xt lautet: deinedomain/admin/includes/modules
dort kommt der Ordner "jtlwawi_connector" und die install ruft man dann so auf

deinedomain/admin/includes/modules/jtlwawi_connector/install.php
 

soulwarrior

Aktives Mitglied
29. Dezember 2010
4
0
AW: Probleme bei der Erstinstallation des WAWI Connectors

Danke für deine Antwort. Wie gesagt wurde das Modul korrekt nach Anleitung installiert, bzw. ich bin bei der manuellen Installation an einem gewissen Punkt gescheitert. Mein Provider hat mir nun die database.php, die zuvor lediglich in /admin/includes/functions hinterlegt war, auch in /includes/functions kopiert. Ich weiß nicht, warum das Folder zuvor falsch war.

Unabhängig davon - denn das Problem besteht nicht mehr - klappt die Installation leider nicht. Beim Schritt http://www.domain.de/admin/includes/modules/jtlwawi_connector/admin aufrufen erhalte ich die Fehlermeldung "Direct Access to this location is not allowed."
Offensichtlich gibt es jetzt neuerdings ein Permission-Problem. Per FTP kann ich leider auch kaum noch Rechte ändern. Ich werde mich also noch einmal an meinen Provider wenden müssen. 🙁
 

soulwarrior

Aktives Mitglied
29. Dezember 2010
4
0
AW: Probleme bei der Erstinstallation des WAWI Connectors

Ich bin mir ehrlich gesagt unsicher, inwiefern mir die FAQ hier weiterhelfen kann. Ich bin der von dir verlinkten Anleitung (15.6.4. - Manuelle Installation des Connectors) Schritt für Schritt gefolgt und komme bis zum vorletzten Punkt.

Wenn ich allerdings /admin/includes/modules/jtlwawi_connector/admin/
aufrufen möchte, so erscheint die Fehlermeldung "Direct Access to this location is not allowed."

Auf diese Meldung geht die FAQ nicht ein und ich bin mir unsicher, wie ich weiter vorgehen soll. Meinen Provider habe ich bereits um Rat gebeten, doch dieser kennt selbstverständlich nicht die genaue Funktionsweise von JTL, so dass ich hier eigentlich auf mehr Unterstützung hoffe.
 

soulwarrior

Aktives Mitglied
29. Dezember 2010
4
0
AW: Probleme bei der Erstinstallation des WAWI Connectors

Leider ist ein Editieren meines vorhandenen Beitrags nicht möglich. Daher noch mal in einem zweiten Post:

Der Fehler ist nun wohl gelöst. Es ist nicht zu fassen, was hier falsch gelaufen ist: Offenbar haben wir uns beim Download des Connectors verklickt und den OS anstelle des XT Commerce Connectors herunter geladen. Da hätten wir wohl noch etwas lange rum probieren können...

Noch einmal danke für die Hilfe hier.
 

Ähnliche Themen