Gelöst Pluginverwaltung weiß mit php7.x

B2B-IT

Gut bekanntes Mitglied
15. Januar 2016
120
10
Hallo zusammen,

wir nutzen den Shop in Version 4.06 (Build: 9), derzeit noch mit php 5.6. Wollen nun aber auf php 7.x wechseln.
Soweit sogut. Das Shopfrontend läuft mit php 7.x, nur sobald wir die Pluginverwaltung öffnen wollen, bleibt der Bildschirm weiß.
Ich habe schon gelesen, dass es daran liegt, dass das ein oder andere Plugin nicht php7 kompatibel ist. Diese wurden auch deaktiviert, trotzdem kommt der Fehler noch.
Müssen die Plugins auch deinstalliert werden um den Fehler zu beheben?

Weiterhin ist mir auch nicht klar, ob alle JTL eigenen PlugIns php7 kompatibel sind, wie kann man das prüfen?

1543575365299.png
 

Mirko.Schmidt User deaktiviert

Guest
Bitte einmal das Error Logging wie hier beschrieben aktivieren. Danach kann der Fehler eingegrenzt werden. Unsere Plugins sollten soweit alle PHP 7.1 kompatibel sein.
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
Nur deaktivieren reicht unter Umständen nicht aus, ich weiß nicht ob es in der 4.06 noch so ist wie in der 4.05er aber wenn ein Plugin eine Bootstrap.php beinhaltet wird diese trotzdem aufgerufen (ich glaube sogar auch wenn es nicht installiert ist aber das ist schon eine Weile her das ich mich darüber geärgert habe) , ist diese dann noch ioncube verschlüsselt kann es zu Problemen kommen wenn diese Version nicht für 7.x verschlüsselt wurde.
 

301Moved

Sehr aktives Mitglied
19. Juli 2013
930
188
Ich glaube, das ist auch in der 4.06 noch so (4.05 gar nicht eingesetzt...). War sehr irritierend, dass deaktiveren nicht gereicht hat und bis ich überhaupt drauf gekommen bin... Einige Plugins musste ich dabei tatsächlich auch vom Server löschen, wenn ich mich richtig entsinne...
 

B2B-IT

Gut bekanntes Mitglied
15. Januar 2016
120
10
Vielen Dank für die Hinweise.
Es lag tatsächlch an einem deaktivierten, aber noch installieren PlugIn. Super Problem gelöst👍
 

Ähnliche Themen