Neu Nach Installation Microsoft SQL Server 2016 = Keine Verbindung mehr zur SQL-2014-Express-Datenbank + keine zur SQL-Server-2016 !?!?

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
8. November 2017
68
3
#1
Hallo,
wir haben auf Grund der 10GB-Datenbank-Problematik nun von SQL-2014-Express auf den "Microsoft SQL Server 2016" wechseln wollen.
Jedoch haben wir nun nach der Installation vom "Microsoft SQL Server 2016" keine Verbindung mehr zum alten SQL-Server-2014 und bekommen auch keine Verbindung mehr zum neuen Server.
Was kann das Problem sein, da wir am Servermanagment (zumindest nicht bewusst) etwas verändert haben?

Das Vorgehen war:
1) Datensicherung SQL-Server 2014
2) SQL-Server 2016 parallel installiert
3) Import Datensicherung in SQL-2016

4) Ab dem Zeitpunkt konnten wir uns mit den einzelnen Clients nicht mehr anmelden und bekommen nun immer diese Fehlermeldung:

1543411094218.png

Als Hintergrundinfo:
Wir haben einen Virtuellen Windows-Server bei Strato.

5) Wir können uns jedoch vom Server selbst (per Remotedesktopverbindung) mit der JTL- Wawi bei der neuen SQL-Server 2016 anmelden. Da klappt es reibungslos.
Nur wenn wir uns mit einem anderen Rechner verbinden wollen, dann kommt die besagte Fehlermeldung.

6) Da der Windows-Server diverse Updates, auch zur SQL-Datenbank angeboten hat, haben wir in der Hoffnung auf mögliche Besserung alle wichtigen Updates auf dem Server durchgeführt.
Jedoch hat auch dies keine Veränderung gebracht.

7) Danach haben wir den SQL-Server-2014 deinstalliert, da es Meinungen dazu gab, dass beide SQL-Server nebeneinander sich eventuell stören könnten!
Jedoch hat auch dies keine Veränderung bei unserem Problem ergeben und selbe Fehlermeldung kommt weiterhin.

Nun hoffe ich, dass jemand eine Idee hat woran es liegen könnte, da bis vor der Installation vom SQL Server 2016 alles reibungslos funktionierte.

Ich danke schon mal allen die Helfen oder Tipps bieten können.
Gruß Andreas
 

deliman

Gut bekanntes Mitglied
13. Februar 2016
469
22
#2
Hallo,

ein Backup vom Stand vor der Installation/Löschung SQL 2014 gibt es, oder?

Ich habe vor Kurzem ein Inplace-Upgrade von 2014 Express auf 2017 Express gemacht, was prinzipiell funktioniert hat. Da gibt es schon einen Thread wo ich auch eine Fehlermeldung und die Lösung beschreibe, die ich dabei hatte. Evt. also das Backup einspielen und dann keine extra Neuinstallation vom SQL Server 2016 sondern ein Inplace Upgrade machen. Im Installationsfenster vom SQL Server müsste das das mittlere Feld sein, wo man eine vorhandene SQL Instanz updaten kann. Bei mir liegt der SQL Server allerdings auf meinem physischen Server hier im Büro.
 

gnarx

Sehr aktives Mitglied
18. Januar 2018
1.505
84
#3
Also bei uns war es die Namensauflösung mit dem SQL Server 2016 Standard. Seit dem wir statt des Servernamens die IP nutzen funzt es.
Außerdem sollte man das Datenverbindungstool als Admin ausführen.
 

Rosi123

Neues Mitglied
10. Dezember 2018
2
0
#4
Habt ihr mal die Firewall Einstellungen am Server kontrolliert?
Der 16er ist i.d.R. in einem anderen Verzeichnis installiert, sodass ggf eine manuelle Firewall Freigabe gesetzt werden muss...

LG
Rosi
 

Ähnliche Themen