Neu Nach der Installation ist der Shop5 aufrufbar, jedoch das Backend nicht.

selman

Aktives Mitglied
1. Oktober 2018
3
0
Hallo,

ich habe gestern den Shop 5 auf den Webserver (All-Inkl.) installiert. Der Shop ist erreichbar, aber leider das Backend /admin nicht. Ich bekomme die Fehlermeldung: http Error 500

Habe dann diese Anweisung durchgeführt (https://guide.jtl-software.de/jtl-s...-jtl-shop-abgleich-angezeigt-was-soll-ich-tun) und folgende Fehlermeldung erhalten:



Warning: include(/www/htdocs/w01e154e/mein-shop.de/includes/vendor/composer/../league/container/src/Inflector/InflectorAggregate.php): Failed to open stream: No such file or directory in /www/htdocs/w01e154e/mein-shop.de/includes/vendor/composer/ClassLoader.php on line 571

Warning
: include(/www/htdocs/w01e154e/mein-shop.de/includes/vendor/composer/../league/container/src/Inflector/InflectorAggregate.php): Failed to open stream: No such file or directory in /www/htdocs/w01e154e/mein-shop.de/includes/vendor/composer/ClassLoader.php on line 571

Warning
: include(): Failed opening '/www/htdocs/w01e154e/mein-shop.de/includes/vendor/composer/../league/container/src/Inflector/InflectorAggregate.php' for inclusion (include_path='.:/usr/share/php:..') in /www/htdocs/w01e154e/mein-shop.de/includes/vendor/composer/ClassLoader.php on line 571

Fatal error
: Uncaught Error: Class "League\Container\Inflector\InflectorAggregate" not found in /www/htdocs/w01e154e/hundeshop-fiffi.de/includes/vendor/league/container/src/Container.php:49 Stack trace: #0 /www/htdocs/w01e154e/mein-shop.de/includes/src/Router/BackendRouter.php(147): League\Container\Container->__construct() #1 /www/htdocs/w01e154e/mein-shop.de/admin/index.php(14): JTL\Router\BackendRouter->__construct(Object(JTL\DB\NiceDB), Object(JTL\Cache\JTLCache), Object(JTL\Backend\AdminAccount), Object(JTL\Services\JTL\AlertService), Object(JTL\L10n\GetText), Object(JTL\Smarty\BackendSmarty)) #2 {main} thrown in /www/htdocs/w01e154e/mein-shop.de/includes/vendor/league/container/src/Container.php on line 49


Es würde mich sehr freuen, wenn Ihr mir helfen könnt 🙂
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
952
203
Ich denke das hier bereits ein Support Ticket erstellt wurde, deshalb die gleiche Antwort wie im Supportticket, hier auch aufgezeigt.

Bitte prüfen Sie ob sie wirklich alle Dateien korrekt hochgeladen haben und WICHTIG auch
im binären Modus übertragen haben. Auch ob alle verzeichnisrechte korrekt sind.
 

RoKo

Aktives Mitglied
19. Oktober 2011
42
1
Hallo Selman

Hast Du Dein Problem gelöst bekommen? Ich habe von 5.1.5 auf 5.2.4 aktualisiert und habe genau das gleiche, wobei ich beim ersten Versuch hat das Frontend auch "auf den ersten Blick" funktioniert, da habe ich aber vermutlich vergessen den Cache zu löschen.
Ich habe überprüft dass ALLE Dateien hochgeladen sind, auch auch den BINÄREN Modus, Verzeichnisrechte sind ok.
Aber: ich habe auch Allinkl als Hoster, das hat mich hellhörig gemacht!

die .htaccess in /admin habe ich auch mit überschrieben, die hat sich ja laut weiterem Forumsbeitrag verändert.
Ich habe das Update jetzt zum zweiten Mal nicht geschafft

Bei eingeschaltetem Debug bekomme ich im Frontend:
Deprecated: JTL\ShopBC::getConfigValue is deprecated - use JTL\Shop::getSettingValue() instead. in /www/htdocs/v12345/meinedomainde/shop/includes/src/ShopBC.php on line 308

Ich habe wirklich keine Idee mehr, freue mich über jede Anregung

Danke, Roman
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.651
2.702
Berlin
Firma
css-umsetzung
Was ist mit den Plugins die installiert sind?
Es muss darauf geachtet werden das diese auch Shop 5.2 kompatibel sind.
 

Ähnliche Themen