Offen Minifizieren / Komprimieren von CSS + JS - falsche Server-Einstellungen (Hosteurope)?

Der_Bob

Gut bekanntes Mitglied
10. August 2007
222
9
Servus,

Bei uns funktioniert leider das Minifizieren von CSS + JS nicht richtig. Wir nutzen ein Child-Template, haben aber auch testweise das unveränderte EVO-Template aktiviert, bei dem das gleiche Problem besteht. Sobald wir die Option "Komprimierung von JavaScript- und CSS-Dateien" (+ Komprimierung des HTML-Ausgabedokuments + Komprimierung von Inline-JavaScript-Code + Komprimierung von Inline-CSS-Code) aktivieren, werden keine JS-Funktionen mehr geladen, das macht sich schon beim Slider auf der Startseite oder dem Mega-Menü (klappt nicht mehr auf) bemerkbar.
Wie wir bereits versucht haben, das Problem zu fixen aufgrund von ähnlichen Forenbeiträgen (erfolglos):

- Template-Cache geleert und Seite mit STRG + F5 neu geladen
- Ursprüngliches EVO-Template aktiviert
- Unveränderte .htaccess hochgeladen (+ Zusatz für Passwortschutz)

Habt Ihr eine Idee, wo das Problem sein könnte bzw. hatte jemand das gleiche Problem bei Hosteurope? Bisher tippen wir auf die Server-Einstellungen, allerdings seh' ich nicht, woran es liegen könnte. phpinfo zeigt:

Loaded Modules [...] mod_deflate [..]
HTTP_ACCEPT_ENCODING gzip, deflate

Viele Grüße,
Marcus
 

timmehosting

Aktives Mitglied
25. Juli 2016
36
4
Gibt es im Error-Log der Website eine Fehlermeldung, die mit dem Problem in Zusammenhang stehen könnte?
 

Der_Bob

Gut bekanntes Mitglied
10. August 2007
222
9
Ich bin mir nicht sicher, ob ich das richtige Error-Log meine, aber das, was ich mit F12 -> Console / Konsole einsehen kann, zeigt in FireFox keine Fehler und in Chrome:

Uncaught SyntaxError: missing ) after argument list [JTL]/asset/jtl3.js?v=4.03
Uncaught TypeError: slider.nivoSlider is not a function [JTL]/:458

Erster Fehler sieht natürlich relativ verdächtig aus, allerdings habe ich meines Erachtens nichts in der angegebenen Datei verändert. Ich nehm' mal nicht an, dass das "von Haus aus" bei der V 4.04 eine Klammer fehlt, oder?
 

timmehosting

Aktives Mitglied
25. Juli 2016
36
4
Ich meine das Error-Log der Website auf dem Server. Wenn Du Dich da per FTP oder SSH einloggst, vermute ich, daß es da einen entsprechenden Ordner gibt, wo die Logs liegen.
 

Der_Bob

Gut bekanntes Mitglied
10. August 2007
222
9
Ich meine das Error-Log der Website auf dem Server. Wenn Du Dich da per FTP oder SSH einloggst, vermute ich, daß es da einen entsprechenden Ordner gibt, wo die Logs liegen.

Ok, das ist bei hosteurope anscheinend etwas anders. Einen Ordner mit den logs gibt's nicht, aber man kann die Errorlogs im Backend einsehen.
Leider ist dort nichts Auffälliges. Zwar ein Fehler, der auch nicht sein sollte, aber nur selten auftritt und nur die cron_exportformate.php betrifft. Sonst kein entsprechender Fehler ersichtlich.
 

Der_Bob

Gut bekanntes Mitglied
10. August 2007
222
9
Hat sonst niemand sonst ein Problem mit der Minifizierungs-Funktion?
Wir suchen seit Wochen eine Lösung, aber haben keinerlei Ansatzpunkt, da wir keine Fehlermeldung o.Ä. bekommen und weder unser Provider, noch der JTL-Support kann uns (kostenpflichtig) weiter helfen.
 

Der_Bob

Gut bekanntes Mitglied
10. August 2007
222
9
Problem gelöst!
Würde gern den Kopf auf den Tisch hauen, befürchte aber, dass ich das bereuen würde.

Ich mach's kurz: Es gab eine JS-Datei, die mit minifiziert wurde und in der mit <!-- statt // oder /* kommentiert wurde! In meinem Editor wurde das (wahrscheinlich genauso wie beim Ersteller) trotzdem als Kommentar farblich markiert, führte aber dazu, dass in de minifizierten Datei 4 Funktionen später eine Klammer fehlende Klammer angezeigt wurde (was an der Stelle natürlich sinnlos war). Also nach wochenlanger Suche <!-- abgeändert in /* und Minifizierung funktioniert...
 

ag-websolutions.de

Sehr aktives Mitglied
29. Dezember 2009
14.548
233
Vielen Dank für deine Rückmeldung!

Handelt es sich bei der js-Datei um eine im Paket mit ausgelieferte Datei oder wo kommt die her?
 

Ähnliche Themen