In Bearbeitung Lieferstatus anhand der Beschaffungszeit setzen

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

KostjaThomas

Aktives Mitglied
13. Januar 2017
71
2
#1
Hallo, der Connector zu Gambio setzt den Lieferstatus leider nicht anhand der Beschaffungszeit, sondern nur die einfach nur die Anzahl der Tage. Im Shop werden dann Lieferzeiten wie "0 Tage" statt "sofort lieferbar - 2-3 Tage" oder "60 Tage" statt z.B. "6-8 Wochen" angezeigt. Ich würde mir wünschen, daß zu der automatisch ermittelten Beschaffungszeit des Artikels in Gambio der dazu passenden Liefetrstats gesetzt wird. Jedem Lieferstaus in Gambio ist ja auch die dazugeörige Lieferzeit in Tagen zugeordnet, das sollte also möglich sein. Also als Beispiel, die automatsiche Beschaffungszeit ist Null, da der Artikel auf Lager ist, der Connector setzt nun den Lieferstatus "auf Lager 2-3 Tage", dem ich in Gambio die Liefezeit in Tagen 0 zugeordnet habe. Im Moment hinterlegt der Connektor einfach einen neuen Lieferstatus, der dann wie gesagt einfach 0 Tage heißt. Ich weiß, daß ich den Lieferstatus im Artikel entsprechende unter sonstiges setzen kann und dieser dann auch korrekt in Gambio gesetzt wird. Dann muss ich aber für alle Artikel diesen Status manuell pflegen, bei über 35.000 Varianten ist das natürlich nicht möglich... Ich habe schon versucht, das per Workflow zu steuern, aber hier steht mir die automatsich ermittelte Bechaffungszeit nicht zur Verfügung bzw. ich hab's nicht gefunden. Zu diesem Ansatz habe ich einen separaten Forumbeitrag in den Workflows erstellt. Hier frage ich nach einer Connector-seitigen also idealen Lösung.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
318
50
#5
Ich habe mir gerade nochmal deinen Beitrag durchgelesen und erst jetzt verstanden was du möchtest. Wir werden das intern besprechen, ob man das sinnvoll allgemein für den Connector abbilden kann oder nicht. Unabhängig davon kannst du ein Connector Plugin schreiben, welches den Connector um genau diese Funktionalität erweitert.
 

KostjaThomas

Aktives Mitglied
13. Januar 2017
71
2
#6
OK, ich könnte als Zwischenlösung per Ameise die Lieferantenlieferzeit auf die zusätzliche Beschaffungszeit kopieren, dann müsste man das mit eine Workflow regeln können. Ist aber keine Ideallösung...
Gibt es ein Tutorial zu Verwirklichung von Connector Plugins? Ich habe nicht damit noch nie befasst. Der Gambio Connector ist ja leider immernoch mit vielen zum Teil krassen Fehlern behaftet, da liese sich einiges verbessern...
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
318
50
#7
Unter folgendem Link gibt es ein paar Infos bzgl. Connector Plugins: http://docs.jtl-connector.de/en/latest/plugins/index.html

Der Gambio Connector ist ja leider immernoch mit vielen zum Teil krassen Fehlern behaftet, da liese sich einiges verbessern...
Wir freuen uns, wenn wir den Connector verbessern können. Allerdings müssten wir auch wissen was verbessert werden kann. Schick uns einfach mal deine Verbesserungsvorschläge, dann können wir weiter schauen.
 

KostjaThomas

Aktives Mitglied
13. Januar 2017
71
2
#8
Hier eine kurze Auflistung der Fehler, die mir im Moment dazu einfallen:

1. fataler Fehler: Bei neu angelegten Artikel mit Varianten wird kein Eintrag in der Tabelle products_properties_admin_select erzeugt. Das hat zur Folge, daß man Varianten im Gambio Backend nicht mehr bearbeiten kann. Das Backend hängt sich dadurch mit einer Fehlermeldung auf. Das hat zwar keine Auswirkung im Frontend, trotzdem gibt es durchaus Situationen, in denem man doch darauf angewiesen ist, im Backend Ändrungen vorzunehmen. Außerdem macht man sich sozusagen von JTL abhängig, weil man in Gambio ohne JTL keine Chance mehr hat, Artikel zu bearbeiten.
2. Obwohl wir nur Preise, Texte oder Bilder in JTL anpassen und auf alle Varinaten vererben, werden zum Teil bereits vorhandene Artikel in Gambio mit allem Varianten gelöscht und komplett neu angelegt. Wann genau gelöscht und wann aktualisiert wird konnte ich noch nicht nachvollziehen. Die Konsequenz ist allerdings auch fatal. Die betroffenen Artikel sind in aktuellen Warenkörben und Merkzetteln der Kunden dann ncht mehr vorhanden, weil diese anhand der Artikel IDs in die Datenbank gespeichert werden, diese dann ja neu vergeben wurde. Die Artikelstatistik ist damit dann auch gelöscht und fängt wieder bei Null an. Sehr unschön.
3. Die Online- Shop-Suchbegriffe (in den Artikelstammdaten unter Sonstiges) werden weder importiert noch exportiert, so daß wir nach Anlegen von neuen Artikeln immer noch ins Backend müssen, um diese nachzutragen. (habe ich schon mal gemeldet)
4. Die Bilder bekommen in Gambio einen weißen Rand die das Bild auf das quadratische Format auffüllen (auch bereits gemeldet)
5. Das Leeren des Cache wird in Gambio nicht vollständig ausgelöst, so daß neue Artikel erst dann in Gambio sichtbar werden, wenn man im Backend den Cache manuell leert (auch schon gemeldet)

Wenn mir noch etwas auffällt/einfällt, werde ich es noch ergänzen. Ich bin gerne bereit, Aktualisierungen/Anpassungen diesbezüglich im Livebetrieb zu testen, wenn das behilflich ist.

Noch etwas:
6. "Neu im Sortiment seit" wird nicht exprotiert. Artikel. die schon länger offline angelegt sind, würde ich gerne im Shop mit "neu" kennzeichnen. Dazu diesent ja die Option "Neu im Sortiment seit" auf "Datum von heute" umzustellen. Wird aber leider nicht an Gambio exportiert, sondern immer das JTL-Einstelldatum. Wenn ich es dann manuell in der Gambio Datenbank überschreibe, wird es im nächsten Update wieder überschrieben.
 
Zustimmungen: Benjamin Schaffrath

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
102
13
#9
Hallo KostjaThomas,

Hier eine kurze Auflistung der Fehler, die mir im Moment dazu einfallen:
1. fataler Fehler: Bei neu angelegten Artikel mit Varianten wird kein Eintrag in der Tabelle products_properties_admin_select erzeugt. Das hat zur Folge, daß man Varianten im Gambio Backend nicht mehr bearbeiten kann. Das Backend hängt sich dadurch mit einer Fehlermeldung auf. Das hat zwar keine Auswirkung im Frontend, trotzdem gibt es durchaus Situationen, in denem man doch darauf angewiesen ist, im Backend Ändrungen vorzunehmen. Außerdem macht man sich sozusagen von JTL abhängig, weil man in Gambio ohne JTL keine Chance mehr hat, Artikel zu bearbeiten.
Den Fehler konnte ich mit Gambio Version: 3.11.2.0, Connector Version: 2.9.7 und Wawi Version: 1.4.29.1 nicht nachstellen. Unter Artikel -> Bearbeiten Dropdown -> Attribute Editieren, konnte ich sowohl Einfache Variationen als auch Variationskombinationen editieren. Es wäre super wenn du näher beschreiben könntest wie es zu dem Fehler kommt :)

2. Obwohl wir nur Preise, Texte oder Bilder in JTL anpassen und auf alle Varinaten vererben, werden zum Teil bereits vorhandene Artikel in Gambio mit allem Varianten gelöscht und komplett neu angelegt. Wann genau gelöscht und wann aktualisiert wird konnte ich noch nicht nachvollziehen. Die Konsequenz ist allerdings auch fatal. Die betroffenen Artikel sind in aktuellen Warenkörben und Merkzetteln der Kunden dann ncht mehr vorhanden, weil diese anhand der Artikel IDs in die Datenbank gespeichert werden, diese dann ja neu vergeben wurde. Die Artikelstatistik ist damit dann auch gelöscht und fängt wieder bei Null an. Sehr unschön.
Auch dieses verhalten konnte ich mit den oben genannten Versionen nicht nachstellen. Artikel wurden nur gelöscht / neu angelegt wenn dies in der Wawi so gewollt war. (Artikel Deaktiviert -> Aktiviert)
3. Die Online-Shop-Suchbegriffe (in den Artikelstammdaten unter Sonstiges) werden weder importiert noch exportiert, so daß wir nach Anlegen von neuen Artikeln immer noch ins Backend müssen, um diese nachzutragen. (habe ich schon mal gemeldet)
Die Onlineshop-Suchbegriffe werden nicht unterstützt, jedoch werden die Metadaten vom Connector genutzt:
1560328083432.png
4. Die Bilder bekommen in Gambio einen weißen Rand die das Bild auf das quadratische Format auffüllen (auch bereits gemeldet)
Nach der ursprünglichen Meldung wurde ein Ticket erstellt, über diesen Link kannst du jederzeit Status abrufen: https://issues.jtl-software.de/issues/CO-509
5. Das Leeren des Cache wird in Gambio nicht vollständig ausgelöst, so daß neue Artikel erst dann in Gambio sichtbar werden, wenn man im Backend den Cache manuell leert (auch schon gemeldet)
Auch dieses Problem konnte ich nicht nachstellen. Eventuell gibt es ein Caching seitens des Servers, welches das Problem verursacht.
6. "Neu im Sortiment seit" wird nicht exprotiert. Artikel. die schon länger offline angelegt sind, würde ich gerne im Shop mit "neu" kennzeichnen. Dazu diesent ja die Option "Neu im Sortiment seit" auf "Datum von heute" umzustellen. Wird aber leider nicht an Gambio exportiert, sondern immer das JTL-Einstelldatum. Wenn ich es dann manuell in der Gambio Datenbank überschreibe, wird es im nächsten Update wieder überschrieben.
Die Funktion "Neu im Sortiment" wird aktuell vom Connector nicht unterstützt, ich habe dazu mal ein Ticket angelegt, damit es bald implementiert wird: https://issues.jtl-software.de/issues/CO-519
 

KostjaThomas

Aktives Mitglied
13. Januar 2017
71
2
#10
Ok, gehen wir das im Einzelnen durch.

1. Hier geht es nicht um Attribute sondern um Eigenschaften. Attribute werden in Gambio kaum noch verwendet und soweit ich weiß in Zukunft auch nicht mehr groß unterstützt. Wie gesagt, fehlt bei neu angelegten Artiken mit Eigenschaften (da hatte ich mich undeutlich ausgedrückt), der Eintrag in die Tabelle products_properties_admin_select, weswegen im Backend dem Artikel die Zuweisung der Eigenschaftenkombinationen fehlt und die Eigenschaften nicht mehr editierbar sind. ich habe mir das in den Tabellen genauer angeschaut, der Eintrag in products_properties_admin_select fehlt definitiv (also zumindest bei mir).

2. Wann genau dieser Fehler auftritt, konnte ich bisher leider nicht nachvollziehen, kommt aber definitiv vor. Müsste man im Connector ergründen, ob dort bei bestimmten Configurationen so vorgegangen wird, also alles löschen und neu anlegen. Meine Vermutung ist, daß das passiert, wenn Daten komplett auf die Varinaten vererbt werden odr aber wenn der Artikeltitel verändert wird? Konnte ich aber bisher nicht nicht verifizieren.

3. Das die Metadaten Suchbegriffe exportiert werden ist mir bekannt - so weit so gut - , fast wichtiger für einen ordentlichen Shopbetrieb wären die Suchbegriffe für den Shop. Was nützt die Suchfunktion im Shop, wenn aufgrund der fehlenden Suchbegriffe Artikel nicht gefunden werden... Wir müssen das wie gesagt im Monet für jeden Artikel im Gambio Backend nachtragen, sehr umständlich ... Wäre also eigentlich zwingend, daß das in Zukunft unterstützt wird.

4. OK.

5. Das Probem konnte ein Kollege schon nachstellen (zunächst bei mir im System per Fernwartung, dann auch selbst). Es könnte auch schon ein Ticket dazu existieren. Wenn ein neuer Artikel erstellt wird (durch duplizieren eines schon vorhanden Artikels in JTL), fehlt das Ausführen des "Cache für Artikel- und Kategoriezuordnungen neu erzeugen". Neue Artikel werden deswegen in der jeweiligen Rubrik nicht dargestellt, nur unter "neu" oder wenn man den Artikel explizit sucht. Nach manuellem Ausführen des Cache, ist der Artikel dann auch in der jeweiligen Rubrik sichtbar.

6. Wäre schön, da Artikel manchmal bei uns schon länger in JTL angelegt sind aber erst später in den Shop exportiert werden.

Wir können das gerne auch mal zusammen auf meinem System nachstellen (bis auf 2.), wenn es hilfreich ist.
 

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
102
13
#11
Ok, gehen wir das im Einzelnen durch.

1. Hier geht es nicht um Attribute sondern um Eigenschaften. Attribute werden in Gambio kaum noch verwendet und soweit ich weiß in Zukunft auch nicht mehr groß unterstützt. Wie gesagt, fehlt bei neu angelegten Artiken mit Eigenschaften (da hatte ich mich undeutlich ausgedrückt), der Eintrag in die Tabelle products_properties_admin_select, weswegen im Backend dem Artikel die Zuweisung der Eigenschaftenkombinationen fehlt und die Eigenschaften nicht mehr editierbar sind. ich habe mir das in den Tabellen genauer angeschaut, der Eintrag in products_properties_admin_select fehlt definitiv (also zumindest bei mir).

2. Wann genau dieser Fehler auftritt, konnte ich bisher leider nicht nachvollziehen, kommt aber definitiv vor. Müsste man im Connector ergründen, ob dort bei bestimmten Configurationen so vorgegangen wird, also alles löschen und neu anlegen. Meine Vermutung ist, daß das passiert, wenn Daten komplett auf die Varinaten vererbt werden odr aber wenn der Artikeltitel verändert wird? Konnte ich aber bisher nicht nicht verifizieren.

3. Das die Metadaten Suchbegriffe exportiert werden ist mir bekannt - so weit so gut - , fast wichtiger für einen ordentlichen Shopbetrieb wären die Suchbegriffe für den Shop. Was nützt die Suchfunktion im Shop, wenn aufgrund der fehlenden Suchbegriffe Artikel nicht gefunden werden... Wir müssen das wie gesagt im Monet für jeden Artikel im Gambio Backend nachtragen, sehr umständlich ... Wäre also eigentlich zwingend, daß das in Zukunft unterstützt wird.

4. OK.

5. Das Probem konnte ein Kollege schon nachstellen (zunächst bei mir im System per Fernwartung, dann auch selbst). Es könnte auch schon ein Ticket dazu existieren. Wenn ein neuer Artikel erstellt wird (durch duplizieren eines schon vorhanden Artikels in JTL), fehlt das Ausführen des "Cache für Artikel- und Kategoriezuordnungen neu erzeugen". Neue Artikel werden deswegen in der jeweiligen Rubrik nicht dargestellt, nur unter "neu" oder wenn man den Artikel explizit sucht. Nach manuellem Ausführen des Cache, ist der Artikel dann auch in der jeweiligen Rubrik sichtbar.

6. Wäre schön, da Artikel manchmal bei uns schon länger in JTL angelegt sind aber erst später in den Shop exportiert werden.

Wir können das gerne auch mal zusammen auf meinem System nachstellen (bis auf 2.), wenn es hilfreich ist.
Morgen,

1. Das Problem mit den Eigenschaften würde ich mir gerne mal bei dir anschauen.

3. Man könnte das Verhalten hier so ändern, dass die Metadaten gleichzeitig als Suchbegriffe eingetragen werden. Das Problem an den Onlineshop-Suchbegriffen ist, dass diese nicht übersetzbar sind.

5. Auch das würde ich mir gerne mal ansehen, wenn möglich.

Wie würde es bei dir denn zeitlich passen?