Neu Kundenzuordnung nach Umstieg von modified zu JTL-Shop in der Wawi.

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

Bicho

Neues Mitglied
11. Juni 2018
3
0
#1
Hallo Community,

ich bin am vergangenen Wochenende mit meinem Shop von modified auf JTL-Shop 4.0 umgestiegen.
Weitestgehend hat alles geklappt und Bestellung trudeln auch schon auf dem JTL-Shop ein.

Nun ist mir etwas aufgefallen, wo ich ad-hoc nicht weiterkomme.
Ich hatte zuvor die Kundenadressen aus dem modified-shop exportiert und in den JTL-Shop importiert. Alles gemäß der Anleitung unter
https://guide.jtl-software.de/Migration_von_XTC_auf_JTL-Shop
Hatte soweit auch alles geklappt.

Allerdings stelle ich heute folgendes Problem fest.
Ein Kunde bestellt und anhand der Kundennummer in der JTL- WaWi stelle ich fest das es ein "Alt"-Kunde ist und schaue es mir etwas genauer an. Die WaWi hat die Kundennr 2145 erkannt. Allerdings stelle ich bei genauerer Betrachtung fest das die Kundennummer des Kunden die 4203 ist. Die 2145 war einem anderem Kunden zuvor zugeordnet.

Was könnte hier zu dem durcheinander geführt haben? Sind die Kundennummern aus dem Shop evtl. nicht sauber mit denen aus der Wawi gemappt?

Hat jemand eine Idee? Sollte ich die Kunden im Shop evtl. wieder löschen, bevor es zu schwerwiegenderen Problemen kommt, oder kann ich das irgendwie noch bereinigen?

Danke schon mal vorab.
 

JulianG

Moderator
Mitarbeiter
14. November 2013
295
40
#2
Hallo Bicho,

der Shop hat eigentlich keine Kundennummer. Es gibt zwar ein Feld dafür, dieses wird aber nur dann gefüllt, wenn man in JTL- Wawi in den Kundendetails auf "In allen Onlineshops aktualisieren" klickt. Dadurch wird dann die Wawi-Kundennummer an das Shop-Konto (falls überhaupt vorhanden) übersendet.

Ich gehe davon aus, dass dein JTL-Shop vorher komplett neu und leer war? Hat der JTL-Shop eine eigene "neue" Shop-Anbindung erhalten; oder hattest du den XTC via Connector verbunden und dessen Zugangsdaten durch die des JTL-Shop ersetzt?
 

Bicho

Neues Mitglied
11. Juni 2018
3
0
#3
...
Ich gehe davon aus, dass dein JTL-Shop vorher komplett neu und leer war? Hat der JTL-Shop eine eigene "neue" Shop-Anbindung erhalten; oder hattest du den XTC via Connector verbunden und dessen Zugangsdaten durch die des JTL-Shop ersetzt?
Erst einmal vielen Dank für die Antwort.

Ja, es stimmt, der Shop war neu und leer.

Und es stimmt auch das ich die vorhandene Anbindung überschrieben habe und nicht neu erstellt habe. Dieser Gedanke ist mir auch schon gekommen, meinst du es könnte daran liegen?
 

JulianG

Moderator
Mitarbeiter
14. November 2013
295
40
#4
Es wird definitiv daran liegen, wenn du beim Überschreiben der Anbindung nicht den Button "Onlineshopdaten zurücksetzen" geklickt hast:
JTL-Wawi-2018-06-29-10-36-51.jpg
Das ist natürlich ein sehr gefährlicher Button, aber genau für den Fall gedacht, dass sich das Shopsystem in der selben Shop-Anbindung ändert. Im neuen Shopsystem fängt ja der interne Schlüssel (kKunde) für Kunden wieder neu an zu zählen. Das gilt auch für die Import-Reihenfolge wenn Kundendaten im Shop-Backend importiert werden.
Wenn nun die internen Shop-Schlüssel (kKunde) nicht mehr zu den internen Wawi-Shop-Schlüsseln (kInetKunde) passen, dann ist die Zuordnung falsch.

Wenn der Button hingegen gedrückt wird, sind alle diese Verbindungen aufgehoben. Das kann dann zwar bedeuten, dass manche Kundenkonten später in der Wawi doppelt auftauchen weil nicht korrekt gematched wird (eine Änderung der Adresse bedeutet -> Es wird nicht von der Wawi auf ein bestehendes Konto gematched; nur wenn 1:1 das gleiche kommt wird automatisch zugordnet), aber dafür sind dann keine Kundenkonten falsch verbunden.

Im Grunde hast du dann keine andere Wahl, als jetzt eine Wawi-Backup-Sicherung zu machen, und dann den Button jetzt noch nachträglich zu drücken. Das bedeutet, dass auch jetzt ggf. richtige Verknüpfungen verloren gehen. Damit kannst du z.B. auch keine Kundengruppen-Änderungen mehr vornehmen, bis erneut die Kundendaten vom Shop in die Wawi gekommen sind. Auch Bestellupdates können keine mehr versendet werden, das bedeutet: Bevor du das machst, musst du alle Shop-Bestellungen die in JTL-Wawi sind abgeschlossen haben, oder damit leben, dass manche Kunden ggf. keine Versand-Email, Bezahlt-Email, Storniert-Email erhalten (oder du versendest diese dann aus JTL-Wawi heraus).
 
Zustimmungen: Bicho

Bicho

Neues Mitglied
11. Juni 2018
3
0
#5
Danke für die Antwort.
Ich denke das könnte mein Problem beheben.

Bin nun aus meinem Urlaub zurück und habe nun den Button gemäß anleitung gedrückt, und werde die nächsten Bestellung mal beobachten.

Vilen Dank nochmals