Neu Keine Bild-Links mehr im Shopware Produktexport (Varianten Lösung)

AQH

Mitglied
21. August 2019
9
0
Hallo,

nach dem Connector-Update auf 2.8.6 werden neu synchronisierte Bilder (genauer: deren Links) nicht mehr im Produktexport ausgegeben, wenn man die Shopware Varianten-Lösung einsetzt.
Code:
{assign var="string" value=$sArticle.articleID|articleImages:$sArticle.ordernumber:2:"##"|escape}
{assign var="productVariantImage" value="##"|explode:$string}
...
<g:image_link>{$productVariantImage[0]}</g:image_link>
Mit der Standard-Version (also nur der Bild-Link vom Vater) funktioniert es:
Code:
<g:image_link>{$sArticle.image|image:1}</g:image_link>
Zuerst waren nur Artikel betroffen, die nach dem Connector Update geändert wurden oder neu waren. Wir hatten dann einen Komplettabgleich der Bilder vorgenommen in der Hoffnung, dass das wieder irgendwas gerade biegt... jetzt funktioniert die Varianten-Lösung bei keinem Artikel mehr. Nur noch Standard.
 

AQH

Mitglied
21. August 2019
9
0
Hallo (nochmal),

durch Zufall hat sich aus einem Gepräch ergeben, dass das o.a. Problem auch bei einem Bekannten auftritt. Ich hätte also schon zwei unabhängige Systeme wo dieses Problem auftritt. Wir haben auch einmal unsere Versionen verglichen:

System 1: WAWI v1.5.36.2, Connector v2.8.6, Shopware v5.6.9 -> funktionierte vor Update mit Connector v2.8.3
System 2: WAWI v1.5.36.2, Connector v2.8.6, Shopware v5.6.8 -> funktionierte vor Update mit Connector v2.5.4

Ansonsten wurde an den Systemen nichts geändert. Im Übrigen ist die $string Variable bis auf die "##"-Trennzeichen leer. D.h. bei nur einem hinterlegten Bild ist die Variable komplett leer, bei zwei Bildern enthält sie "##", bei drei "####" usw.

Ich hoffe diese Infos helfen etwas weiter. Wäre schon gut, wenn das wieder funktioniert...
 

AQH

Mitglied
21. August 2019
9
0
Hallo Immanuel,

meinst Du unsere Exportvorlage oder wo man die generell findet? Wir haben mehrere... überall das gleiche. Haben es eben auch mit der hauseigenen von Shopware probiert (Google Produktsuche XML) -> das selbe Problem. D.h. läßt man sie wie sie ist, gibt es die Links zu den Bildern. Ändert man sie für Variantenbilder ab (wie unter https://docs.shopware.com/de/shopware-5-de/marketing-und-einkaufswelten/produktexporte beschrieben), fehlen die Links zu den Bildern (wie im ersten Post beschrieben). Wir können uns das auch gerne live anschauen, wenn's hilft.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu 1.5.x - Worker-Service holt keine Währungen? JTL-Wawi - Fehler und Bugs 0
Neu Keine Anzeige von Benutzern im WMS Mobile Server User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Kasse kann keine Verbindung zum TSE herstellen nach letztem Update JTL-POS - Fehler und Bugs 1
Neu Keine Exportdokumente bei Freiposition User helfen Usern - Fragen zu JTL-Wawi 0
Neu Trotz Multishop keine zweite Shop-Anbindung Onlineshop-Anbindung 2
Umleitungsfehler beim Aufruf der Startseite - Keine WAWI-Anbindung möglich Einrichtung JTL-Shop5 0
Neu Google Exportformat: Feed für Google Shopping enthält keine Kindartikel Betrieb / Pflege von JTL-Shop 2
Neu Keine Versandart für B2B Kunden im JTL Auswählbar... User helfen Usern - Fragen zu JTL-Wawi 9
Neu Amazon Briefpost keine Sendungsnummer wird hochgeladen. Lösung ? Amazon-Lister - Ideen, Lob und Kritik 1
Beantwortet LS POS 2.0.0 Fehler - keine Kassen-OID Fragen rund um LS-POS 1
Neu Im Popup "Versand" keine Inhalte aus OPC JTL-Shop - Fehler und Bugs 2
Neu Kundenkonto: Kein Zugriff des Kunden möglich, Fehlfunktionen, keine Anmeldung JTL-Shop - Fehler und Bugs 0
Neu Auftragsexport XML --> HAN zu SKU mit ausgeben --> keine passende Variable Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Keine Datenbankverbindung Installation von JTL-Wawi 6
Gelöst Seit Update der Android App auf V 1.0.4.3 keine Kartenzahlung mit Zettle by Paypal möglich JTL-POS - Fehler und Bugs 3
Neu Gelöst: Hosting JTL-Wawi (SQL-Datenbank) - Keine Verbindung zur Datenbank Individuelle Listenansichten in der JTL-Wawi 4
Neu Artikelübersicht im Shop, keine Sortierung möglich JTL-Wawi - Fehler und Bugs 0
Neu Bestellung versendt - keine eMail bei unregestrierten Kunden Allgemeine Fragen zu JTL-Shop 0
SUBSCRIPTION - Vorübergehend keine Informationen verfügbar Upgrade JTL-Shop4 auf JTL-Shop5 3
Neu Kann keine Rechnungen via JTLwawiExtern.Dll speichern JTL-Wawi - Fehler und Bugs 2
Neu Product-Stream zeigt keine Kategorieauswahl JTL-Shop - Fehler und Bugs 0
Neu Fehlermeldung beim Import "Keine Multishop Lizenz vorhanden" weil aus versehen 2 Connectoreinträge zum gleichen Shop angelegt wurden. Allgemeines zu den JTL-Connectoren 1
Neu Connector schließt keine Bestellung in Shopware ab Shopware-Connector 6
Neu Artikel direkt in Seller Central anlegen > keine FNSKU-Übernahme in die WaWi-Artikel Amazon-Anbindung - Fehler und Bugs 1
Neu Umsatzsteuer-Berechnungsservice VCS Lite sendet keine Rechnungen für Business-Kunden???? Arbeitsabläufe in JTL-Wawi 1
Neu Shop 5.0.1 versendet keine Newsletter - Warteschlange leer JTL-Shop - Fehler und Bugs 0
Neu Keine Übernahme der Artikel-Versandkosten aus Modul gambioultra Gambio-Connector 1
Neu Funktion für Keine, Kurz- & Langbeschreibung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Keine gültige Multilizenz???? Allgemeines zu den JTL-Connectoren 2
Neu Es werden Keine Paypalzahlungen mehr an die WaWi übertragen JTL-Shop - Fehler und Bugs 3
Neu DATEV Rechnungsdatenservice 2.0 überträgt keine Amazon Rechnungsdaten Schnittstellen Import / Export 3
Neu Keine Änderung der Auftragsfarben möglich? User helfen Usern - Fragen zu JTL-Wawi 4
Neu Shop nimmt keine Bilder an JTL-Wawi - Fehler und Bugs 1
Neu Für diesen Zielort stehen keine Versandarten zur Verfügung. Bitte kontaktieren Sie uns direkt, um diese Bestellung abzuwickeln. Betrieb / Pflege von JTL-Shop 1
Neu Angebotsvorlagen oder einzustellende/laufende Angebote: Menge = Verfügbar (wenn >0, sonst 0) keine Funktion? Einrichtung und Installation von JTL-eazyAuction 4
In Bearbeitung Konfigurationsartikel in POS fehlerhaft? Falsche Preise, keine Validierung JTL-POS - Fehler und Bugs 4
Neu Rechnungsdatenservice 2.0 Fehler - keine Objektinstanz Schnittstellen Import / Export 3
nach Update von JTL Shop 4 auf 5 keine Kategoriebilder mehr Upgrade JTL-Shop4 auf JTL-Shop5 5
Verwiesen an Support DPD Webdienst gibt keine Versandlabel aus JTL-ShippingLabels - Fehler und Bugs 1
Offen Mobile Server Verwaltung - keine Benutzer sichtbar JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 3
Neu JTL Shop 5 Keine Neuregistrierung möglich Einrichtung JTL-Shop5 3
Neu Es steht keine Versandart für Ihre Bestellung zur Verfügung. Bitte kontaktieren Sie uns direkt, um diese Bestellung abzuwickeln. Allgemeine Fragen zu JTL-Shop 1
Neu Fast keine Google ergebnisse Allgemeine Fragen zu JTL-Shop 3
Verwiesen an Support DHL Versenden 3.0 keine Zolldokumente JTL-ShippingLabels - Fehler und Bugs 1
Issue angelegt Amazon VSC Lite - keine Workflows mehr möglich? JTL-Workflows - Fehler und Bugs 2
Neu Keine Übertragung an DHL möglich JTL-Wawi - Fehler und Bugs 1
Neu Probleme seit Update auf 1.5.38.1 : keine Amazon FBA Bestellungen mehr und Fehler beim Zugriff auf Wawi Logbuch Amazon-Anbindung - Fehler und Bugs 1
Gelöst Keine Bestände im Shop bei Varkombi, dadurch keine Bestellung möglich User helfen Usern - Fragen zu JTL-Wawi 10
In Diskussion Zahlungsart erlaubt keine Teillieferung JTL-ShippingLabels - Fehler und Bugs 3
Gelöst Workflow schreibt keine Datei mit Endung JTL-Workflows - Fehler und Bugs 2
Ähnliche Themen