Gelöst JTL-Shop 5 Neuinstallation

DerDima

Aktives Mitglied
29. April 2016
68
9
Bielefeld
Hallo liebe Community.

Ich erhalte ganz am Anfang der Installation folgende Meldung:

Fehlermeldung.PNG

Was genau bedeutet dieser Netzwerk-Fehler und wie behebe ich ihn?

Viele Grüße
Dima
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
hi,

Sicher, dass da alle Dateien korrekt übertragen wurden? Gab es eventuell Übertragungsfehler?
 

Bau.Shop

Gut bekanntes Mitglied
19. September 2013
223
0
Bitterfeld-Wolfen im Solar Valley
Hallo,

bei mir war alles grün beim Datenbank update 👍 und plötzlich weine weiße Seite 😡

Nach Aktualisierung der Seite kommt: 1.jpg

Nach lesen im Forum und antworten anderer habe ich folgende Codezeilen in der Datei /includes/config.JTL-Shop.ini.php eingefügt

2.jpg

und die Seite wurde wieder angezeigt. Dieses mal nur eine weiße Seite ohne Fehlermeldung aber mehr eben auch nicht 😢

Hat irgend einer noch einen Tipp?

DANKE, Jörg
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Kannst du in den Errorlogs schauen oder direkt auf /admin/dbupdater.php oder zugreifen? Ohne Fehlermeldung kommen wir sonst nicht weiter. Dann bitte Ticket mit Zugangsdaten (backend, ftp, db) in dem dafür vorgesehenen Feld oder PM an mich.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Alles richtig übertragen. Keiner Fehler. Ich kann gerne noch mal alles löschen und erneut hochladen, wenn es daran liegen könnte.
Lieber überschreiben statt löschen, sonst kommt noch was weg, was nicht weg soll 😉
Die Fehler kommen mir am ehesten so vor, als gäbe es ein Problem mit den Shopdateien an sich oder die PHP-Version passt nicht. Achte auch auf den binären Übertragungsmodus!
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Schuld hier war das veraltete ws_dashbar Plugin. Leider wurden die Plugins entgegen der Upgrade-Anleitung vorher nicht deaktiviert.
 
  • Gefällt mir
Reaktionen: Bau.Shop

DerDima

Aktives Mitglied
29. April 2016
68
9
Bielefeld
Lieber überschreiben statt löschen, sonst kommt noch was weg, was nicht weg soll 😉
Die Fehler kommen mir am ehesten so vor, als gäbe es ein Problem mit den Shopdateien an sich oder die PHP-Version passt nicht. Achte auch auf den binären Übertragungsmodus!

Leider bleibt die Fehlermeldung. Es gibt keine fehlerhaften oder unvollständigen Übertragungen. Alles OK.

Bei einer Installation von JTL Shop 4 lief alles einwandfrei. Kann es sein, dass die von JTL zum Download bereitsgestellte 5.0.0 Version im Kundencenter Fehler enthält?
 
Zuletzt bearbeitet:

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
dass die von JTL zum Download bereitsgestellte 5.0.0 Version im Kundencenter Fehler enthält?
Also fehlerfrei ist keine Software, weder von Google, Microsoft, noch die von Shop4 und Shop5. Da ganz neu, können da insbesondere was die verschiedenen Serverwelten und Zustände da draußen, die man unmöglich vorher alle testen kann, angeht natürlich noch Kinderkrankheiten sein; aber in der Regel funktioniert die Installation schon. Da hakt irgendwas ganz speziell bei dir... ich denke das kriegen wir auch nur raus, wenn wir uns das selbst ansehen. Bitte eröffne dazu ein Ticket über das Kundencenter für das Produkt "JTL-Shop" und hinterlege FTP-Zugangsdaten im dafür vorgesehenen Feld oder schreib mich via PM an.
 
  • Gefällt mir
Reaktionen: DerDima

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
  • Gefällt mir
Reaktionen: DerDima

DerDima

Aktives Mitglied
29. April 2016
68
9
Bielefeld
Hi zusammen.

Leider habe ich mal wieder ein kleines Problem und hoffe auf eure Hilfe.

Es geht um die in dem JTL Guide aufgeführte Domainweiterleitung, die mir einfach nicht in den Kopf will.

Folgender maßen habe ich das nun gemacht:

Übergeordnete .htaccess :

htaccess Bild.PNG

Datei includes/config.JTL-Shop.ini.php :

config.JTL-Shop.ini.php Bild.PNG


Ansonsten wurde absolut nichts verändert.

Nun ist die erste und wichtigste Frage: Ist das so richtig? Den Sinn dahinter verstehe ich nämlich nicht so richtig und weiß auch nicht, ob "...bei jedem Klick eine unnötige Weiterleitung..." stattfindet.

Die zweite Frage und das eigentliche Problem:

Vor Installation des Shops hatte ich einen Ordner mit Bildern im FTP angelegt, um diese für die Crosspromo auf eBay zu verwenden. Die Bilder haben alle in der WaWi und auf eBay die URL´s https://domainname.de/Bilder/Crosspromo/Bildname.png

Nun muss ich feststellen, dass diese Bilder in der Crosspromo auf eBay nicht mehr angezeigt werden. Ich kann das Bild im Browser nun auch nur aufrufen, wenn ich die URL wie folgt schreibe: www.domainname.de/Bilder/Crosspromo/Bildname.png

Das klingt vielleicht jetzt nicht so wild, weil man ja die URL für die Bilder in der WaWi abändern könnte, allerdings handelt es sich um zig Artikel mit einer riesigen Anzahl an bebilderter Crosspromo in jedem Artikel selbst.

Habe ich nun was falsch gemacht? Ist die Weiterleitung nicht geglückt? Könnt ihr mir bitte helfen?

Vielen Dank im Voraus.

Grüße
Dima
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Hallo,
grundsätzlich ist es eine reine Geschmacksfrage, ob mann seine Seite mit www.meine-domain.tld oder mit meine-domain.tld aufruft. Die einen bevorzugen das www, die anderen nehmen es lieber ohne. Die allermeisten Menschen, die jedoch eine Domain im Browser eintippen, werden das einfach ohne www schreiben.
Warum ist jetzt eine Weiterleitung wichtig? Grundsätzlich sind www.meine-domain.tld und meine-domain.tld zwei UNTERSCHIEDLICHE Domains, auch wenn das eine eine Sub-Domain der anderen ist. In Zeiten in denen Browser sehr stark darauf achten, welche Zugriffs- und Ausführungsrechte Ressourcen bekommen, die nicht von DERSELBEN Domain wie die aufrufenden Seite geladen werden, ist es also sehr wichtig und entscheidend ob nun mit oder ohne www verwendet wird. Der Shop liefert über das Template für alle Ressourcen die er selbst verwaltet die Domain aus, die in der config.JTL-Shop.ini.php im Define für URL_SHOP angegeben ist. Das ist also die Domain, unter der alle Ressourcen (Javascript, Bilder, Fonts, etc.) angesprochen werden. Es muss also sichergestellt werden, dass der Shop IMMER unter dieser Domain aufgerufen wird, egal ob der Nutzer nun ein www oder eben keins eintippt. Diese Sicherstellung passiert über die Rewrite-Rules in der .htaccess.
Wenn du also deine Shop-URL bisher vorzugsweise in der Form meine-domain.tld angegeben hast, ist es eher kontraproduktiv jetzt auf die Variante mit www zu setzen. Damit wird dann jeder der bekannten und verlinkten Aufrufe erstmal mit einer Weiterleitung beantwortet. Du solltest deine Regel also eher in die andere Richtung abändern, also als Hauptdomain in die config.JTL-Shop.ini.php ein https://domainname.de und eine Weiterleitungsregel, die Aufrufe mit www entsprechend auf ohne www umleitet.
 

Ähnliche Themen