Neu JTL Shop 5 mit Wawi verbinden - Keine Verbindung möglich!

AN-DI

Sehr aktives Mitglied
22. Juli 2019
219
38
Hallo,

ich würde gerne den JTL Shop 5 an die Wawi anbinden, leider bekomme ich nur eine Fehlermeldung.
Kann jemand helfen? Hab gesehen das Thema wurde schon mal hier bearbeitet aber ich konnte keine
Lösung finden.

Hosting: TimmeHosting
PHP: 7.4
Wawi: 1.5.31.0

Viele liebe Grüße
Andreas
 

AN-DI

Sehr aktives Mitglied
22. Juli 2019
219
38
Hello @FMoche,

leider habe ich mir genaue Fehlermeldung nicht gemerkt. Konnte aber mit Hilfe von TimmeHosting das Problem lösen.

Es hat eine Rewrite Rule gefehlt: rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last;


Danke dennoch für deine Antwort.
 
  • Gefällt mir
Reaktionen: ams und Benjamin.1983

ams

Aktives Mitglied
22. Juli 2014
52
20
Hallo Zusammen,

die Nachstehenden Information dienen nur der Vollständigkeit halber, für weitere Suchende.

andreas_cl meint die Fehlermeldung die die WAWI ausgibt wenn der Button "Verbindung testen / Lizenz aktivieren" gedrückt wird.
Die WAWI meldet dann „ Synchronisation mit Webshop nicht möglich! Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration!“

wawi-shop-sync.jpg

Das Problem ist die derzeit von TimmeHosting zur Verfügung gestellte Vorlage für JTL Shop 4/5.

Wie anderas_cl scheibt muss in der Konfiguration für die Website im Reiter Umleitung folgendes abgespeichert werden.

rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last;

Diese Konfiguration funktioniert dann aber nicht mehr für JTL Shop kleiner Version 5!

Ansonsten hilft einem auch der freundliche und kompetente Service, per Anruf bei TimmeHosting, bei dem Problem weiter und hinterlegt die rewrite rule.

Mit freundlichen Grüße,
AMS
 
  • Gefällt mir
Reaktionen: brahem

Dani´s Kiosk

Neues Mitglied
31. Dezember 2020
13
0
Hallo Zusammen,

die Nachstehenden Information dienen nur der Vollständigkeit halber, für weitere Suchende.

andreas_cl meint die Fehlermeldung die die WAWI ausgibt wenn der Button "Verbindung testen / Lizenz aktivieren" gedrückt wird.
Die WAWI meldet dann „ Synchronisation mit Webshop nicht möglich! Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration!“

Den Anhang 53492 betrachten

Das Problem ist die derzeit von TimmeHosting zur Verfügung gestellte Vorlage für JTL Shop 4/5.

Wie anderas_cl scheibt muss in der Konfiguration für die Website im Reiter Umleitung folgendes abgespeichert werden.

rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last;

Diese Konfiguration funktioniert dann aber nicht mehr für JTL Shop kleiner Version 5!

Ansonsten hilft einem auch der freundliche und kompetente Service, per Anruf bei TimmeHosting, bei dem Problem weiter und hinterlegt die rewrite rule.

Mit freundlichen Grüße,
AMS


Darf ich Fragen wo dieser Reiter Umleitung sich befindet?
Danke.
 

ams

Aktives Mitglied
22. Juli 2014
52
20
Hallo Dani´s Kiosk,

in den Hosting Einstellungen, bei z.B. Timmehosting zu finden im ISPConfig / Website / Domain / Umleitungen (zweiter Reiter).

Mit freundlichen Grüße,
AMS
 

mahmut.mavili@msd-steelde

Neues Mitglied
15. Januar 2021
8
0
Hallo zusammen,

ich habe das selber Problem, bekomme es aber nicht gelöst. Kann mir wer da weiterhelfen?
Das ganze ist nachdem Update auf JTL-Shop Version 5 passiert.

Vielen Dank schonmal!

Meine Webseite wird bei ionos 1&1 gehostet.
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
952
203
@
mahmut.mavili@msd-steelde

wirklich genau das gleiche Problem? Was wird bei Dir ganz genau angezeigt als fehlermeldung? ist die Shop URL wie oben schon geschrieben auch 100% richtig in der wawi hinterlegt? gerne screenshots, dann kann man sicherlich eher helfen.
Noch als Nachtrag, Update auf Shop 5, ist auch wirklich die htaccess dann mitgenommen worden aus dem Shop 5 paket? mit der Shop 4 htaccess ist kein Abgleich möglich da diese anders aufgebaut ist.
Da du dann bei 1/1 bist musst du auch folgendes aus dem Guide beachten:

https://guide.jtl-software.de/jtl-s...einem-server-von-1und1-oder-strato-betreiben/
 

StephanW

Aktives Mitglied
28. Juni 2010
14
2
Nach einem Umzug des JTL-Shops auf einen anderen Server war auch bei mir die Synchronisation nicht mehr möglich.

der ganz einfache Workaround bei meinem Problem:

In der Onlineshop-Anbindung musste ich die Onlineshop-URL auf "https" setzen, dann hat der Abgleich wieder funktioniert.

anbindung.png
 

AD_2021

Neues Mitglied
28. Juli 2021
13
0
Hallo Zusammen,

die Nachstehenden Information dienen nur der Vollständigkeit halber, für weitere Suchende.

andreas_cl meint die Fehlermeldung die die WAWI ausgibt wenn der Button "Verbindung testen / Lizenz aktivieren" gedrückt wird.
Die WAWI meldet dann „ Synchronisation mit Webshop nicht möglich! Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration!“

Den Anhang 53492 betrachten

Das Problem ist die derzeit von TimmeHosting zur Verfügung gestellte Vorlage für JTL Shop 4/5.

Wie anderas_cl scheibt muss in der Konfiguration für die Website im Reiter Umleitung folgendes abgespeichert werden.

rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last;

Diese Konfiguration funktioniert dann aber nicht mehr für JTL Shop kleiner Version 5!

Ansonsten hilft einem auch der freundliche und kompetente Service, per Anruf bei TimmeHosting, bei dem Problem weiter und hinterlegt die rewrite rule.

Mit freundlichen Grüße,
AMS
Hallo AMS,
ich hoffe du kannst mir helfen.
Ich habe den selben Fehler.
Ich weiss jedoch nicht wie und wo ich den RewriteRule hinterlegen muss.
Mein Hosting ist bei SiteGround.com
Anbei ein Screenshot wie es im Menü Domain und Unterpunkt Weiterleitung ausschaut. Was muss bzw. kann ich da ändern oder umstellen ?
Ich hatte schonmal mit dem Shop verbunden. Dann habe ich alles gelöscht und wieder neu hochgeladen. Seit dem bekomme ich den gleichen Fehler wie oben.
Vielen Dank im Voraus.
 

Anhänge

  • Bildschirmfoto 2021-10-24 um 16.53.03.png
    Bildschirmfoto 2021-10-24 um 16.53.03.png
    582,4 KB · Aufrufe: 34

Ähnliche Themen