Neu JTL Shop 5.1.1 Umzug auf neuen Server

chrpoker

Aktives Mitglied
21. Oktober 2019
13
0
Guten Tag zusammen,

ich benötige Hilfe zum Thema Serverumzug.

Ausgangslage:
Shophosting bei 1&1 mit Shopversion 5.1.1 (mit Snackys Template). Läuft stabil, leider bisschen träge und ohne Cachefunktion (nur Dateicache)

Neue Situation:
Dedizierter Server mit deutlich mehr Leistung, als System läuft dort Debian.

Also ran an den Umzug, Anleitung von JTL (JTL GUIDE) geschnappt und los.
Den neuen Server mit benötigter Software lt. Systemvoraussetzungen (Systemvoraussetzungen) augestattet und mit dem Systemcheck geprüft.
Alles Grün, alles schön.

Shop in den Wartungszustand gesetzt, die kompletten Onlineshopdateien kopiert (binär übertragen), die Datenbank gesichert und auf dem neuen Server mit phpMyAdmin importiert.
Anschließend dann die Dateirechte geprüft.

Nur die URL habe ich noch nicht umgezogen, da der alte Shop noch auf der zu nutzenden URL läuft. Also ist die neue Umgebung aktuell nur per IP erreichbar. (Vielleicht liegt da irgendwo mein Fehler?!?)

Ergebnis:
Beim Aufruf des Shops kommt folgende Meldung:
Fatal error: Uncaught RuntimeException: Cannot load template Snackys in /var/www/html/includes/src/Smarty/JTLSmarty.php:98 Stack trace: #0 /var/www/html/includes/src/Smarty/JTLSmarty.php(76): JTL\Smarty\JTLSmarty->initTemplate() #1 /var/www/html/includes/src/Smarty/JTLSmarty.php(202): JTL\Smarty\JTLSmarty->__construct() #2 /var/www/html/includes/src/Shop.php(710): JTL\Smarty\JTLSmarty::getInstance() #3 /var/www/html/includes/src/Shop.php(511): JTL\Shop->_Smarty() #4 /var/www/html/includes/letzterInclude.php(30): JTL\Shop::__callStatic() #5 /var/www/html/wartung.php(13): require('/var/www/html/i...') #6 /var/www/html/includes/globalinclude.php(128): require_once('/var/www/html/w...') #7 /var/www/html/index.php(6): require('/var/www/html/i...') #8 {main} thrown in /var/www/html/includes/src/Smarty/JTLSmarty.php on line 98

Beim Aufruf des Backends, kommt die normale Anmeldemaske, welche allerdings ebenfalls entweder den Cookie-Fehler schmeißt, oder ebenfalls folgende Meldung:
Fatal error: Uncaught RuntimeException: Cannot load template Snackys in /var/www/html/includes/src/Smarty/JTLSmarty.php:98 Stack trace: #0 /var/www/html/includes/src/Smarty/JTLSmarty.php(76): JTL\Smarty\JTLSmarty->initTemplate() #1 /var/www/html/includes/src/Smarty/MailSmarty.php(27): JTL\Smarty\JTLSmarty->__construct() #2 /var/www/html/includes/src/Shop.php(2267): JTL\Smarty\MailSmarty->__construct() #3 /var/www/html/includes/vendor/illuminate/container/Container.php(869): JTL\Shop::JTL\{closure}() #4 /var/www/html/includes/vendor/illuminate/container/Container.php(754): Illuminate\Container\Container->build() #5 /var/www/html/includes/vendor/illuminate/container/Container.php(701): Illuminate\Container\Container->resolve() #6 /var/www/html/plugins/s360_klarna_shop5/ServiceProvider.php(229): Illuminate\Container\Container->get() #7 /var/www/html/includes/vendor/illuminate/container/Container.php(869): Plugin\s360_klarna_shop5\ServiceProvider->Plugin\s360_klarna_shop5\{closure}() #8 /var/www/html/includes/vendor/illuminat in /var/www/html/includes/src/Smarty/JTLSmarty.php on line 98

Vom Hersteller des Templates kam daraufhin folgende Antwort:
die Meldung hatten wir bislang noch nicht, nein.
Es scheint so als fehle da etwas, z.B. das Plugin zum Template oder Template zum Plugin, oder aber auch nur eine der PHP Dateien, Pfade passen nicht oder ähnliches.
Laut Fehler "fehlt" halt schlichtweg etwas.
Kann das bei uns aber in keiner der genannten Konstellationen nachstellen (klar gibt es Fehler wenn was fehlt, aber nicht den gezeigten).

...

Hat noch jemand eine Idee? Einen Hinweis? Oder sollte ich vor dem Umzug den Shop auf das Default Template von JTL umstellen?

Wäre um jeden Rat dankbar.

Danke und schönes anstehendes Wochenende!
 

chrpoker

Aktives Mitglied
21. Oktober 2019
13
0
Evtl. muss noch was an der .htaccess angepasst werden?
In der .htaccess habe ich nur den Punkt der RewriteBase auf "/" gesetzt.
Der Shop befinden sich im Wurzelverzeichnis /var/www/html und nicht in einem weiteren Unterordner.

<IfModule mod_rewrite.c>
RewriteEngine on

#REWRITE ANPASSUNG 1 (REWRITEBASE)
#Wenn Ihr Shop in einem Unterverzeichnis (also z.B. meinedomain.de/meinverzeichnis) installiert ist, so kommentieren Sie die kommende Zeile aus und passen Sie den Verzeichnisnamen an
RewriteBase /


Die anderen RewriteRegeln sind nicht aktiv.
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
1.220
461
Moin,
hast Du geprüft, ob deine Snackys Vorlage aktiv ist ? Am besten de- und wieder aktivieren. Wenn nicht - kurzfristig eine andere Vorlage aktiv schalten.
Viele Grüße, Ihr MVH-Team
 

chrpoker

Aktives Mitglied
21. Oktober 2019
13
0
Moin. Über die Dateiebene - nein. In der Datenbank - eventuell. Lieber Backend im abgesicherten Modus fahren.
Ja nur leider komme ich da ja auch nicht rein. (Siehe oben)

Ich glaube es könnte besser sein, das Snacky Template im Ursprungsshop mal zu deaktivieren und ein default Template zu aktivieren. Dann alles nochmal kopieren und dann testen.
 

chrpoker

Aktives Mitglied
21. Oktober 2019
13
0
Ok nach ein bisschen fummeln komme ich nun mit dem "Abgesicherten Modus" in das Backend.
Allerdings bekomme ich bei sehr vielen Menüunterpunkten folgende Meldung:


Fatal error: Uncaught TypeError: Argument 1 passed to JTL\Template\Config::__construct() must be of the type string, null given, called in /var/www/html/includes/src/Template/Admin/Controller.php on line 88 and defined in /var/www/html/includes/src/Template/Config.php:29 Stack trace: #0 /var/www/html/includes/src/Template/Admin/Controller.php(88): JTL\Template\Config->__construct() #1 /var/www/html/admin/shoptemplate.php(20): JTL\Template\Admin\Controller->handleAction() #2 {main} thrown in /var/www/html/includes/src/Template/Config.php on line 29
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
1.220
461
Ok nach ein bisschen fummeln komme ich nun mit dem "Abgesicherten Modus" in das Backend.
Allerdings bekomme ich bei sehr vielen Menüunterpunkten folgende Meldung:


Fatal error: Uncaught TypeError: Argument 1 passed to JTL\Template\Config::__construct() must be of the type string, null given, called in /var/www/html/includes/src/Template/Admin/Controller.php on line 88 and defined in /var/www/html/includes/src/Template/Config.php:29 Stack trace: #0 /var/www/html/includes/src/Template/Admin/Controller.php(88): JTL\Template\Config->__construct() #1 /var/www/html/admin/shoptemplate.php(20): JTL\Template\Admin\Controller->handleAction() #2 {main} thrown in /var/www/html/includes/src/Template/Config.php on line 29
Wie ich davor meinte deine Template ist nicht aktiv bzw. nicht richtig installiert.
 

Ähnliche Themen