Für den Fall, dass da jemand mal drüber stolpert:
Fehlercode 3: wurde bei mir zurückgegeben, da ich einen MySql-Fehler in der Migrations bei einem Plugin-Update hatte.
(Die info.xml existiert definitiv. Sonst würde ja auch nicht angezeigt werden, dass es ein Update für das Plugin gibt, inkl. der höheren Versionsnummer.)
Fehlercode 7 wurde auch falsch zurückgegeben, da sich die PluginID nicht geändert hat.
Aber, das Plugin wurde (vermutlich ausgelöst durch den MySQL-Fehler) ein zweites mal in die tplugin eingetragen und musste "per Hand" rausgelöscht werden.
Alles in Allem ein bisserl buggy die Fehlermeldung. Vor allem, wenn auch das Plugin buggy ist...
🙂
Gruß
Ronnie