Gelöst Fehler beim Erstellen eines Auftrages - SQL Error -1 preforming exec

minne6

Aktives Mitglied
25. November 2014
81
1
Hallo zusammen,

sobald wir einen manuellen Auftrag erstellen bzw. fertigstellen wollen erhalten wir den Fehler

Fehler beim Zugriff auf die Datenbank.
SQL Error -1 preforming exec
SQL State:00000
SQL Message:
Src: Exec Direct.

Dieser Fehler kommt nur bei einem von 4 angebundenen Onlineshops unter einem Mandanten (wir nutzen Multishop)
Kann uns jemand erklären, wo der Fehler steckt und was wir tun können, dass wir den Fehler beheben?
Wir haben bereits alle Dienste neu gestartet und auch die Wawi ist auf dem aktuellsten Stand.

Danke und Gruß
Simon
 

minne6

Aktives Mitglied
25. November 2014
81
1
Anbei ein Auszug: Der Fehler äußert sich so, dass sich die Wawi aufhängt (Keine Rückmeldung). Bei den anderen Shops funktioniert es.

JTL-Wawi 7b8-1824 ENTER SQLExecDirect
HSTMT 0x028A8860
UCHAR * 0x11F2C4C0 [ -3] "EXEC [spGetNextNummer] @cName = 'Auftrag', @kFirma = 7, @nNoUpdate = 0\ 0"
SDWORD -3

JTL-Wawi 7b8-1824 EXIT SQLExecDirect with return code -1 (SQL_ERROR)
HSTMT 0x028A8860
UCHAR * 0x11F2C4C0 [ -3] "EXEC [spGetNextNummer] @cName = 'Auftrag', @kFirma = 7, @nNoUpdate = 0\ 0"
SDWORD -3

DIAG [01000] [Microsoft][ODBC SQL Server Driver][DBMSLPCN]ConnectionRead (recv()). (10053)

DIAG [08S01] [Microsoft][ODBC SQL Server Driver][DBMSLPCN]Allgemeiner Netzwerkfehler. Weitere Informationen finden Sie in der Dokumentation über Netzwerke. (11)

JTL-Wawi 7b8-1824 ENTER SQLErrorW
HENV 0x028BFC60
HDBC 0x028A2308
HSTMT 0x02895B78
WCHAR * 0x001852A0
SDWORD * 0x001852E8
WCHAR * 0x00184EA0
SWORD 512
SWORD * 0x001852EC

JTL-Wawi 7b8-1824 EXIT SQLErrorW with return code 100 (SQL_NO_DATA_FOUND)
HENV 0x028BFC60
HDBC 0x028A2308
HSTMT 0x02895B78
WCHAR * 0x001852A0
SDWORD * 0x001852E8
WCHAR * 0x00184EA0
SWORD 512
SWORD * 0x001852EC
 
Zuletzt bearbeitet:

Manuel Pietzsch

JTL-Wawi
Mitarbeiter
2. Januar 2012
2.895
1.074
Hückelhoven
Hi,

du hast vermutlich eine zu lange laufende Nummer für die hier zugewiesene Firma. Prüf mal deine Nimmernkreise, die Belegnummer darf am Ende nur 10 Zeichen lang sein. Das haben wir bereits auf dem Radar.

Gruß

Manuel
 
  • Gefällt mir
Reaktionen: minne6

minne6

Aktives Mitglied
25. November 2014
81
1
Das war es! Danke. Erst hatte ich gedacht, dass es nicht funktioniert, aber ich bin über VPN auf dem Server und daher braucht es etwas länger. Nun läuft es! Danke für schnelle Hilfe.
 
  • Gefällt mir
Reaktionen: Manuel Pietzsch

Ähnliche Themen