Neu ecoDMS auf Ubuntu Server OS Installation: unknown user ecodms und keine Clientverbindung möglich

Forumler

Neues Mitglied
30. Januar 2024
2
0
Hallo zusammen,

ich habe ecoDMS in der neuen Version auf Ubuntu Server installiert entsprechend Handbuch. Es lief soweit alles ohne Fehlermeldungen durch. Allerdings jetzt beim Prüfen des ecoDMS Service auf dem Ubuntu Server ob dieser läuft erhalte ich folgende Meldung (zu dem bei der Erstinstallation genannten User ecodms und Passwort ecodms, welche standard bei Ersteinrichtung):

root@ecodms-ubuntu-server:/home/ecodms-admin# sudo service ecodms status
● ecodms.service - LSB: Start ecoDMS at boot time
Loaded: loaded (/etc/init.d/ecodms; generated)
Active: active (exited) since Tue 2024-01-30 18:05:26 UTC; 23min ago
Docs: man:systemd-sysv-generator(8)
Process: 39747 ExecStart=/etc/init.d/ecodms start (code=exited, status=0/SUCCESS)
CPU: 7ms

Jan 30 18:05:26 ecodms-ubuntu-server systemd[1]: Starting LSB: Start ecoDMS at boot time...
Jan 30 18:05:26 ecodms-ubuntu-server ecodms[39747]: Starting ecoDMS Server
Jan 30 18:05:26 ecodms-ubuntu-server sudo[39748]: root : unknown user ecodms ; PWD=/ ; USER=ecodms ; <------------------------------------------ Das ist auffällig
Jan 30 18:05:26 ecodms-ubuntu-server ecodms[39748]: sudo: unknown user ecodms
Jan 30 18:05:26 ecodms-ubuntu-server ecodms[39748]: sudo: error initializing audit plugin sudoers_audit
Jan 30 18:05:26 ecodms-ubuntu-server systemd[1]: Started LSB: Start ecoDMS at boot time.
root@ecodms-ubuntu-server:/home/ecodms-admin#

Normalerweise ist das der Standarduser während der Installation. Erst nach erfolgreicher Client-Verbindung kann man Username und PW empfohlenerweise ändern. Im Handbuch steht nichts extra vom Anlegen des Users auf dem Ubuntu Server usw.
Stop und Start des Services hat nichts gebracht. Logischerweise kann ich mich auch nicht von x-beliebigen Client auf die IP-Adresse des Ubuntu bzw. ecoDMS-Servers mittels Standarduser/PW connecten.

Wieso meckert er den User denn an, muss ich den User auf dem Ubuntu Server erst anlegen oder was ist die Ursache für den Fehler?
 

Forumler

Neues Mitglied
30. Januar 2024
2
0
Nur mal zum Vergleich, nach manuellen Anlegen des User ecodms und Service Start taucht der Fehler nicht auf. Aber seit wann muss ich den User nun manuell anlegen?
PS. Ich kriege allerdings auch keine Verbindung zum Server mit dem ecodms User hersgestellt. Habt ihr eine Idee?


ecodms-admin@ecodms-ubuntu-server:~$ sudo service ecodms status
● ecodms.service - LSB: Start ecoDMS at boot time
Loaded: loaded (/etc/init.d/ecodms; generated)
Active: active (exited) since Wed 2024-01-30 18:07:00 UTC; 18min ago
Docs: man:systemd-sysv-generator(8)
Process: 2520 ExecStart=/etc/init.d/ecodms start (code=exited, status=0/SUCCESS)
CPU: 17.329s

Jan 30 18:07:00 ecodms-ubuntu-server systemd[1]: Starting LSB: Start ecoDMS at boot time...
Jan 30 18:07:00 ecodms-ubuntu-server ecodms[2520]: Starting ecoDMS Server
Jan 30 18:07:00 ecodms-ubuntu-server sudo[2521]: root : PWD=/ ; USER=ecodms ; COMMAND=/opt/ecodms/ecodmsserver/run.sh
Jan 30 18:07:00 ecodms-ubuntu-server sudo[2521]: pam_unix(sudo:session): session opened for user ecodms(uid=1002) by (uid=0)
Jan 30 18:07:00 ecodms-ubuntu-server ecodms[2522]: ecoDMS Server started.
Jan 30 18:07:00 ecodms-ubuntu-server sudo[2521]: pam_unix(sudo:session): session closed for user ecodms
Jan 30 18:07:00 ecodms-ubuntu-server systemd[1]: Started LSB: Start ecoDMS at boot time.
Jan 30 18:07:00 ecodms-ubuntu-server ecodmsserver20[2526]: Service ecoDMS Server 20 is starting up
Jan 30 18:07:00 ecodms-ubuntu-server ecodmsserver20[2526]: ecoDMS Server 20 startup java Process ok
Jan 30 18:07:08 ecodms-ubuntu-server ecodmsserver20[2526]: ecoDMS Server 20 shutdown completed
 

Ähnliche Themen