Gelöst Dringend! Komplettabgleich nicht möglich - Onlineshop down

Siegelringe-Hersteller

Gut bekanntes Mitglied
22. Juli 2014
220
6
Dortmund
Hallo Mitstreiter,

eigentlich selten geworden, aber ich benötige heute doch mal wieder eure Hilfe. Es wäre insofern dringend, da der Shop nicht wieder mit Artikeln, Kategorien etc. gefüllt werden kann und somit de facto kein Handel stattfinden kann.

Aus unerfindlichen Gründen funktioniert der Abgleich zwischen dem Online-Shop und der Wawi nicht mehr.

Sobald der Abgleich gestartet wird, wird nach 4 Minuten folgende Meldung angezeigt:

"Maximale Ausführungszeit von 240 Sekunden überschritten.
Datei: (...)/shop/dbeS/xml_tools.php"

Zwischen dem letzten funktionierenden Abgleich und dem jetzigen "Fehler" wurden neue Artikel, samt Bilder und Variationskombinationen erstellt. Diese sollten jetzt in den Shop gebracht werden.

Was noch aufgefallen ist:
Im Webshop-Abgleich-Fenster wird angezeigt, dass die Globalen Einstellungen gesendet werden.
Rechts über dem Vorgangsbalken, an welchem sich optisch nichts ändert, standen beim ersten Versuch ca. 33000 Artikel/Einstellungen/wasauchimmer.
Beim zweiten Versuch wurde schon eine Zahl über 77000 angezeigt und mittlerweile steht dort die ungefähre Zahl 184000. (edit: am Morgen nach dem Verfassen des Textes 256000)

Da ich vermutete, dass der Cache damit zu tun haben könnte, habe ich den Shop-Cache mehrfach geleert (war eh alles deaktiviert).

Ich danke bereits im Voraus für jedwede Hilfe!

WaWi-Version 1.3.15.4 (edit: zwischenzeitlich von 1.2.3.7 upgedatet)
JTL-Shop-Version 4.05 (Build 2)
 
Zuletzt bearbeitet:

lj-shadow

Sehr aktives Mitglied
15. März 2013
466
47
Morgen,
mal ins blaue geschossen:

Deine max_execeution time von php läuft ab und du überträgst zu viele Artikel auf ein mal.
Schau mal in die Übertragungsparameter vom Shop.
Warum das immer mehr Artikel werden (scheint ja in etwa verdoppelt zu werden), kann ich dir aber nicht sagen
 

Siegelringe-Hersteller

Gut bekanntes Mitglied
22. Juli 2014
220
6
Dortmund
Guten Morgen,

- max_execution_time mittlerweile von 240 auf 480 hochgesetzt. Alle anderen Parameter sind im grünen Bereich.

- Nun kommt die Meldung nach ca. 2 Minuten: "Der Server meldete eine ungültige oder unbekannte Rückmeldung."

- Im Errorlog (von Microsoft SQL-Server) nachgeschaut: "
2018-02-26 08:43:09.01 spid15s Dedicated administrator connection support was not started because it is disabled on this edition of SQL Server. If you want to use a dedicated administrator connection, restart SQL Server using the trace flag 7806. This is an informational message only. No user action is required.
2018-02-26 08:43:09.02 spid15s Recovery is complete. This is an informational message only. No user action is required.
2018-02-26 08:43:09.02 Server SQL Server is attempting to register a Service Principal Name (SPN) for the SQL Server service. Kerberos authentication will not be possible until a SPN is registered for the SQL Server service. This is an informational message. No user action is required.
2018-02-26 08:43:09.02 spid15s SQL Server is now ready for client connections. This is an informational message; no user action is required.
2018-02-26 08:43:09.02 Server The SQL Server Network Interface library could not register the Service Principal Name (SPN) [ MSSQLSvc/Fraalex-Laptop:JTLWAWI ] for the SQL Server service. Windows return code: 0xffffffff, state: 63. Failure to register a SPN might cause integrated authentication to use NTLM instead of Kerberos. This is an informational message. Further action is only required if Kerberos authentication is required by authentication policies and if the SPN has not been manually registered.
2018-02-26 08:43:09.02 Server The SQL Server Network Interface library could not register the Service Principal Name (SPN) [ MSSQLSvc/Fraalex-Laptop:49695 ] for the SQL Server service. Windows return code: 0xffffffff, state: 63. Failure to register a SPN might cause integrated authentication to use NTLM instead of Kerberos. This is an informational message. Further action is only required if Kerberos authentication is required by authentication policies and if the SPN has not been manually registered.
2018-02-26 08:53:06.28 spid52 Starting up database 'eazybusiness'."

Ich kenne mich hier null aus, aber die markierten Passagen lesen sich irgendwie nicht positiv...

Kann mir jemand helfen, der sich damit auskennt?
 
Zuletzt bearbeitet:

Siegelringe-Hersteller

Gut bekanntes Mitglied
22. Juli 2014
220
6
Dortmund
Problem vorerst gelöst.
Letztendlich war es wohl ein sich selbst potenzierender Eintrag in der Datenbank, welcher beim Einsatz der Ameise hervorgerufen wurde.

Die Lösung brachte dann letztendlich der Sevice-Partner rshost.eu. Schnell und bewiesenermaßen kompetent.
Vielen Dank an dieser Stelle.
 

kljgr

Aktives Mitglied
13. Oktober 2015
86
1
Wir haben zurzeit ähnliche Probleme beim Abgleich von 3 JTL Shops.

Wie kann ich auf Fehlersuche gehen=?
 

Rico Giesler

Offizieller Service Partner
SPBanner
10. Mai 2017
13.247
1.526
Da rshost.eu alex helfen konnte wäre dies eine Möglichkeit sich dahin zu wenden.
 

Ähnliche Themen