Neu Die Online Shop Anbindung gelöscht, was nun?

Lukas5881

Neues Mitglied
22. Februar 2020
8
0
Hi,
ich habe die Online Shop Anbindung gelöscht, aber vorher alles richtig installiert und den Online Shop richtig angelegt. Wenn ich den jetzt wieder verbinden will kommt die Fehlermeldung, wie im Screenshot 14. Ich bin bei Strato. Außerdem was Informatik etc. angeht ein Laie. Was kann man da machen?
 

Anhänge

  • Screenshot (14).png
    Screenshot (14).png
    321,2 KB · Aufrufe: 35

Inge

Sehr aktives Mitglied
21. Juni 2014
121
27
Wenn ich deinen Shop besuche erhalte ich folgende Fehlermeldung:

Die Konfigurationsdatei des Shops konnte nicht geladen werden! Bei einer Neuinstallation bitte hier klicken.

Deine ganze Installation hat noch gar nicht begonnen - oder deine auf dem FTP includes\config.JTL-Shop.ini.php Datei hat sich in Luft aufgelöst.
Wenn du dir nicht sicher bist und diese Installations-Schritte noch nicht gesehen hast, mach das erstmal fertig.

http://510402514.swh.strato-hosting.eu/install/index.php

Zudem würde ich dann nochmal die Dokumentation durchlesen, da anscheinend hier noch Vorarbeiten bzw. Grundwissen fehlt.
In den Install-Schritten würdest du auch das Wawi-Sync PW vorgeben.
Da in deinem Foto das PW bereits ausgefüllt ist, gehe ich davon aus, dein Shop war mal installiert.
Also ist wahrscheinlich die o.g. config.JTL-Shop.ini.php Datei auf dem FTP verschwunden. Dann frage ich mich jedoch, wieso das /install/ Verzeichnis noch existiert.
Nach einer Installation löscht man das. Das ist alles sehr unsauber. Vom fehlenden DNS Namen und HTTPS mal ganz abgesehen.
Hast du irgendwie ein defektes Backup hochgespielt? Dateien verloren? Den Shop noch nie installiert gehabt? Den Onlineshop versucht neuzinstallieren (halb)?
 
Zuletzt bearbeitet:

Lukas5881

Neues Mitglied
22. Februar 2020
8
0
ich habe das schon einmal richtig installiert. Wenn ich das nochmal installieren will, kommt diese Meldung (siehe Screenshot 15). Was kann man da machen?
 

Anhänge

  • Screenshot (15).png
    Screenshot (15).png
    535,6 KB · Aufrufe: 22

Inge

Sehr aktives Mitglied
21. Juni 2014
121
27
Wenn du deinen Shop installiert hast, kannst und solltest du nach der Installation das /install/ Verzeichnis löschen. Dies wird auch im ACP so angemerkt, wenn nicht geschehen.

Aber: Wenn du auf deine Hauptseite gehst, siehst du, die Konfig-Datei ist defekt.

Kannst du bitte mal überprüfen, ob du eine Datei hast "includes\config.JTL-Shop.ini.php" im Shop.
Daran liegt alles, der Installer legt diese Datei an und erstellt die DB Tabellen.
Wenn dein Shop bereits installiert wurde, müsste ja diese Datei existieren.
Dann wundere ich mich jedoch, warum deine Hauptseite sagt, die Datei würde nicht existieren.

Überprüfe erstmal, ob die Datei wirklich existiert (Konfig-Datei).

http://510402514.swh.strato-hosting.eu
--> Die Konfigurationsdatei des Shops konnte nicht geladen werden!
 

Lou Zypher

Sehr aktives Mitglied
5. August 2019
216
31
Die config.JTL-Shop.ini.php oder die config.JTL-Shop.ini.initial.php?
Schau mal in der ersten rein, da sollte was drin stehen.
Weiter in der Datenbank selbst die tabelle tsynclogin anschauen, da stehen deine Sync-Daten Wawi<>Shop drin.

http://510402514.swh.strato-hosting.eu/ <-- ist das deine Domain? Evtl. bei der Installation eine "echte" Domain angegeben?
 

Lukas5881

Neues Mitglied
22. Februar 2020
8
0
Also, ich habe bei der Installation eventuell einen Fehler gemacht, anstatt die korrekte Domain zu nehmen, habe ich die falsche Domain genommen. Muss ich dann neu installieren? Muss ich dabei etwas beachten? Ich frage, weil ich habe die ganzen Dateien bereits für die richtige Domain www.jikoni.de mit filezilla hochgeladen. Habe die config.JTL-Shop.ini.initial.php umbenannt und die 777 für Schreibrechte vergeben. Aber wenn ich nun jikoni.de/install mache dann kommt eine Fehlermeldung.
 

Lou Zypher

Sehr aktives Mitglied
5. August 2019
216
31
jikoni.de/install wird nicht funktionieren, da liegen ja die Daten vom ePages-Shop.
Sind die Dateien vom JTL-Shop in einem separaten Ordner?
Dann ruf mal jikoni.de/JTL-Shop-Ordner/install/index.php auf um den Shop zu installieren.
JTL-Shop-Ordner ist dann der Name des Ordners wo die JTL-Daten liegen.


...habe ich die falsche Domain genommen. Muss ich dann neu installieren?
Nein, du musst die URL nur in der config.JTL-Shop.ini.php ändern.
 

Lukas5881

Neues Mitglied
22. Februar 2020
8
0
jikoni.de/JTL-Shop-Ordner/install/index.php...dann kommt folgende Fehlermeldung: The requested URL /JTL-Shop-Ordner/install/index.php was not found on this server.
Die Dateien sind nicht in einem Ordner, habe alle Dateien markiert und dann mit filezilla hochgeladen. Siehe Screenshot 17
Außerdem ich habe mir die config.JTL-Shop.ini.php mal im filezilla angeguckt, die ist leer und 0 Byte...
 

Anhänge

  • Screenshot (17).png
    Screenshot (17).png
    648,3 KB · Aufrufe: 10

Inge

Sehr aktives Mitglied
21. Juni 2014
121
27
config.JTL-Shop.ini.php ist leer, das ist schlecht 😉

Hast du die befüllte Datei noch?
 

Inge

Sehr aktives Mitglied
21. Juni 2014
121
27
In der Datei steht dein Datenbank-Passwort (DB_PASS) sowie das Datenbank-Entschlüsselungs-PW (BLOWFISH_KEY) für die existierenden Daten in der Datenbank. Ohne diesen Schlüssel kannst du auch die bereits vorhandenen Daten in der Datenbank vom JTL-Shop nicht weiternutzen. Z.B. sind Kundendaten nicht im Klartext in der DB abgelegt, sondern werden über diesen Key symmetrisch verschlüsselt. Ohne diesen Key kannst du daher die Daten nicht mehr lesen. Das hat auch Datenschutz-Gründe und Sicherheits-Gründe.

Dir bleibt jetzt quasi nur noch eine Neuinstallation des JTL-Shops. Danach das neue Wawi-Sync PW vom JTL-Shop in die JTL-Wawi eintragen und einen Onlineshop-Abgleich starten, das befüllt dann auch die JTL-Shop Datenbank neu.

-------------

Je nachdem, wie "weit" dein Geschäft bereits war (z.B. dein JTL-Shop lief schon ein paar Jährchen) würde ich das aber nicht machen (Neuinstallation), da dann auch z.B. auch deine Kunden alle neu anmelden werden müssen (alte Session Keys werden fehlen da die DB leer ist bei der Neuinstallation). Außerdem werden wahrscheinlich auch Bestellhistorie der Kunden im Kundencenter deines neuen Shops fehlen. Da die JTL-Wawi solche Daten quasi nicht neubefüllt (es eben nicht alles in der JTL-Wawi DB gespiegelt) und du deinen Shop "neuinstalliert" hast. Nur Beispiele, es gibt wahrscheinlich noch andere Nachteile.

Wenn dir deine alten Daten im JTL-Shop viel wert sind, würde ich mich lieber ggf. an einen SP (=ServicePartner) wenden, der das alte System noch über komplexe Methoden zu retten versuchen könnte, z.B. Teile der alten Datenbank mit der neuen vermengen, oder eben die Konfigurationsdatei aus einem Backup retten und und und.

Alternative und am einfachsten wäre bei fehlender Konfig-Datei dann nur die Neuinstallation vom JTL-Shop (/install/ Seite neu aufrufen und durchlaufen, vorher Datenbank bereinigen).
 
Zuletzt bearbeitet:

Lukas5881

Neues Mitglied
22. Februar 2020
8
0
Neuinstallation ist auch das beste, vor allem mit der Domain, wo auch mein Shop läuft. Nur wenn ich die Domain jikoni.de/install eingebe, dann kommt eine Fehlermeldung. Ich habe die ganzen Dateien bereits für die richtige Domain www.jikoni.de mit filezilla hochgeladen. Habe die config.JTL-Shop.ini.initial.php umbenannt und die 777 für Schreibrechte vergeben. Aber wenn ich nun jikoni.de/install mache dann kommt eine Fehlermeldung. 404. Ansonsten siehe Nachricht von 13:48 Uhr
 

Inge

Sehr aktives Mitglied
21. Juni 2014
121
27
http://510402514.swh.strato-hosting.eu/install

-> hier geht der Installer

https://www.jikoni.de/install

-> hier nicht

ich weiß nicht welche Domäne auf was von deinem FTP zeigt.

404 heißt, der Webserver findet unter /install nichts. Also entweder existiert das Verzeichnis nicht (überprüfe mal mit dem FTP) oder deine .htaccess-Datei ist fehlerhaft oder deine Domänen/Server Einstellungen vom Webserver sind nicht korrekt.
 

Ähnliche Themen