Neu [4.05.7] - Wawi meldet Verbindung wurde vom Server abgebrochen

JohnFrea

Sehr aktives Mitglied
21. September 2017
975
305
Hi,

seit dem Update von 4.05 Build 6 auf 4.05. Build 7 bekomme ich folgende Wawi Fehlermeldung bei einem Abgeich:

"Verbindung wurde vom Webserver abgebrochen"

Hat jemand das Problem ebenfalls? Oder eine Lösung?

Wir verwenden Wawi 1.3.14.2

John
 
Zuletzt bearbeitet:

Mirko.Schmidt User deaktiviert

Guest
Hallo,
ich denke mal hier ist das Update von 4.0"5".6 zu 4.0"5".7 gemeint. Gab's irgendwelche Fehler beim Backend Update, gibt's beim Dateien/Datenbank Check irgendwelche Fehlermeldungen?
 

JohnFrea

Sehr aktives Mitglied
21. September 2017
975
305
Es wurde von 4.05.6 auf 4.05.7 geupdatet.
Einen Fehler im Backend gab es nicht
Im Shop Wartung > Status liefert ebenfalls keine Fehler.

Ein Teil des Abgleichs läuft auch durch. Der Fehler tritt erst beim letzten Punk des Abgleichs auf.
 

JohnFrea

Sehr aktives Mitglied
21. September 2017
975
305
Der Fehler kommt beim Erreichen des Punktes Konfigurationsbilder - wobei wir gar keinen Konfigurator im Shop benutzten.

Probiert wurde bereits (Tip durch den Support)
- Update erneut per FTP übertragen
- Anpassen der JTL Shop Übertragungsparameter in der Wawi (halbieren)
- Check, ob zu große Bilder in der Wawi sind. Die größten Bilder sind 800k bei 1600x1600 und lassen sich durch die Wawi nicht weiter klein konvertieren, wenn 1600x1600 bleiben soll. Die Bilder waren auch früher nie ein Problem und sind schon lange in der Wawi

Auffällig ist, daß der Fehler beim Erreichen des Unterpunktes quasi sofort kommt. Da wird nicht erste lange versucht etwas hoch zu laden.
 

Anhänge

  • jtl fehler.JPG
    jtl fehler.JPG
    75,9 KB · Aufrufe: 45

Mirko.Schmidt User deaktiviert

Guest
Das sieht eher danach aus, als würde dbeS/lastjobs.php vom Shop da angestoßen werden und nicht korrekt laufen. Daher einmal folgendes bitte durchlesen und überprüfen.

Am Ende des Abgleiches werden noch einige Funktionen angestoßen. Das passiert über die Datei /dbeS/lastjobs.php

Folgenden Features werden dabei angestoßen und können nacheinander deaktiviert werden (Ausschlussverfahren) um das Problem einzugrenzen:

  • Erstellung der Sitemap: System->Export->Sitemap in den Einstellungen Option "Sitemap beim Wawi Abgleich erstellen"
  • Senden von Bewertungserinnerungen: Storefront->Bewertungen in den Einstellungen Option "Bewertungserinnerung nutzen"
  • Garbage Collector: System->Globale Einstellungen->Globale Einstellungen Option "Automatische Shop Bereinigung (GarbageCollector)"
  • Plugins: Alle Plugins können sich am Ende des Abgleiches einklinken. Wenn die vorherigen Optionen keine Wirkung zeigten, Deaktivierung einzelner Plugins nacheinander
 

JohnFrea

Sehr aktives Mitglied
21. September 2017
975
305
Das Problem wird durch Aufruf von

executeHook(HOOK_LASTJOBS_HOLEJOBS);

in function getJobs() in /dbeS/lastjobs.php ausgelöst.

An HOOK_LASTJOBS_HOLEJOBS, also HOOK 134 hängen bei mir:
  • JTL Search
  • Amazon Pay (JTL-Shop 4) by Solution 360
Es liegt am Amazon Pay (JTL-Shop 4) by Solution 360. Deaktiviere ich das Plugin, läuft der Abgleich sauber durch. Plugin Version ist 1.12
 

Mirko.Schmidt User deaktiviert

Guest
Dann bitte einmal an Solution360 wegen dem Problem wenden, damit die dort weiterhelfen können.
 

Bernd.Krueger

Aktives Mitglied
17. Februar 2016
8
0
Das sieht eher danach aus, als würde dbeS/lastjobs.php vom Shop da angestoßen werden und nicht korrekt laufen. Daher einmal folgendes bitte durchlesen und überprüfen.

Am Ende des Abgleiches werden noch einige Funktionen angestoßen. Das passiert über die Datei /dbeS/lastjobs.php

Folgenden Features werden dabei angestoßen und können nacheinander deaktiviert werden (Ausschlussverfahren) um das Problem einzugrenzen:

  • Erstellung der Sitemap: System->Export->Sitemap in den Einstellungen Option "Sitemap beim Wawi Abgleich erstellen"
  • Senden von Bewertungserinnerungen: Storefront->Bewertungen in den Einstellungen Option "Bewertungserinnerung nutzen"
  • Garbage Collector: System->Globale Einstellungen->Globale Einstellungen Option "Automatische Shop Bereinigung (GarbageCollector)"
  • Plugins: Alle Plugins können sich am Ende des Abgleiches einklinken. Wenn die vorherigen Optionen keine Wirkung zeigten, Deaktivierung einzelner Plugins nacheinander

Hallo,
ich habe seit dem letzten Update zu 4.06(build: 11) das gleiche Problem.
Amazon Pay by Solution 360 ist nicht aktiv.

Meine Frage ist jetzt, was passiert, wenn ich wie empfohlen die Funktionen nacheinander deaktiviere.
Mir sagen die alle nichts und ich denke, wenn die vorhanden und aktiviert sind, dann wird das sicher einen Grund haben und nötig sein.

Außerdem tritt das Problem nur sporadisch auf. Unabhängig davon, ob ich Artikel bearbeitet, oder neu angelegt habe.
Heute z.B. nachdem ich einige Auslieferungen gebucht habe und neue Bestellungen abrufen wollte.

Wenn ich die Fehlermeldung bestätige kommt sie mehrmals (Die Häufigkeit variiert) wieder.
Wenn ich oftgenug bestätige läuft der Abgleich schliesslich irgendwann durch.
 
Zuletzt bearbeitet:

Bernd.Krueger

Aktives Mitglied
17. Februar 2016
8
0
Hallo,
sorry für die späte Rückmeldung.
Das Problem war ein Serverproblem. Was genau habe ich nicht verstanden, aber nachdem der Hoaster meinen Shop auf eine neue Datenbank gepack hatte lief alles problemlos.
Die alte Datenbanbk war nicht auf dem aktuellsten Stand, da dort noch ältere Shops lagen.
Leider kann ich es nicht genauer Beschreiben.
Gruß Bernd Krueger
 

Ähnliche Themen