Worker in der 1.7.15.3 hängt ständig beim Shopabgleich

michab

Aktives Mitglied
8. Oktober 2012
47
8
Das der Worker nicht ordnungsgemäß läuft ist ja beim Lesen hier häufiger zu finden.
Einen Hinweis auf die Ursache allerdings nicht.
Der Worker ist bei uns als Dienst hinterlegt und wird über einen administrativen User gestartet.
Zunächst läuft der Worker ohne Probleme.
Nach dem ersten Abgleich hängt allerdings der Abgleich mit dem Shop regelmäßig.
Abgleich von eBay, Track&Trace sowie der Start der Workflows funktioniert weiter.
Der Shopabgleich hängt im Status --> Läuft "Initial 1.Aufruf -[0.00%] (0/0)
Neustarten des Abgleiches hängt bei Neustart angefordert.
Der Versuch den Worker-Dienst neu zu starten scheitert. --> Fehler 1053 Dienst antwortet nicht rechtzeitig.
Am Ende bleibt es den Server neu zu starten.
Wir haben "noch" keine 500 Artikel im Shop und würden gerne neben eBay auch andere Marktplätze nutzen.
Wir haben noch einiges vor, aber ohne eine funktionierende Software ist das schlecht möglich.
Ich würde mich über Lösungen freuen.

LG micha
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
6.694
1.610
Berlin
Eventuell ist ja auch der Shop schuld,
Ich würde hier mal den cache vom Shop deaktivieren und das dann nochmals testen.

Der Cache kann beim Abgleich Probleme machen, insbesondere wenn man mit dem Dateicache arbeitet.
 

michab

Aktives Mitglied
8. Oktober 2012
47
8
Naja, dann wird sich an dem Zustand wohl auch nichts mehr ändern.
Ich hab von den Tickets bisher noch nichts gelesen.

Eventuell ist ja auch der Shop schuld,
Ich würde hier mal den cache vom Shop deaktivieren und das dann nochmals testen.

Der Cache kann beim Abgleich Probleme machen, insbesondere wenn man mit dem Dateicache arbeitet.
Und siehe da.
Tatsächlich sind jetzt schon einige Abgleiche nach Abschalten des Objekt-Caches im Shop durchgelaufen
ohne das der Abgleich hängen bleibt.
In diesem Fall liegt es wohl tatsächlich am Shop.

Vielleicht kann man das ja innerhalb von JTL mal kommunizieren.

Der Shop als "Schaufenster" der Wawi könnte m.E. sowieso eine Überarbeitung vertragen.
Aber nicht in Richtung Bling-Bling sondern Funktionalität. (Versand)

Danke für deinen Support.
 

AlexMT-Commerce

Sehr aktives Mitglied
11. August 2017
162
33
Hi, bei uns hängt sich der Worker 2.0 (kein Dienst) immer bei den SCX Abgleichen (Kaufland / OTTO) irgendwann auf mit folgendem letzten Abgleich: "Attribute(Empfangen): 1. Aufruf - [0,00%] (0/0)." danach passiert nichts mehr. Aktuell passiert das ca. alle 2-5 Tage. Da hilft dann nur alle Abgleiche manuell zu deaktivieren. Der eine hängende Abgleich lässt sich natürlich lässt sich dann aber nicht deaktiveren - auch nach längerer Wartezeit nicht. Da hilft dann nur Task beenden. Dann ca. 10min warten und erstmal ein SCX-Abgleich manuell machen und dann kann man alles wieder starten. Ist halt schwierig für ein Ticket zu rekonstruieren, da wir nicht länger als nötig auf den Worker verzichten können. Hat jemand eine Idee? Wir nutzen aktuell auch noch die 1.7.15.4.
 

gigi80

Sehr aktives Mitglied
3. Juni 2016
551
72
Und siehe da.
Tatsächlich sind jetzt schon einige Abgleiche nach Abschalten des Objekt-Caches im Shop durchgelaufen
ohne das der Abgleich hängen bleibt.
In diesem Fall liegt es wohl tatsächlich am Shop.

Vielleicht kann man das ja innerhalb von JTL mal kommunizieren.

Der Shop als "Schaufenster" der Wawi könnte m.E. sowieso eine Überarbeitung vertragen.
Aber nicht in Richtung Bling-Bling sondern Funktionalität. (Versand)

Danke für deinen Support.
Dann hast du Glück. Bei den im Ticket bekannten Shops laufen Redis Cache. JTL baut ständig irgendwelche DLL um das Verhalten nachzustellen....
 

michab

Aktives Mitglied
8. Oktober 2012
47
8
Zu früh gefreut.
Der Worker hängt wieder.
Da es zu den Abbrüchen auch kommt wenn SCX genutzt wird, steht der Worker wieder
im Rampenlicht. Könnte es evtl sein das der Worker an einem Timeout stirbt ?
 

John

Sehr aktives Mitglied
3. März 2012
2.648
511
Berlin
Ich hatte bei einem Kunden ähnliche Probleme mit dem Worker als Dienst.
Mir wars irgendwann zu blöd und ich bin zu dem Verfahren übergegangen, welches ich schon seit mehr als 7 Jahren erfolgreich am laufen habe:

1. Worker alle 3 Stunden sanft zu beenden versuchen. Zwischen den Versuchen 15 Minuten Zeit geben.
2. Beendet er sicht nicht, nach den 3 Versuchen den Worker hart killen.
3. Worker-Client Prozesse anschließend killen, bis keine mehr da sind.
4. 10 Minuten warten, dann Worker neu starten.

Das ganze übernimmt inzwischen ein Programm, per Aufgabenplanung alle 3 Stunden gestartet wird.

LÄUFT.
 

Anhänge

  • Worker-Restarter.png
    Worker-Restarter.png
    38,1 KB · Aufrufe: 24

michab

Aktives Mitglied
8. Oktober 2012
47
8
Klingt erst einmal gut, aaaber....
Dazu müsste der Worker ja erst einmal 3 oder x Stunden durchhalten.
Das macht er aber nicht.
Wenn ich die Prozedur "zu Fuß" durchgehe (Client-Worker beenden --> Worker beenden)
dann steht, nach dem Worker - Neustart, bei der Überprüfung des Status, der Shop auf "mit Fehlern beendet".
Da muss also der Worker wieder beendet werden um den Vorgang in der Wawi zurückzusetzen.
Dann neu starten.
Vielleicht bin ich ja zu ungeduldig. 10 Minuten warten ist nicht so mein Ding.
 

michab

Aktives Mitglied
8. Oktober 2012
47
8
Definitiv.
Nachdem der Worker bzw. ein Client Unterprozess irregulär beedent wurde, ist diese per Eintrag in der Datenbank für eine Weile gesperrt.
Die 10 Minuten Wartezeit sind meiner Erfahrung nach nötig.
Hallo John

Vielen Dank für den Wegweiser.

Dann also mit Geduld.

Ich hab jetzt folgenden Lösungsansatz gewählt.
Ich setze ein Powershell-Script ein.
Regelmäßig scannt das Script nach Worker Client Prozessen mit 0% CPU Last.
Findet das Script einen solchen Prozess wird dieser beendet.
In der Folge fährt das Script den Worker herunter und startet den nach 10 Minuten wieder neu.

Bisher funktioniert das sehr gut.

Gruß Michael
 
  • Gefällt mir
Reaktionen: HUSATECH

AlexMT-Commerce

Sehr aktives Mitglied
11. August 2017
162
33
Bei uns hat der SCX Abgleich jetzt fast 1 Monat ohne Probleme funktioniert. Jetzt hängt er sich seit gestern wieder mehrfach am Tag auf...
JTL Version: 1.7.15.4
 

HUSATECH

Mitglied
4. April 2023
6
1
Moin zusammen,

wir schlagen uns seit dem Update von 1.7.13.1 auf die 1.8.11.2 mit ähnlichen Problemen rum. Der Shopabgleich hängt sich unregelmäßig immer wieder auf ("Initial 1.Aufruf -[0.00%] ). Mal geht es drei Tage gut, mal hängt der Worker mehrmals am Tag.

Die Lösung mit dem Powershell-Script klingt nicht verkehrt. Würde ich gerne mal testen. Michael, könntest du das Skript hier netterweise zur Verfügung stellen?

Besten Dank und Gruß
Ronny
 

michab

Aktives Mitglied
8. Oktober 2012
47
8
Ok
Bei uns läuft das Script zufriedenstellend.
Wo anders wurde es nicht getestet.

Es gibt daher keinerlei Gewährleistung meinerseits.
Wer das Script einsetzen möchte sollte halt wissen was er tut.


Hab noch ne Kurzanleitung fürs Einbinden dazugepackt.
Ich hoffe es hilft euch auch.

Viel Spaß damit
 

Anhänge

  • OSScript-WorkerRestart.txt
    1,8 KB · Aufrufe: 8
  • Anleitung-Script.txt
    1,9 KB · Aufrufe: 9
  • Gefällt mir
Reaktionen: hago24 und HUSATECH

michab

Aktives Mitglied
8. Oktober 2012
47
8

HUSATECH

Mitglied
4. April 2023
6
1
Das Problem soll, laut JTL, mit Version 1.8.12.2 behoben sein.
Leider kann ich im Changelog lediglich den Punkt "JTL-Shop - Abgleich - WAWI-75480 - Abgleich mit einer 3-stelligen Länder-ISO nicht möglich" finden. Im Ticket WAWI-72420 steht der Status auf "More Info". Wo kommt die Info her, dass der Bug mit Version 1.8.12.2 behoben sein soll?

Danke und Gruß
Ronny
 
Ähnliche Themen
Titel Forum Antworten Datum
Worker Error TrackAndTrace JTL-Wawi 1.8 1
Worker Benutzer ändern JTL-Wawi 1.8 2
Wie schalt ich den worker Client aus auf den Server wegen Update JTL-Wawi 1.8 1
Neu Ein Kundenauftrag führt zu Fehlern im Worker "Pfad / Dateiname zu lang" JTL-Wawi - Fehler und Bugs 0
Worker hat Zeitlücken von vielen Stunden JTL-Wawi 1.8 1
JTL Worker Manueller Abgleich nicht möglich trotz deaktivierem Worker 2.0 JTL-Wawi 1.8 4
Neu JTL Worker 2.0 und tinetbestellung Technische Fragen zu den JTL-Connectoren 0
Worker 2.0 Abgleich dauert sehr lange JTL-Wawi 1.7 8
Neu Hilfe - Performanceproblem mit Shop durch Worker JTL-Shop - Fehler und Bugs 28
JTL Wawi Update 1.7.15.5 - Worker hat keinen Zugriff auf DB JTL-Wawi 1.7 6
Worker angeblich nicht gestartet und nicht konfigurierbar - Aber auf nur einem neuen Win11 Client?!? JTL-Wawi 1.7 2
Bug? Worker 2.0 - Shop Abgleich "Quicksync" ist kein Quicksync mehr - Paketgröße wird ignoriert JTL-Wawi 1.8 10
1.8.11.0 - Worker SQL lässt System hängen JTL-Wawi 1.8 0
Neu Neues Tool - Worker 2.0 automatisch beenden, killen und neu Starten Dienstleistung, Jobs und Ähnliches 20
JTL Worker 2.0 - Fehlermeldungen im Log, aber wo? JTL-Wawi 1.8 1
Wichtig UPS Änderung der Authentifizierungsmethode zu OAuth2 JTL-ShippingLabels - Ideen, Lob und Kritik 0
Grundepreise bei Vaterartikel in der Artikelvorschau im Shop JTL-Wawi 1.8 0
Neu Einschränkung der abzuholenden Aufträge Shopify-Connector 1
Neu Wie kann ich mit der Wawi Ebay Rechnungen erstellen und nach ebay hochladen? eBay-Anbindung - Fehler und Bugs 3
Neu Creation Date der Artikel Falsch Shopware-Connector 0
Neu Datenträgerverwendung oberste Tabellen - Größe der DB verringern (Logs etc) User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehler beim Hochladen der Datei JTL-Shop - Fehler und Bugs 0
Neu Mehrere Firmen - automatisierte Änderung der Kundennummer? Arbeitsabläufe in JTL-Wawi 7
Neu Der Shop schickt die Aufträge nicht mehr an die Wawi JTL-Shop - Fehler und Bugs 1
Neu Automatische Sortierung der Bilder & Anzahl der Ebay Bilder eBay-Anbindung - Fehler und Bugs 0
Verwendung der Statistik in Wawi 1.8: JTL-Wawi 1.8 3
Neu Kann man in der POS zwischen Mandanten umschalten? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Footer in der Größe anpassen Gelöste Themen in diesem Bereich 5
Falsche Anzeige der Bestandsführung JTL-Wawi - Fehler und Bugs 5
Neu Drucken-Button auf der Artikeldetailseite Allgemeine Fragen zu JTL-Shop 0
Setup Nummernkreise neue Firma - Länge der Kreise JTL-Wawi 1.8 8
Neu Darstellung/Werte der Variantenauswahl auf Amazon anpassbar? Amazon-Lister - Ideen, Lob und Kritik 0
Neu Kategorienbaum in einer Unterkategorie über der Filterung ausblenden Allgemeine Fragen zu JTL-Shop 1
Neu Anzahl der gefüllten Versandboxen ausgeben lassen Eigene Übersichten in der JTL-Wawi 1
Neu leeres Textfeld erstellen für einen Hinweis auf der Rechnung User helfen Usern - Fragen zu JTL-Wawi 2
Versandkosten werden bei der Gewinnermittlung nicht breücksichtig (1.8.12.2) JTL-Wawi 1.8 1
Wie kann ich etwas in der WAWI Datenbank per SQL ändern? JTL-Wawi 1.8 2
Neu Was steckt hinter der Zahl von 53 Bildern auf Ebay bei Variationsartikeln (und einer unsinnigen Fehlermeldung der Wawi)? JTL-Wawi - Fehler und Bugs 2
Neu Gravierender Fehler in der Shop Software Betrieb / Pflege von JTL-Shop 3
Neu Packtisch: In der Liste der Aufträge neue Feld-Spalte mit Spalteneditor hinzufügen Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Workflow der bei Stücklisten: Überverkäufe de-/aktivieren User helfen Usern - Fragen zu JTL-Wawi 11
Wo befindet sich das Feld mit der Information für "Zustandsbeschreibung" auf Ebay? JTL-Wawi 1.8 9
Neu Nach Umstellung auf WMS Probleme mit der JTL Ameise Installation von JTL-WMS / JTL-Packtisch+ 0
Neu Vorschaubilder in der Artikeldetailseite werden nicht angezeigt Betrieb / Pflege von JTL-Shop 1
Neu Update des JTL shops aus der Wawi funktioniert nicht Allgemeine Fragen zu JTL-Shop 1
Neu EK-Netto der Verkäufe aus Datenbank ? User helfen Usern - Fragen zu JTL-Wawi 5
Neu Shopify Erhöhung der Varianten von 100 auf 2000 - Connector App Problem Shopify-Connector 4
Fehler beim Rendering der Attribute bei SCX Abgleich kaufland.de - Anbindung (SCX) 4
Neu Eigene Felder des Auftrages in der Druckvorlage Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu klare Warnung vor den Bausteinen und der PDF in Vorlagen User helfen Usern - Fragen zu JTL-Wawi 4

Ähnliche Themen