felix.bauerschaefer

Sehr aktives Mitglied
15. November 2019
218
31
Nienburg/Weser
Hallo miteinander,

Problem bei manchen Artikeln auf unseren Webshop wird der URL-Pfad trotz vorhandener Metadaten in der Artikelbeschreibung nicht richtig gesetzt.
Andere Artikel wiederum werden beim erstmaligen Übertragen direkt mit richtigem Shop URL-Pfad angezeigt.

Wir benutzen momentan:
JTL-Shop 4.05.9
JTL-Wawi 1.5.28.0

Das gleiche gilt auch für Kategorie Pfade handelt es sich hierbei um einen vielleicht mitgeschleiften Bug konnte im Issue Tracker nichts finden für die Version.
Oder würde ein Komplettabgleich das Problem vielleicht schon beseitigen können? Ich musste mehrfach einen Artikel erneut hochladen bis das Problem verschwunden ist.

Generierter URL-Pfad vom System und darunter, derjenige der eigentlich angezeigt werden soll.
Code:
https://www.iw-nord.de/navi.php?a=705694
https://www.iw-nord.de/Quartar-Clean-100-Desinfektionsreiniger-gebrauchsfertig-500-ml-Flasche

Mit freundlichen Grüßen
Felix Bauerschäfer
 
Zuletzt bearbeitet:

Rainer S

Moderator
Mitarbeiter
8. August 2018
742
128

felix.bauerschaefer

Sehr aktives Mitglied
15. November 2019
218
31
Nienburg/Weser
Wir hatten eine ähnliche Vermutung und sind von PHP 7.4 auf 7.0 zurück. Genauer gesagt gerade: 7.0.33nmm1, leider scheint das Problem zu bestehen. Wir sind momentan, dabei auch wieder auf einen aktuellen Stand zu kommen nur ist uns dies aufgefallen und ich konnte in diesem Fall kein Bug-Report dafür vorfinden.
Die Artikel wurden vor der Umstellung erstellt, verwundert mich also warum überhaupt solche URLs erstellt, umgestellt worden sind. Umstellung erfolgte am Freitag ich versuche mal ein zwar Artikel, vom Shop zu nehmen und erneut hochzuladen da es bereits bei anderen Artikeln scheinbar den URL-Pfad repariert hatte.

EDIT: Scheint, ein resultierter Fehler aus der PHP-Version zu sein.
 
Zuletzt bearbeitet:

Hias

Mitglied
4. März 2019
4
0
Hi,
wir haben das gleiche Problem
PHP-Version 7.3.23-he.0
Shopversion 4.06 (Build: 17)

Shop Komplettabgleich gemacht, Problem bleibt bestehen

noch jemand eine Idee?
 

felix.bauerschaefer

Sehr aktives Mitglied
15. November 2019
218
31
Nienburg/Weser
Wir benutzen momentan PHP-Version:
7.3.22-nmm1

Mit dieser haben wir nicht mehr die URL-Pfad Probleme. Das oben war von mir falsch gedacht, war noch bei SEO-Pfad Problemen.
Mit der gleichen Shop-Version wie Ihr, vielleicht ist in eurer PHP-Version ein Bug drin? Könntet ihr versuchen auf die schnelle eine andere zu verwenden? Ansonsten beim Hoster- /Anzufragen das er eine andere PHP-Version für euren Server bereitstellen kann auf PHP Version 7.3.
 

Entenfurz

Gut bekanntes Mitglied
28. Januar 2016
111
0
Auch wir haben das gleiche Problem
Vorher Shop 4 06 09
dann verschwanden bei allen Artikel bei denen wir Updates gemacht hatten und neu hochgeladen haben die Seo Urls, während bei alten Artikeln diese noch funktionierten.
Dann manuell auf 4 06 17
geupdatet weil wir dachten das hängt mit dem PHP Update bei HostEurope zusammen, die haben seit kurzem PHP 7.4.11-7.4.11-1
Wawi mit 1 35 0 auch auf den neuesten Stand gebracht
Cache geleert, alle Artikel neu abgeglichen, weiterhin wird nur die URL mit der Artikelnummer angelegt. Ist Blöd, da alle Urls von uns bei Google nun flöten sind, da Google die SEO Urls nutzt.
Dieses Problem taucht auf sowohl bei Artikeln mit speziell angelegter SEO Url, als auch bei Artikeln ohne Seo Url. Die SEO Url taucht nirgends auf.
Das gleiche auch bei den URLs zu den einzelnen Kategorien, vorher SEO Url, jetzt Nummer.
Da muss irgendwo bei euch wohl ein Fehler sein, wenn wir nicht allein sind...
Update: Hatten vorher 7.2, da funktionierte es, habe jetzt bei HostEurope gebeten uns auf 7.3 runterzuschrauben, funktionierte aber nach Komplettabgleich leider auch nicht.
 
Zuletzt bearbeitet:

Rainer S

Moderator
Mitarbeiter
8. August 2018
742
128
@marcheller

Gerne kannst du einmal deine Shop URl Posten, der Shop 4 ist nicht mit PHP Version 7.4 kompatibel, wenn du die Shopversion 4.06.17 nutzt mit PHP 7.3 wie du geschrieben hast dann sollten die URLs nach einem manuellen Komplettabgleich auch wieder richtig hinterlegt sein.
 

Hias

Mitglied
4. März 2019
4
0
Also im Testshop hat es nicht funktioniert. Jetzt habe ich die gleichen Schritte im Live- Shop gemacht, jetzt klappt alles
Ich weiß nicht wieso, bin aber natürlich froh dass es jetzt geht :D
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Die Shop-URL verweist nicht auf einen gültigen Shop! Shopify-Connector 1
2 JTL-Shops = unterschiedlicher SEO-URL-Stamm nötig JTL-Wawi 1.8 5
Neu SEO URL der Kategorien wird nicht an Shopware 6 übertragen Shopware-Connector 0
Neu URL einer Unterkategorie weiterleiten Allgemeine Fragen zu JTL-Shop 3
Neu Woocommerce mit JTL Connector "Die Shop-URL verweist nicht auf einen gültigen Shop" WooCommerce-Connector 4
Neu Suche Seite 2 gibt falsche URL aus JTL-Shop - Fehler und Bugs 4
Neu Artikel - Sprachen - Alle eigene SEO URL? Smalltalk 1
Neu URL ändern Allgemeine Fragen zu JTL-Shop 2
Neu Ein Kundenauftrag führt zu Fehlern im Worker "Pfad / Dateiname zu lang" JTL-Wawi - Fehler und Bugs 0
Neu Passwort vergessen Mail wird nicht gesendet in 5.3.1 JTL-Shop - Fehler und Bugs 1
Neu JTL-WMS Mobile Artikelname wird nicht mehr vollständig angezeigt JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Seitennavigation wird doppelt angezeigt Allgemeine Fragen zu JTL-Shop 0
Eigenes Feld wird nicht angezeigt JTL-Wawi 1.8 2
Bestellvorschläge - Lagerbsestand in "Bestand gesamt" wird nicht angezeigt JTL-Wawi 1.8 0
Neu Auftragszahlung über Kasse, Auftrag wird nicht als "Verpackt und Versendet" markiert JTL-POS - Fehler und Bugs 1
Neu Artikel im Warenkorb wird von 1 auf null runtergesetzt. Anstatt es zu entfernen wird es automatisch wieder auf 1 gesetzt Allgemeine Fragen zu JTL-Shop 6
Selbstabholer wird zu DHL national geändert. JTL-Wawi 1.8 1
Neu JTL POS wird nicht an WaWi angebunden Einrichtung / Updates von JTL-POS 2
Globaler Mindestbestand bei neuen Artikeln wird trotz Nullbestand nicht in den Bestellvorschlägen berücksichtigt JTL-Wawi 1.6 1
Neu Neues 5.3 Feature Versandklassen-Assistent wird nicht angezeigt Gelöste Themen in diesem Bereich 5
Neu Bankverbindung wird nicht in Aufträgen/Rechnungen aus Abonnements aktualisiert User helfen Usern - Fragen zu JTL-Wawi 0
Wird jetzt das Widerrufsrecht aufgehoben? Gelöste Themen in diesem Bereich 3
Rechnungsentwurf wird nicht zur Rechnung bei Auslieferung JTL-Wawi 1.8 8
Bestand von Kinderartikeln wird im Vaterartikel zusammenaddiert JTL-Wawi 1.8 1
Neu Rechnungsdatum ist gleich Lieferdatum wird nicht erkannt User helfen Usern - Fragen zu JTL-Wawi 1
Neu PrestaShop Connector für Prestashop 8 mit PHP 8.2 wird nicht unterstützt PrestaShop-Connector 3
Neu Auftrag mit Freiposition Menge 0 läßt sich nicht ausliefern + wird nicht auf Lieferschein angezeigt User helfen Usern - Fragen zu JTL-Wawi 1
Neu Merkmalübersetzung wird im Shop nicht angezeigt JTL-Shop - Fehler und Bugs 2
Neu JTL zu Shopify Bestand wird nicht aktualisiert Shopify-Connector 0
Neu Wo kann ich einstellen, welche Rechnungsvorlage "gezogen" wird Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 13
Neu FBA Lager wird nicht angelegt Amazon-Anbindung - Fehler und Bugs 14
Neu Rechnung wird nicht auf englisch gespeichert Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
In Diskussion Wareneingang Packtisch 1.8.12.0: Seriennumer wird abgeschnitten. JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Fehler: Sonderpreis falsch formatiert, wird nicht importiert; obwohl importiert genau wie exportiert User helfen Usern - Fragen zu JTL-Wawi 0
Neu Versandmail / Versandbenachrichtigung wird nicht gesendet JTL-Wawi - Fehler und Bugs 1
Neu Menüleiste wird plötzlich in der Mitte von der Seite angezeigt Allgemeine Fragen zu JTL-Shop 0
In Diskussion JTL POS Kundennummer wird nicht an JTL Wawi übertragen JTL-POS - Fehler und Bugs 2
Kann ich eine email an die Wawi senden durch die dann ein neuer Auftrag generiert wird? (Daten müssen händisch vervollständigt werden...) JTL-Wawi 1.8 2
Issue angelegt [WAWI-75449] Artikel duplizieren - ASIN wird nicht mit dupliziert. JTL-Wawi - Fehler und Bugs 1
Neu Ware auf Retoureplatz wird als "verfügbar" betrachtet JTL-Wawi - Fehler und Bugs 2
Gelöst Packtisch+ 1.8.112 : Rechnung wird bei Teillieferung erzeugt, obwohl als Ausführungsbedingung "Nur bei der letzten Teillieferung" ausgewählt ist. JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 2
Neu Funktionsattribut unverkäuflich wird nicht an den Shop übertragen Allgemeine Fragen zu JTL-Shop 1
Neu Title Tag wird auf Loginseite nicht übernommen Betrieb / Pflege von JTL-Shop 1
Neu Erstinstallation JTL WaWi 1.8.12 - heruntergeladen wird SQL Express 2017 _statt_ der empfohlenen 2022 Version Installation von JTL-Wawi 8
Neu Kurzbeschreibung von einem "Stücklisten-Artikel" wird in der Rechnungskorrektur Vorlage nicht angezeigt. Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Shop wird nicht verbunden Onlineshop-Anbindung 2
Neu Guthaben reduziert nicht den Auftragswert sondern wird als Zahlung angerechnet User helfen Usern - Fragen zu JTL-Wawi 2
Neu Sortiernummer Merkmalwert wird nicht richtig übernommen (Ameise) JTL-Wawi - Fehler und Bugs 3
Lieferanten EK wird nicht auf Artikelebene kopiert? EK ist überall 0 beim Artikel. JTL-Wawi 1.8 8
Neu Versandkosten Berechnung im Warenkorb wird nicht aktualisiert JTL-Shop - Fehler und Bugs 1

Ähnliche Themen