Neu Synchronisation Kundenrabatt von was abhängig?

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

chmod

Aktives Mitglied
19. März 2012
62
3
#1
Hallo,
wir haben aktuell eine Rabattaktion laufen wo jeder Kunde 10% von seiner Bestellung via Online- Shop abgezogen bekommt (über Kupon), was soweit auch prima funktioniert. Dazu habe ich vorher bei allen Kunden mittels Ameise voreingestellte Kundenrabatte genullt (es sollte kein Rabatt zum Rabatt möglich sein) und dann exportiert, dass diese nach der Aktion wieder sauber importiert werden können. Soweit so gut, hat alles funktioniert in unserer Wawi-Version (1.3.x.x - in der 1.4.x.x gab es eine Variante, die nen Bug hatte beim Import mit der Ameise). Aaaaaber, nun zu meinem Phänomen:
Obwohl in der Wawi nun alle Kundenrabatte auf Null standen (habs mit nem Export nochmal gecheckt) und der Shopabgleich auch funktioniert hat und um die 250 Kunden rabattseitig zurückgestuft hat, sind um die zehn Kunden im Shop zurückgeblieben, die nach wie vor Rabatt in der Shopdatenbank hatten. Habe diese dann manuell vie phpMyAdmin korrigiert, was kein Problem war, jedoch wäre es natürlich interessant, weshalb die ca. zehn Kunden nicht mit der Wawi synchronisiert wurden.
Welche Abhängigkeiten bestehen denn wenn die Wawi Daten zum Shop überträgt? Wann wird ein Datensatz aktualisiert, wann nicht?
Ist nicht wirklich wichtig da das eigentliche Problem manuell berichtigt und somit behoben wurde, wäre aber halt interessant zu wissen warum das so war ...

LG
chmod

P.S. Shop 4 in aktuellster Variante, Wawi V1.3.13.0
 

Mirko.Schmidt

Moderator
Mitarbeiter
14. August 2015
1.680
104
#2
Hallo,
lief vielleicht der Worker noch während des Imports? Dann könnte es sein, dass die Kunden übersprungen wurden. Oder die Aktualisierung nicht richtig gesetzt wurde per Wawi. Ist jetzt schwer ohne Logs zusagen, aber im Regelfall, sobald der Kunde gespeichert wird, wird beim nächsten Abgleich die Daten von diesem Kunden übertragen.
 

chmod

Aktives Mitglied
19. März 2012
62
3
#3
Hallo,
der Worker ist tatsächlich gelaufen, ja. Ok, dann ist das nun auch logisch, wenngleich das schon ein schöner Zufall gewesen sein muss dass ich genau diesen Moment erwischt habe, da der nur alle 15 Minuten einen Shopabgleich durchführt. Danke für die Info.

LG
chmod
 

Ähnliche Themen