Neu Standard-Symbole fehlen

bsa-products

Aktives Mitglied
8. November 2016
13
0
Hi,

in meinem Shop fehlen seit dem Update auf 5.0.0 die ganzen Standard-Symbole wie Pfeile, Warenkorb, Suche etc.
Wechsle ich in den Onsite-Composer, sind sie alle da.

Was könnte hier schiefgelaufen sein?
Es ist das normale Nova-theme im Einsatz.
 

Anhänge

  • symbole.PNG
    symbole.PNG
    4,5 KB · Aufrufe: 10

Notebookpartstore

Gut bekanntes Mitglied
17. März 2013
246
11
Leider hiflt es bei mir nicht habe nach wie vor nur Vierecke :(
Failed to load resource: the servcer respond with a status 403
oder
net::ERR_ABORTED 403

1612000375199.png
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.509
359
Halle
Hallo, das ist meistens ein www / ohne-www Problem. Du solltest die Seite exakt so aufrufen, wie sie in deiner config.JTL- Shop.ini.php eingetragen ist.
 

Notebookpartstore

Gut bekanntes Mitglied
17. März 2013
246
11
Hallo, das ist meistens ein www / ohne-www Problem. Du solltest die Seite exakt so aufrufen, wie sie in deiner config.JTL-Shop.ini.php eingetragen ist.
Hi,
danke für die Rückmeldung.
Leider bleibt das Ergebnis das gleiche... -> Icons fehlen, die Artikelbilder werden aber Korrekt angezeigt.
Ich kann es nicht zu 100% bestätigen aber ich glaube auch, dass es seit dem Umzug auf einen 64Bit Server durch den Hoster gekommen ist.
Kann es sein, dass es hier vll. die Gruppenberechtigungen (Lesen/Schreiben/Ausführen) zerschossen hat?

@FPrüfer
Die Dateiattribute standen bei mir auf 710.
Die Originalattribute stehen auf 750.
Somit denke ich, dass es durch den Umzug passiert ist.

Nachdem ich diese geändert hatte waren die Bilder wieder da.
Ich hatte die Einstellungen auf die Unterverzeichnisse mit einbezogen. Sollte dies ein Problem sein, dass lass mich das wissen damit ich das dort wieder geradebiegen kann.


1612257868766.png

Grüße
Fabian
 
Zuletzt bearbeitet:

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.509
359
Halle
Die Attribute sind natürlich stark von der korrekten Verzeichnisstruktur abhängig. Es kommt z.B. darauf an, wer der Besitzer des Ordners ist. Meistens ist das der FTP-User, der sollte dann auch die 7 (Lesen, Schreiben, Ausführen) haben, damit er das Verzeichnis beschreiben kann. Die Gruppe ist i.a.R die Webserver-Gruppe. Diese sollte Verzeichnisse in jedem Fall lesen können - also 5 (Lesen und Ausführen). Der Rest benötigt normalerweise keine Zugriffsrechte, also 0. Damit geht die 750 in Ordnung. Die 710 funktioniert normalerweise nicht, ausser der Webserver-User ist zugleich der Besitzer des Verzeichnisses. Das würde ich aber für ein Sicherheitsrisiko halten!
Im Normalfall gilt also: Für alle Verzeichnisse 750 (bei manchen Konfigurationen auch 755) und für Dateien entsprechend 640 (ggfs. 644). Verzeichnisse die vom Webserver beschrieben werden müssen, müssen dann entsprechend die 770 (ggfs. 775) haben und beschreibbare Dateien analog dazu 660 (ggfs. 664).