Beantwortet SQLDateTime Überlauf bei initialem Datentransfer

bunzel

Mitglied
31. Mai 2021
49
4
Hallo zusammen,

WAWI Version: 1.5.47.4
Gambio Version: 4.0.2.0
Connector Version: 2.16.3

Ich hab einen bestehenden Gambio Shop erfolgreich mit dem Connector an die WAWI angeschlossen. Bei dem Komplett Abgleich konnten auch alle Kategorien und einige Artikel übertragen werden. Allerdings leider nicht alle Artikel, ich erhalte die nachfolgende Fehlermeldung. In einem älteren Forenbeitrag habe ich schon gefunden, dass man die Datums Felder in Gambio prüfen soll. Ich habe in der Products Tabelle bereits die Datumsfelder angepasst, weiß zufällig jemand wo ich in Gambio noch Datumsfelder anpassen sollte bzw. wie ich das in den Logs finden kann wo der Fehler aufgetreten ist?

Vielen Dank


Fehler aus dem Abgleich Protokoll (Das was direkt beim Abgleich angezeigt wird):


Artikel-Empfangen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
SqlDateTime-Überlauf; muss zwischen 1/1/1753 12:00:00 AM und 12/31/9999 11:59:59 PM liegen.
bei System.Data.SqlClient.TdsParser.TdsExecuteRPC(SqlCommand cmd, _SqlRPC[] rpcArray, Int32 timeout, Boolean inSchema, SqlNotificationRequest notificationRequest, TdsParserStateObject stateObj, Boolean isCommandProc, Boolean sync, TaskCompletionSource`1 completion, Int32 startRpc, Int32 startParam)
bei System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, Boolean inRetry, SqlDataReader ds, Boolean describeParameterEncryptionRequest)
 
Zuletzt bearbeitet:

bunzel

Mitglied
31. Mai 2021
49
4
Update: GELÖST, falls jemand das gleiche Problem hat:

Unter mein-shop.de/jtlconnector/install/#dev_logging lassen sich die Dev Logs als zip runterladen. Da gibt es auch Datenbank logs.
Wenn man nach einem Onlineshopabgleich in den Datenbank logs sucht nach "WHERE products_id = 4711" sieht man in welcher Reihenfolge die Artikel bearbeitet wurden.
Nach der letzten erfolgreich eingelesenen ID, müsste dann die Produkt ID kommen, bei der der Fehler aufgetreten ist.

Da sieht man auch welche SQL Abfragen für jeden Artikel ausgeführt werden, - eine dieser Abfragen müsste das fehlerhafte Datumsfeld erhalten. Hab alle Abfragen ausprobiert Ergebnis:

In der Tabelle specials in Gambio sind noch Datumsfelder auf '1000-01-01 00:00:00'

SQL Befehle für Korrektur (Keine Gewähr):

Werte Datumsfelder anzeigen:
Select Distinct begins_date from specials order by begins_date
Select Distinct expires_date from specials order by expires_date


Werte korrigieren:
Hinweis: Ich habe hier einfach NULL genommen, es kann sein, dass irgendwelche Sonderpreise in Gambio dann nicht mehr richtig funktionieren, evtl. einfach irgendein anderes Datum wie '2020-01-01 00:00:00' verwenden.

Update specials set begins_date = NULL where begins_date = '1000-01-01 00:00:00'
Update specials set expires_date= NULL where expires_date= '1000-01-01 00:00:00'


Ggf. noch die anderen Felder von der Tabelle specials prüfen:
specials_last_modified
specials_date_added
date_status_change
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: bork

Ähnliche Themen