Neu SQL-Fehlermeldung beim Update einer DB auf Version 1.5.30.0 bei FOREIGN KEY-Einschränkung 'FK_dbo_tMerchantVersandRef_kVersand'

Gerhard2019

Mitglied
11. November 2019
5
0
Hallo bekomme immer die gleiche Fehlermeldung egal welche Version ich Updaten möchte: Aktuell ist Version 1.5.29.3 die einzige die läuft. Folgender Fehler tritt immer auf.

03:33:46 Fehler in der Version 1.5.30.0 beim Befehl:
==============================================
IF NOT EXISTS(SELECT *
FROM INFORMATION_SCHEMA.TABLE_CONSTRAINTS
WHERE CONSTRAINT_NAME='FK_dbo_tMerchantVersandRef_kVersand')
BEGIN
ALTER TABLE [FulfillmentNetwork].[tMerchantVersandRef] WITH CHECK ADD CONSTRAINT [FK_dbo_tMerchantVersandRef_kVersand] FOREIGN KEY([kVersand])
REFERENCES [dbo].[tVersand] ([kVersand])
ON DELETE CASCADE
END
==============================================
Message: Das Einführen der FOREIGN KEY-Einschränkung "FK_dbo_tMerchantVersandRef_kVersand" für die tMerchantVersandRef-Tabelle kann Schleifen oder mehrere Kaskadepfade verursachen. Geben Sie ON DELETE NO ACTION oder ON UPDATE NO ACTION an, oder ändern Sie andere FOREIGN KEY-Einschränkungen.
LineNumber: 5
Procedure:


03:33:46 Fehler in der Version 1.5.30.0 beim Befehl:
==============================================
IF NOT EXISTS(SELECT *
FROM INFORMATION_SCHEMA.TABLE_CONSTRAINTS
WHERE CONSTRAINT_NAME='FK_dbo_tMerchantVersandRef_kVersand')
BEGIN
ALTER TABLE [FulfillmentNetwork].[tMerchantVersandRef] WITH CHECK ADD CONSTRAINT [FK_dbo_tMerchantVersandRef_kVersand] FOREIGN KEY([kVersand])
REFERENCES [dbo].[tVersand] ([kVersand])
ON DELETE CASCADE
END
==============================================
Message: Die Einschränkung oder der Index konnte nicht erstellt werden. Siehe vorherige Fehler.
LineNumber: 5
Procedure:

Vielen Dank für Eure Hilfe
 

HMS_IT

Sehr aktives Mitglied
29. Januar 2014
782
110
Leipzig
Der Fehler resultiert aus der Fuflillment-Schnittstelle. Das muss JTL fixen, mach ein Support-Ticket auf.
 

MKoberstein

Aktives Mitglied
25. September 2018
5
0
Hallo, ich wollte meine schon etwas ältere Version 1.5.12.1 nun auch mal auf die aktuellste Version bringen und bekomme den selben Fehler bei Zwischenschritt 1.5.30.0.

Gibt's da jetzt einen schnellen Fix oder muss ich auch ein Supportticket erstellen?
 

MKoberstein

Aktives Mitglied
25. September 2018
5
0
Niemand einen Tipp? Zumal ich die Fulfillment-Schnittstelle noch nie benutzt oder getestet habe.
 

T4DT.GmbH

Offizieller Service Partner
SPBanner
6. November 2018
332
167
Hannover
Das liegt daran, dass der Schlüssel bereits mit dem FK_FulfillmentNetwork_tMerchantVersandRef_kVersand existiert und die JTL-Migration kaputt ist.
Um das Problem zu beheben müsste es reichen den o.g. FK vor dem Update zu löschen (oder in FK_dbo_tMerchantVersandRef_kVersand umzubenennen). @MKoberstein

@Gerhard2019

Keine Ahnung warum in aktuellen Setups das immer noch nicht behoben ist. Das Problem ist asbach uralt.
 

Ähnliche Themen