Neu Shopware 6 - Probleme mit Attributen

dotnetpower

Gut bekanntes Mitglied
22. Dezember 2006
197
9
Guten Morgen,

ich versuche grade, so wie bei Shopware 5, mittels Attributen Datenbankfelder zu setzen.
Primär geht es darum für den Alterscheck von Repertus zu steuern. Dieser erstellt in der Tabelle "product" die Spalte age_id. Wenn ich jetzt die age_id als Attribut angebe, dann wird die zwar in den Shop geschrieben und taucht auch beim Produkt unter den Zusatzfeldern auf, nur in die Spalte age_id der Tabelle product wird nix geschrieben...

1614161109731.png

Hat jemand ähnliche Probleme? Ticket erstell ich auch gleich...

Gruss,
Bernd
 

saimax

Aktives Mitglied
10. Mai 2010
35
2
Hamburg
Du meinst Shopware 6. (jedenfalls nach deinem Bild oben)
Die Attribute müssen den gleichen Namen haben.
Also z.B. JTL Wawi age_id dann bei Shopware unter Zusatzfeldern den technischen Namen auch age_id nennen.
Wenn der in Shopware nicht angelegt ist wird er erzeugt und landet in custom_jtl.
Besser dieses Attribut selber anlegen und nicht erzeugen lassen.
Das klappt beim ersten Mal auch hervorragend aber leider werden danach Veränderungen nicht mehr übertragen.
Es bleibt immer der erste Wert.
Vielleicht hilft dir das ja.
Gruß

Update.
Nach einem Komplettabgleich werden die Veränderungen übertragen.
 
Zuletzt bearbeitet:

concet

Mitglied
22. Juli 2019
11
5
Wir haben aktuell das selbe Problem. Die Attribute sind zwar allesamt in JTL werden in Shopware aber unter custom_jtl abgelegt in den Pugin-Labels wo die eigentlich rein sollten werden die leider nicht abgelegt in Shopware.

Wie ist hier die beste Vorgehensweise um auch die Konsistenz zu gewährleisten?

Wir würden folgendermaßen vorgehen:
1. Die Attribute in JTL löschen und die enthaltenen custom_jtl in Shopware ebenfalls löschen
2. in JTL einmal neu anlegen
3. Synch nochmal starten

Klingt das sinnvoll?
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu *Probleme mit Shopware-Connector nach Update auf 1.5.42.0 und großem Abgleich* Shopware-Connector 1
Neu Seit Connector Update: Wenn Versand gesetzt, wird kein Lieferschein über den Connector an Shopware 5 übertragen Shopware-Connector 0
Neu Shopware 6 abgleich mit vielen Errors wegen zu langen metaDescription Shopware-Connector 1
Neu Aufträge aus Onlineshop (Shopware) nicht im Filter für Versandart vorhanden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 alle Artikelbilder sind doppelt vorhanden Shopware-Connector 1
Gelöst Fehler bei Shopware 6 Connector Übertragung von Artikelbildern durch den Shopabgleich Shopware-Connector 4
Neu Shopware 5: Paypal Kauf auf Rechnung -> Retouren Shopware-Connector 2
Neu Kundenattribute aus JTL zu Shopware senden Shopware-Connector 1
Neu Shopware 6 Abgleich Problem Bilder Shopware-Connector 3
Neu Shopware 6 langsamer Abgleich Shopware-Connector 6
Neu Datenimport Shopware 5.5.10 zu JTL 1.5.42.0 immer Fehlermeldung Shopware-Connector 3
Neu Eigene Felder bei Shopware 6 Shopware-Connector 1
Neu Kategorien übertragung JTL -> Shopware Shopware-Connector 0
Neu Shopware 5 Connector - JTL WaWi Critical Error User helfen Usern - Fragen zu JTL-Wawi 0
Neu Bilderuplaod Shopware 5 - Connector - ohne Funktion Shopware-Connector 3
Neu JTL-WaWi und Migration Shopware 5 auf Shopware 6 Shopware-Connector 0
Neu Shopware Connector kein Abgleich mehr möglich Shopware-Connector 4
Neu Connector schließt keine Bestellung in Shopware ab Shopware-Connector 6
Beantwortet Shopware 6 - Artikel ohne Bestandsführung nicht kaufbar / als Abverkauf gelistet Shopware-Connector 1
Neu JTL - Shopware 6 Abgleich - CONSTRAINT-Vialoation Shopware-Connector 2
Neu Shopware Connector 5 und 6 Shopware-Connector 4
Neu Keine Bild-Links mehr im Shopware Produktexport (Varianten Lösung) Shopware-Connector 3
Neu Shopware - Connector - JTL 5 Shop Umstieg auf JTL-Shop 0
Neu Shopware 6 und Variantenbilder (Swatches) Shopware-Connector 1
Neu JTL Wawi - Shopware - Subshops mit unterschiedlichen Beschreibungen Shopware-Connector 12
Neu Maximale Verkaufsmenge - Shopware 6 Connector Shopware-Connector 0
Neu Probleme Shipping DHL JTL-ShippingLabels - Fehler und Bugs 7
Neu Probleme mit der Datei feature.json Technische Fragen zu den JTL-Connectoren 3
Gelöst Probleme mit unserem Testshop Einrichtung JTL-Shop5 7
Neu Probleme mit Variantenartikel Betrieb / Pflege von JTL-Shop 1
Neu Erfahrungen/Probleme mit dem Servicedesk Servicedesk (Beta) 7
Neu DHL International nach GB/UK nur Probleme Smalltalk 0
Neu Probleme Probleme Probleme.... Keine Boxen auf der Startseite Einrichtung JTL-Shop5 6
Neu Probleme inkrementierung von LL.CountData Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Probleme beim Einstellen von Produkten auf Amazon JTL-Wawi - Fehler und Bugs 0
Neu 2 MwSt. Probleme User helfen Usern - Fragen zu JTL-Wawi 10
Gelöst Probleme bei Update auf JTL5 - Class not found Installation / Updates von JTL-Shop 1
Neu Probleme mit Shop-Abgleich und Produktbildern & -Beschreibungen Shopify-Connector 12
In Bearbeitung Sunmi T2 + Kundendisplay => Probleme JTL-POS - Fragen zu Hardware 1
Neu Probleme mit der Sitemap / Null gültige Seiten User helfen Usern 5
Neu Probleme Doppelte Rechnungen / Amazon VCS Lite Arbeitsabläufe in JTL-Wawi 0
Neu Probleme mit Nachrichtenversand aus JTL an Ebay-Alias-Emails im Format abc123@members.ebay.com User helfen Usern - Fragen zu JTL-Wawi 0
Neu Probleme mit Abgleich und Varkombis seit 1.1.9 Shopify-Connector 3
Gelöst HTML Editor Probleme JTL-Wawi - Fehler und Bugs 4
Neu Probleme bei Amazon und Servicedesk Servicedesk (Beta) 8
Neu Probleme mit Testshop Installation Installation / Updates von JTL-Shop 4
Neu Probleme mit Retoure bei JTL 1.5.38.1 User helfen Usern - Fragen zu JTL-Wawi 0
Neu JTLShop5 mit PHP8 probleme mit Paypal JTL-Shop - Fehler und Bugs 3
Neu Probleme mit Aktualisierung der Lieferzeiten WooCommerce-Connector 0
In Bearbeitung Verschiedene Probleme mit dem Kundendisplay JTL-POS - Fehler und Bugs 10

Ähnliche Themen