Neu Shop 4.05 Kontakt kann nicht angezeigt werden - HTTP 500

gimba

Aktives Mitglied
14. Februar 2016
68
1
Hallo Community,

ich habe über die Suche leider nichts gefunden, daher versuche ich es auf diesem Wege...
Wir haben kürzlich einen JTL Shop 4.05 aufgesetzt und versuchen uns aktuell noch an der Einrichtung.
Ein Problem technischer Natur beschäftigt uns dabei aktuell in einer Form, dass wir da tatsächlich auf Eure Hilfe angewiesen sind. Wir haben ein Kontaktformular installieren wollen, haben die Einstellungen angepasst, Betreffs hinzugefügt und unter CMS eine Spezialseite Kontakt angelegt. Sobald man diese jedoch aufruft, bekommt man nur einen HTML 500 Fehler. Der gesamte Shop wird über https aufgerufen. Die Einstellung dafür habe ich sowohl mit "Standard" als auch mit "erzwungen" getestet. Auch sonst habe ich quasi alles getestet, was ging und bin mit meinem Latein da nun am Ende.
Kann uns jemand von Euch vielleicht einen brauchbaren Tipp geben?
Vielen dank vorab.
 

gimba

Aktives Mitglied
14. Februar 2016
68
1
Ich habe gerade die JTLDebug Funktion gefunden, die mir folgendes auswirft:

Key setting_1 could not be loaded.
Key setting_1could not be set.
Key tpl_Evo could not be loaded.
Key tpl_Evocould not be set.
Key tpl_Evo could not be loaded.
Key tpl_Evocould not be set.
Key plgnbtsrp could not be loaded.
Key plgnbtsrpcould not be set.
Key setting_11 could not be loaded.
Key setting_11could not be set.
Key setting_124 could not be loaded.
Key setting_124could not be set.
Key tpl__admin could not be loaded.
Key current_template__admin could not be loaded.
Key current_template__admincould not be set.
Key template_minify_data_adm_bootstrap could not be loaded.
Key template_minify_data_adm_bootstrapcould not be set.
Key hook_list could not be loaded.
Key hook_listcould not be set.
Key setting_1 could not be loaded.
Key setting_1could not be set.
Key plgn_2_2_0 could not be loaded.
Key plgn_2_2_0could not be set.

Vielleicht hilft das ja 😉
 

gimba

Aktives Mitglied
14. Februar 2016
68
1
Danke für den Tipp. Die Ausgabe lautet dann wie folgt:
Fatal error: Cannot redeclare eingabenKorrekt() (previously declared in .../htdocs/includes/artikel_inc.php:284) in .../htdocs/includes/kontakt_inc.php on line 153

Entsprechender Auszug aus der kontakt_inc.php:
upload_2017-5-22_11-21-59.png
Ich bin kein Programmierer, aber ich frage mich, warum eine Funktion namens eingabenkorrekt ausgeführt wird, in dem Moment, in dem lediglich die Kontaktseite aufgerufen wird. Sollte das nicht beim Absenden des Formulars erfolgen oder verstehe ich da etwas falsch?
 

gimba

Aktives Mitglied
14. Februar 2016
68
1
includes/libs/flashchart/data-files/bar-test-all.txt - modifiziert - Die Date habe ich dann aus dem ZIP nochmal geuppt, aber ohne Veränderung...

Außerdem wird mir das OS in Gelb angezeigt:
SunOS localhost 5.10 Generic_142901-13 i86pc (SunOS localhost 5.10 Generic_142901-13 i86pc)

Stellt das etwa ein Problem dar?
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Hallo,
Fatal error: Cannot redeclare eingabenKorrekt() (previously declared in .../htdocs/includes/artikel_inc.php:284) in .../htdocs/includes/kontakt_inc.php on line 153
Der Namenskonflikt ist äußerst ärgerlich, aber normalerweise sollte im Standard keine Konstellation existieren, in der die beiden Dateien gleichzeitig inkludiert werden. Sind irgendwelche Plugins aktiv oder werden auf der Kontakseite spezielle Boxen angezeigt? Wenn ja, dann mal bitte einzeln deaktivieren um ggfs. herauszufinden wo da was zuviel geladen wird.
 
  • Gefällt mir
Reaktionen: gimba

gimba

Aktives Mitglied
14. Februar 2016
68
1
Hallo,

Der Namenskonflikt ist äußerst ärgerlich, aber normalerweise sollte im Standard keine Konstellation existieren, in der die beiden Dateien gleichzeitig inkludiert werden. Sind irgendwelche Plugins aktiv oder werden auf der Kontakseite spezielle Boxen angezeigt? Wenn ja, dann mal bitte einzeln deaktivieren um ggfs. herauszufinden wo da was zuviel geladen wird.
Das war es, vielen Dank FPrüfer. Ein Plugin von SuS ITS war hier der Übeltäter. Ich werde also dort ansetzen.
Danke auch an ag-websolutions für die tatkräftige Untersützung.
 

deliman

Sehr aktives Mitglied
13. Februar 2016
1.069
132
Hallo,

habe das gleiche Problem mit einem SuS IT Plugin (Längen- & Flächenberechnung) - Kontaktseite bleibt weiß wenn das Plugin aktiv ist. Wie wurde das Problem gelöst, damit man das Plugin trotzdem nutzen kann? Hat SuS IT da etwas gefixt?
 

gimba

Aktives Mitglied
14. Februar 2016
68
1
Nein, die sind wohl da dran, eine Version für 4.05 zu entwickeln, mit der dann alles wieder gehen soll. Ich habe denen von diesem Fehler berichtet und es wird mit berücksichtigt, so versicherte man mir.
Man sagte mir außerdem, dass es wohl ca drei Wochen dauern wird. Das ist jetzt auch schon fast drei Wochen her. Ich warte auch jeden Tag drauf 😀
 

Ähnliche Themen