Neu Server-Error beim Export von Shopping-Feeds (Google, Idealo etc.)

Belushi

Gut bekanntes Mitglied
5. September 2019
127
11
Berlin
Hallo Leutz,

ist vermutlich kein Bug am Shop, wusste aber nicht, wohin mit dem Thema.

Problem: Wenn ich Datenfeeds für z.B. Google-Shopping* oder Idealo im Backend erstelle (weißer Plus-Button!), crasht der Shop mit einem 500-Fehler. In der Folge werden auch die Cron-Jobs vom Aufgabenplaner nicht oder unvollständig ("1000 von 2100") ausgeführt.

Der asyncrone Export (blauer Button) funktioniert hingegen problemlos!

Leider habe ich keinen Zugriff auf die Server-Log-Dateien, und im Shop-Log findet sich nichts. 🙁
Ich vermute aber stark, dass ich beim "normalen" Export bzw. den Cron-Jobs entweder gegen ein Time- oder ein Memory-Limit laufe.

Da der asynchrone Export offenbar mit kleineren Batchgrößen arbeitet (also die Anzahl der Produkte, die in einem Rutsch exportiert werden!) würde ich für den normalen Export den Wert gerne mal von Standard "1000" auf z.B. "500" runtersetzen und sehen, ob es dann funktioniert.

Gibt es einen einfachen Weg, das einzustellen?
Und wenn nicht, weiß jemand, wo ich das im PHP anpassen kann?

Danke im Voraus für jeden Tipp!
Belushi

*) Für Google Shopping verwenden wir nicht das Plugin, sondern einen manuell erstellten Feed. Es geht also tatsächlich in beiden Fällen um die 'native' Exportfunktion.
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
952
203
Hi, du könntest in der jrl Shop Config Datei ersteinmal die halbieten Standardwerte versuchen für die Exporte.

define('EXPORTFORMAT_LIMIT_M', 1000);
define('JOBQUEUE_LIMIT_M_EXPORTE', 250);

anstatt 2000 werden hier nur 1000 Artikel pro durchlauf hinterlegt und beim Aufgabenplaner dann nur 250 anstatt 500.
 

Belushi

Gut bekanntes Mitglied
5. September 2019
127
11
Berlin
Baah... genau sowas hab ich wie blöde gesucht; konnte ja nicht sein, dass das "hart" programmiert ist! 🥳
Wird umgehend getestet, Danke!! 👍
 

Belushi

Gut bekanntes Mitglied
5. September 2019
127
11
Berlin
So, getestet:

Mit define('EXPORTFORMAT_LIMIT_M', 1000); hat es fast immer funktioniert; letztlich musste ich nochmal halbieren auf 500 um wirklich bei 10 von 10 manuellen Exporten alle fehlerfrei abschließen zu können.
Dass der Cron nicht läuft scheint andere Ursachen zu haben; da teste ich noch. Ist hier im Forum ja auch immer wieder mal Thema.
Aber wichtig ist, dass der manuelle Export jetzt funktioniert!

Danke nochmal für den rettenden Tip 😉
 
  • Gefällt mir
Reaktionen: Rainer S

Ähnliche Themen