Gelöst Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

su.puk

Aktives Mitglied
1. März 2013
34
1
Wuppertal
Hallo zusamman,

ich bin nun daran auch mal die Betaversion zu testen.
Leider fangen die Probleme schon beim DB-Update an....

Mein Testsystem ist ein HP Notebook Elitebook 8470 mit 4 GB Ram. (Was glaube ich nicht wirklich zum Fehler führt)
Es läuft MSSQL 2012 (wie im Link des Betatests angegeben/ zuvor waren ältere MSSQL Express Versionen Installiert diese aber schon länger entfernt wurden)
JTL Version 0.9.9.966


Die Datenbank ist unsere aktuelle Datenbank die wir auf unserem Produktivsystem einsetzen. Auf diesem ist eine Test/Free Version von LSPOS installiert, da wir das auch nutzen möchten.
Vor dem Update habe ich (hoffentlich) alle Tabellen die auf LSPOS verweisen entfernt, da ich anfangs meinte , dass der Fehler hierherkommen könnte.

Leider habe ich kaum Ahnung von Datenbanken darum weiß ich jetzt nicht wie ich die Fehler Interpretieren muss-

Hoffe es kann mir jemand beim Update helfen.

Unten nun meine Fehler und die dazugehörende Datei im Anhang (in der Zippdatei!)


Schon mal Vielen Dank und Viele Grüße

Roland Brandel

FourbeeS.de

1/15
Das dbo.POS_BonICWarenLager-Objekt wurde nicht gefunden, weil es nicht vorhanden ist oder Sie nicht über die entsprechenden Berechtigungen verfügen.
errorlog_201508101150_01.txt




2/15
Das dbo.POS_BonICWarenLager-Objekt wurde nicht gefunden, weil es nicht vorhanden ist oder Sie nicht über die entsprechenden Berechtigungen verfügen.
errorlog_201508101205_02.txt




3/15
PK_tArtikelSpeicher ist keine Einschränkung. Die Einschränkung konnte nicht gelöscht werden. Siehe vorherigen Fehler.
errorlog_201508101209_03.txt




4/15
DF_teinstellung_nArtDelete ist keine Einschränkung. Die Einschränkung konnte nicht gelöscht werden. Siehe vorherigen Fehler.
errorlog_201508101210_04.txt




5/15
Der Wert NULL kann in die nAbgelaufenesMHDNichtEinbuchen-Spalte, eazybusiness.dbo.TWarenLagerOption-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert.
errorlog_201508101211_05.txt




6/15
DF_tversandart_nVersandMailNichtSenden ist keine Einschränkung. Die Einschrängkung konnte nicht gelöscht werden. Siehe vorherigen Fehler.
errorlog_201508101217_06.txt




7/15
(2x) Der Wert NULL kann in die VerfuegbarZulaufEigen-Spalte, eazybusiness.dbo.tlagerbestand-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert.
errorlog_201508101221_07.txt




7/15
Der Wert NULL kann in die nPrioritaet-Spalte, eazybusiness.dbo.tZahlungsarten-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert.
errorlog_201508101225_08.txt




9/15
PK_tvteuerzone ist keine Einschränkung. Die Einschrängkung konnte nicht gelöscht werden. Siehe vorherigen Fehler.
errorlog_201508101229_09.txt




10/15
(3x) Der Wert NULL kann in die tLagerbestandEigen-Spalte, eazybusiness.dbo.tLagerbestand-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert.
errorlog_201508101237_10.txt




11/15
(3) Der Wert NULL kann in die tLagerbestandEigen-Spalte, eazybusiness.dbo.tLagerbestand-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert. Der Wert NULL kann in die tLagerbestand-Spalte, eazybusiness.dbo.tLagerbestandProLager-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Update.
errorlog_201508101240_11.txt




12/15
(2) Der Wert NULL kann in die tLagerbestandEigen-Spalte, eazybusiness.dbo.tLagerbestand-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert. Der Wert NULL kann in die tLagerbestand-Spalte, eazybusiness.dbo.tLagerbestandProLager-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Update.
errorlog_201508101251_12.txt




13/15
Der Wert NULL kann in die tVersandMailNichtSenden-Spalte, eazybusiness.dbo.tVersandart-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert.
errorlog_201508101254_13.txt




14/15
(2) Der Wert NULL kann in die tLagerbestandEigen-Spalte, eazybusiness.dbo.tLagerbestand-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert. Der Wert NULL kann in die tLagerbestand-Spalte, eazybusiness.dbo.tLagerbestandProLager-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Update.
errorlog_201508101257_14.txt




15/15
(2) Der Wert NULL kann in die tLagerbestandEigen-Spalte, eazybusiness.dbo.tLagerbestand-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Insert. Der Wert NULL kann in die tLagerbestand-Spalte, eazybusiness.dbo.tLagerbestandProLager-Tabelle nicht eingefügt werden. Die Spalte lässte NULL-Werte nicht zu. Fehler bei Update.
errorlog_201508101259_15.txt
 

Anhänge

Petuchov

Sehr aktives Mitglied
1. Oktober 2009
1.695
23
Augsburg
AW: Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

Mal aus der Hüfte
weil es nicht vorhanden ist oder Sie nicht über die entsprechenden Berechtigungen verfügen.
als admin drin rechte geprüft?
Beim update kommt zuerst die Migration der LAger

Das hat alles mit dem Lager zu tun, baut anscheinend einander auf ..
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

Hallo,

es liegt daran das die Tabelle POS_BonICWarenLager gelöscht wurde. Diese wird von der Wawi angelegt und benutzt!

Bitte das über Management Studio ausführen, danach sollte das Update funktionieren.

Code:
CREATE TABLE [dbo].[POS_BonICWarenLager] ( 
  [kBonICWarenLager] bigint IDENTITY(1, 1) NOT NULL,
  [kBonIC] bigint NULL,
  [kWarenLager] bigint NULL,
  CONSTRAINT [PK_POS_BonICWarenLager] PRIMARY KEY CLUSTERED ([kBonICWarenLager]) )
 

su.puk

Aktives Mitglied
1. März 2013
34
1
Wuppertal
AW: Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

Hi,

schon mal danke für die Antworten.
@charlyhahn : Ich denke schon dass der User die Rechte haben müsste.

Hallo Jamusch,
ich habe den Befehl in einen Abfragefenster eingegeben und ausgeführt aber es schlug mit dieser Fehlermeldung fehl.

Meldung 102, Ebene 15, Status 1, Zeile 7
Falsche Syntax in der Nähe von ')'.

Mir ist dabei aufgefallen das eine Klammer offen geblieben ist und diese habe ich (am Ende )mit ');' geschlossen.

Nun lief zwar die Abfrage mit Erfolg durch aber die Tabelle hat er nicht erstellt. Zu mindest finde ich Sie unter Tabellen nicht...
Muss ich da etwas speziell beachten mit dem Management Studio oder habe ich doch noch etwas falsch gemacht?

Habe noch ein Printscreen vom ManagementStudio angefügt...

Danke an alle für die Hilfe und viele Grüße




Roland

SQL_Befehl.jpg
 

Anhänge

  • SQL_Befehl.jpg
    SQL_Befehl.jpg
    98,6 KB · Aufrufe: 32

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

Hallo Roland,

stimmt, die letzte Klammer wurde fehlt.

Du mußt im Studio oben links die Datenbank "eazybusienss" wählen, da steht master.
Danach sollte alles passen. Ich habe es etwas verkürzt die Prüfung vorne war unnötig.
 

su.puk

Aktives Mitglied
1. März 2013
34
1
Wuppertal
AW: Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

Hallo Janusch,

ich liebe Entwickler die nie schlafen 😉

Es hat wunderbar funktioniert!

Vielen Dank nochmal, jetzt kann ich testen.


Gruß Roland
 

su.puk

Aktives Mitglied
1. März 2013
34
1
Wuppertal
AW: Probleme bei DB Update von 0.9.9.923 auf 0.9.9.966 (BETA) - 15 Fehler

Kann ich das Thema auf gelöst setzen? oder kannst nur Du das?
 

Ähnliche Themen