Neu Php-Version 5.4.45 - Abschaltung bei all-inkl

sasch1980

Gut bekanntes Mitglied
27. März 2012
345
5
Hallo,
mein Hostinganbieter all inkl hat mitgeteilt, dass die Php-Versionen 5.2., 5.3. und 5.4. nicht mehr unterstützt werden.
Ich habe keine Ahnung, was das bedeutet und was ich nun tun muss.
Meine Shopversion ist 3.2 (php- Version 5.4.45-nmm3).


Kann es mir jemand erklären?

Danke schon mal und schöne Weihnachtstage!




"die in einer .htaccess Datei gesetzte PHP Version ist zu alt

Loggen Sie sich per FTP in Ihren Webspace ein und bearbeiten Sie folgende .htaccess Dateien. Entfernen Sie dort die AddHandler phpXX-cgi .php Zeilen oder heben Sie die PHP Version alternativ an.

folgende Subdomains oder Domains sind betroffen:

PHP 5.4: /.htaccess "
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.510
698
Berlin
AddHandler php55-cgi .php

der Shop kann bis zu 5.6 gehen, ich gehe davon aus, wenn du AddHandler php56-cgi .php schreibst würde er auch diese ziehen.
Eventuell kannst du auch im Backend vom Hoster die PHP Version direkt einstellen.

Es kann sein das ältere Plugins dann motzen, weil Sie nicht für höhere Versionen vershclüsselt wurden, das musst du im einzelnen testen.
 

sasch1980

Gut bekanntes Mitglied
27. März 2012
345
5
AddHandler php55-cgi .php

der Shop kann bis zu 5.6 gehen, ich gehe davon aus, wenn du AddHandler php56-cgi .php schreibst würde er auch diese ziehen.
Danke schön für die schnellen Antworten!

Wie stelle ich den Shop auf 5.6 um? (Ohne Update möglich?) Dann muss ich sicherlich irgendwann damit rechnen, ein Update auf den 4er Shop machen zu müssen, oder?
Was bedeutet Übersteuerung?

Tschuldigung, verstehe grad nur Bahnhof ;)
 

ag-websolutions.de

Moderator
29. Dezember 2009
14.548
219
Du kannst im all-inkl - Backend (kasserver) für jede deiner (Sub-)Domäne einstellen, auf welcher php-Version diese laufen soll.

Dies hat solange Gültigkeit, wie sich auf dieser (Sub-)Domäne keine htaccess befindet, in der mittels dem Eintrag "AddHandler phpXX-cgi" eben diese zentrale Einstellung übersteuert wird.
Meine Empfehlung:
- kein Eintrag in der htaccess
- dafür Steuerung über kasserver

Bei php5.6 brauchst du ein neues Shop-Installationspaket.
Wende dich am besten an die Supporthotline von JTL
 

sasch1980

Gut bekanntes Mitglied
27. März 2012
345
5
Noch mal für Dummies ;) ... :

Ist es richtig, dass ich die Zeile
#zum arbeiten mit PHP 5.4 AddHandler php54-cgi .php
einfach komplett entfernt habe?

Damit ist die .htaccess-Datei ja nun leer.