Abgelehnt Packtisch hängt bei Artikelscann / Warenausgang

pixxass

Sehr aktives Mitglied
8. Februar 2017
244
56
Chemnitz
Hallo liebe Gemeinde,

wir haben heute sporadisch das Problem, dass beim Warenausgangs-Scann es teilweise sehr lang dauert, bis der Artikel verbucht wurde.
Serverseitig sieht es von den Ressourecen her alles ok aus. Auch das Netzwerk ist kaum belastet.
Im Ereignisprotokoll von Windows fand ich unter Anwendungen aber exakt zu den fraglichen Zeiten folgende Fehlermeldungen:

Eine mögliche Endloswiederholung der Neukompilierung wurde für SQLHANDLE "0x020000004A178C1A45E29F39325EC6E81C6C5895F79345D90000000000000000000000000000000000000000", PlanHandle "0x060005004A178C1A409E4DA74502000001000000000000000000000000000000000000000000000000000000", Startoffset "0", Endoffset "134" erkannt. Die letzte Neukompilierungsursache war "1".

Eine mögliche Endloswiederholung der Neukompilierung wurde für SQLHANDLE "0x02000000647FD2011817F7B292752BD86472906AC4BB9D3D0000000000000000000000000000000000000000", PlanHandle "0x06000500647FD20140AF6A8F4502000001000000000000000000000000000000000000000000000000000000", Startoffset "0", Endoffset "28556" erkannt. Die letzte Neukompilierungsursache war "1".

Eine mögliche Endloswiederholung der Neukompilierung wurde für SQLHANDLE "0x020000002DE5CD0A4BD0FF7566109EB79ECEC27BA6E5F92C0000000000000000000000000000000000000000", PlanHandle "0x060005002DE5CD0A705B1B884502000001000000000000000000000000000000000000000000000000000000", Startoffset "0", Endoffset "25924" erkannt. Die letzte Neukompilierungsursache war "1".


Diese Meldungen finden sich natürlich auch genau so im SQL Log.

Soweit ich mich erinnere hat dies aber was mit Tokenübegabe / Abfrag zu tun (leider haben wir aktuell auch Probleme mit einer Drittanbieter API (Idealo Direktanbindung) - die aber hier eigneltich nur über die Shopdatenbank arbeitet und nichts direkt mit dem Warenausgangsscan (Datenbank Wawi) zutun haben sollte. Die API löst eigentlich nach dem Buchungsereignis aus.

Zusätzlich wurde heute fast exakt mit Beginn der Fehlermeldungen ein Unicorn Update durchgeführt. Nun bin ich unsicher, was die Ursache hierzu sein könnte.... Eigentlich tippe ich eher auf Unicorn (die es meistens sind), möchte aber kurz sicher gehen, ob nicht vielleicht doch ein Wawi / Packtisch Problem besteht bzw. bekannt ist (ich habe bei der Suche im Forum sowie dem Issue Tracker nichts gefunden.
 
Zuletzt bearbeitet:

pixxass

Sehr aktives Mitglied
8. Februar 2017
244
56
Chemnitz
Edit: Wir haben über Mittag Unicorn deaktivert. Alles fein. Keine Fehlerlog mehr dazu.
Danach nun vor 3 Minuten Unicorn wieder aktiviert und mit einem Schlag ging fast nichts mehr. Lange Buchungszeit und Fehlermeldungen wie oben.
Ich wende mich (wiedermal) an Unicorn...

PS: Wenigstens konnte bei der Suche nach dem Fehler, gleich der andere Fehler der API gelöst werden 😉
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Stetto

Stetto

Sehr aktives Mitglied
2. Juli 2009
4.818
580
Vielen Dank. Es liegt vermutlich daran, dass Unicorn und WMS zeitgleich auf zentrale Artikeldaten zugreifen.

Die Zugriffe ändern sich zwar nicht, bei einigen Kunden brachte es aber schon Abhilfe Unicorn in einen eigenen SQL-Mandanten auszulagern und nicht direkt in der Wawi-DB zu betreiben.
 

pixxass

Sehr aktives Mitglied
8. Februar 2017
244
56
Chemnitz
Der Fehler konnte durch simples Deaktiveren einer Option im Unicorn Menü umgangen werden. Einfach den Haken bei "Fehler an Wawi senden" rausnehmen 🙂
 
Zuletzt bearbeitet:

Ähnliche Themen