Nach Upgrade auf V.5 und Umzug anderen Server, sind alle gemachten Anpassungen verschwunden.

BlueOlive

Neues Mitglied
28. September 2020
13
1
Hallo in die Runde,

ich habe folgende Situation:

Ich habe vom bisherigen Shop eine Kopie angelegt, diese geupdatet auf Version 5 und das hat auch gut funktioniert.
Jetzt habe ich die geupdatete Kopie auf den Server umgezogen auf dem der Shop in Zukunft laufen soll hierbei sind alle Anpassungen verschwunden, die ich selber im Shop vorgenommen habe. (Startseitentext, Shop-Logo, Links im Footer, etc.)

Die Artikel sind alle da, aber das Frontend hängt auch ein Bisschen. Wenn ich Artikel in den Warenkorb lege, dann werden die nicht direkt oben als im Warenkorb angezeigt und erscheinen erst, wenn ich die Seite neu lade. Hierbei kann es sich aber auch um ein gesondertes Problem handeln

Gehe ich recht in der Annahme, dass das ein Datenbank-Problem ist? Der hat mir nach dem Umzug, die Datenbank erneut geupdatet, so wie als ich den Shop auf Version 5 geupgraded habe. Ich hab nicht ganz verstanden, warum, denn das war ja eigentlich schon auf dem Testserver geschehen.


Hat jemand eine gute Idee, wie in dieser Situation, weiter vorzugehen ist?

Liebe Grüße



so sollte es aussehen:
1613573058627.png


und so sieht es auf dem Server aus, auf dem der shop in Zukunft laufen soll:


1613573140427.png
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.493
349
Halle
Hallo, die Frage ist: Mit welcher Datenbank hast du denn den Shop nach dem Umzug auf einen neuen Server verbunden? Bei einem neuen Server hast du wahrscheinlich auch eine neue Datenbank angelegt und dort ein Backup eingespielt - Welches Backup?
Für dein Szenario gibt es mehrere "Stolperstellen". War der "bisherigen Shop" weiterhin online und wurde mit der Wawi abgeglichen, während du die Kopie geupgraded hast? Wenn ja, kannst du nicht einfach die Datenbank der Kopie für den Start auf dem neuen Server verwenden. Du MUSST dort die Original-Datenbank erneut migrieren und deine Änderungen aus der "Kopie" per Hand nachtragen. Ansonsten verlierst du alle Kunden und Bestellungen die während der "Einrichtungsphase" im original-Shop eingegangen sind. Die Wawi "kennt" dann zudem einen Zustand (mit anderen IDs) des Shops, der so nicht existiert und es kann zu Datenfehlern und im schlimmsten Fall dazu kommen, dass neue Kunden Einsicht in die Bestellungen bereits bestehender Kunden bekommen.
Wurde die "Kopie" jemals mit derselben Wawi wie der "bishereige" Shop verbunden? Wenn ja, wie?
 

BlueOlive

Neues Mitglied
28. September 2020
13
1
Hallo und Danke für die Schnelle Antwort.

Das mit den Kunden sollte kein Problem sein. Wir bauen den Shop gerade neu auf und der war noch nicht live.
Ich habe den 4er Shop geupgraded und dann ein backup von der geupgradeten Datenbank (jetzt ja 5er Shop) auf dem neuen Server in eine neu angelegte Datenbank importiert.
Der alte Shop wurde nicht mit der Wawi abgeglichen.
Die Wawi hatte ich mit meinem 5er Testshop nicht verbunden, sonder jetzt erst wieder auf dem Server auf dem das dann auch alles laufen soll, angebunden.

Aber ich sehe das schon richtig, dass dies ein Datenbankproblem ist, oder?

Liebe Grüße
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.493
349
Halle
Hallo,
Aber ich sehe das schon richtig, dass dies ein Datenbankproblem ist, oder?
ja, dass ist ein Datenbankproblem. Das sieht so aus, als hättest du dann doch nicht das Backup von NACH dem Upgrade sondern das von DAVOR eingespielt. Wenn alles noch nicht Live ist und noch kein weiterer Abgleich mit der Wawi stattgefunden hat, kannst du einfach das passende Backup nochmal einspielen.
 

BlueOlive

Neues Mitglied
28. September 2020
13
1
Herzlichen Dank für die kompetente Antwort.

Ich hab jetzt den 4er Shop nochmals kopiert und diese kopie geupdatet und dann erneut eine datenbankkopie von dem kopieten ehmals 4er, jetzt 5er gezogen und nun klappt es. Ich kann nicht nachvollziehen, was da mit den Datenbanken schiefgelaufen ist...

Nochmals danke :)
 
Ähnliche Themen
Titel Forum Antworten Datum
nach Upgrade auf v5 "in den Warenkorb"- Buttons ohne Funktion Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Nach Upgrade auf SQL 2017 Express User helfen Usern - Fragen zu JTL-Wawi 0
Nach Upgrade von Shop 4 auf Shop 5 extrem langsam Upgrade JTL-Shop4 auf JTL-Shop5 11
NOVA Template zerschossen nach Upgrade von 4 auf 5 Upgrade JTL-Shop4 auf JTL-Shop5 0
Nach Upgrade fast alle eigenen Seiten verschwunden Upgrade JTL-Shop4 auf JTL-Shop5 8
Neu Fehler beim Abgleich JTL nach WooCommerce User helfen Usern - Fragen zu JTL-Wawi 0
Neu Falscher Bestellstatus bei Amazon nach Umstellung auf DHL Versenden User helfen Usern - Fragen zu JTL-Wawi 1
Neu Shop läuft nicht mehr nach Update Mollie 1.01 Plugins für JTL-Shop 0
In Bearbeitung Lagerbuchung nach Verkauf aus dem POS Allgemeine Fragen zu JTL-POS 1
Gelöst Kasse kann keine Verbindung zum TSE herstellen nach letztem Update JTL-POS - Fehler und Bugs 2
In Bearbeitung Artikelbestandsänderung POS nach Umlagerung in WMS JTL-POS - Fehler und Bugs 3
Neu *Probleme mit Shopware-Connector nach Update auf 1.5.42.0 und großem Abgleich* Shopware-Connector 1
Neu Falsche Lieferzeiten nach Wareneingangsbuchung *Version 1.5.34.1* JTL-Wawi - Fehler und Bugs 0
Neu Onlineshopabgleich nach Update auf 1.5.42.0 nicht mehr möglich JTL-Wawi - Fehler und Bugs 0
Produktstreams nach Attributen Einrichtung JTL-Shop5 3
Neu Lieferschein Positionen nach Lagerplatzkommentar 1 sortieren Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Versandliste - Gesamtmenge & Gewicht aufgeschlüsselt nach Paket Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
nach Update auf 5 kein Wawi Abgleich mehr möglich Upgrade JTL-Shop4 auf JTL-Shop5 2
Gelöst JTL-Pos stürzt nach Benutzeranmeldung / PIN Eingabe ab JTL-POS - Fehler und Bugs 1
Gelöst Abgleich mit dem JTL-Connector nach Update auf 1.5.42.0 nicht mehr möglich JTL-Wawi - Fehler und Bugs 6
Neu Workflow: Versandklasse ändern nach WMS Versand User helfen Usern - Fragen zu JTL-Wawi 0
Neu Auftrag (ohne Rechnung) stornieren nach Lieferung und Retoure Arbeitsabläufe in JTL-Wawi 2
Neu {$Artikel->Versandkosten} - nach Versandland User helfen Usern - Fragen zu JTL-Wawi 0
Neu Berechnung nach update EK Netto (für GLD) User helfen Usern - Fragen zu JTL-Wawi 4
Beantwortet Einlagerung nach Wareneingang kompletter Ladungsträger Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 4
Neu Product-Stream Fehler nach dem Sliden JTL-Shop - Fehler und Bugs 1
Gelöst Nach Versanddatenimport wird Workflow doppelt ausgeführt JTL-Workflows - Fehler und Bugs 2
Neu Im Berichtscontainer Positionen Sortierung nach "Artikel.EigeneFelderAlsText" "Lagerort" User helfen Usern - Fragen zu JTL-Wawi 0
Beantwortet Stücklistenartikel zum Teil weg, nach Update auf Update auf 1.5.41.3 JTL-Wawi - Fehler und Bugs 2
In Diskussion Workflows nach Warengruppen JTL-Workflows - Fehler und Bugs 0
Neu Kein Admin Zugang nach Update auf Shop 5 Installation / Updates von JTL-Shop 10
Neu Versandart nach Artikelpreis Allgemeine Fragen zu JTL-Shop 0
Neu Nach Abgleich: Variationen weg und weitere Abgleiche nicht mehr möglich JTL-Wawi - Fehler und Bugs 0
Neu Reload Funktion nach "in den Warenkorb" anklicken Technische Fragen zu Plugins und Templates 1
Neu Wawi startet nicht mehr nach Update auf Version: 1.5.41.1 Installation von JTL-Wawi 9
Neu Änderungen nach Bestellabschluss Allgemeine Fragen zu JTL-Shop 2
Gelöst Druckerprobleme nach Windows Update JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
In Bearbeitung Verletzung der PRIMARY KEY-Einschränkung nach Update JTL Wawi 1.5.41.1 JTL-Wawi - Fehler und Bugs 4
Neu Google Shopping Plugin: nach Artikel-Update wird Artikel abgelehnt " Wiederverwendeter Wert (ID) Plugins für JTL-Shop 0
In Diskussion DPD nach Großbritannien JTL-ShippingLabels - Fehler und Bugs 3
Neu Onlineshop nach Neuinstallation ohne Backup Installation von JTL-Wawi 1
Neu Aufträge "leer" nach WooCommerce Abgleich WooCommerce-Connector 0
Neu Nach dem Shopabgleich werden Bruttopreise angezeigt WooCommerce-Connector 0
Neu Artikel Bestand in WAWI 1 direkt nach kauf 0 kann nicht ausgeliefert werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Artikel in Kategorien und auf Merkmalseiten nach Merkmalen sortieren? Allgemeine Fragen zu JTL-Shop 0
Neu WAWI 1.5.36.2 Workflow Ausliefern nach Zahlung funktioniert nicht JTL-Wawi - Fehler und Bugs 1
Neu Abgleich mit dem JTL-Connector nach Update auf 1.5.41.0 nicht mehr möglich News, Events und Umfragen 93
Beantwortet Automatische Pickliste nach Anzahl von Aufträgen JTL-Workflows - Ideen, Lob und Kritik 2
Beantwortet Lizensen sind weg aus der wawi nach update auf 1.5.41.0 Installation von JTL-Wawi 9
Neu Abgleich mit Gambio funktioniert nicht mehr nach update Gambio-Connector 2

Ähnliche Themen