Neu Nach Servercrash nur noch Zugriff auf Festplatte

OlliK

Aktives Mitglied
23. März 2020
4
0
Hallo zusammen,

mir ist meine Datenbank abgeschmiert (via SQL Managment steht sie aktuell auf -> Wiederherstellung steht aus, zuvor auf Fehlerverdächtig) und die letzte Sicherung .bak ist leider 3 Wochen alt. Ich habe aber die aktuelle mdf und ldf Datei retten können, Filestream war nicht aktiviert, die Protokolldateien sind wohl beschädigt. Kann ich mit dieser wieder die aktuelle Daten wiederherstellen? Im Forum habe ich bereits mehrere Beiträge dazu gelesen und schon etwas rumprobiert, leider hat davon nix funktioniert z.B. JTL Wawi neu installiert, die mdf und ldf Dateien reinkopiert (Verbindung zur SQL war gekappt, danach neu gestartet) und JTL Wawi ließ sich nicht starten. Was mach ich falsch?

Screenshot 2023-06-13 224653.png



Ein Anhängen der Datenbank war über SQL Mangement auch nicht möglich. Kapiere ich das nicht?

TITEL: Microsoft SQL Server Management Studio
------------------------------

Fehler bei Datenbank anfügen von Server "LUFTFAHRTSHOP-N\JTLWAWI". (Microsoft.SqlServer.Smo)

Hilfe erhalten Sie durch Klicken auf: http://go.microsoft.com/fwlink?Prod...t&EvtID=Datenbank+anfügen+Server&LinkId=20476

------------------------------
ZUSÄTZLICHE INFORMATIONEN:

Ausnahme beim Ausführen einer Transact-SQL-Anweisung oder eines Transact-SQL-Batches. (Microsoft.SqlServer.ConnectionInfo)

------------------------------

Fehler beim Verarbeiten des Protokolls für die eazybusiness-Datenbank. Führen Sie nach Möglichkeit eine Wiederherstellung von einer Sicherung aus. Falls keine Sicherung verfügbar ist, muss das Protokoll möglicherweise neu erstellt werden.
Die neue eazybusiness-Datenbank konnte nicht geöffnet werden. CREATE DATABASE wird abgebrochen. (Microsoft SQL Server, Fehler: 9004)

Hilfe erhalten Sie durch Klicken auf: http://go.microsoft.com/fwlink?Prod...er&EvtSrc=MSSQLServer&EvtID=9004&LinkId=20476

------------------------------
SCHALTFLÄCHEN:

OK
------------------------------



Wenn ich die Datenbank in SQL in den Emergency Modus setzte dann lässt sich die DB via JTL Wawi öffnen und alle Dateien können auch gelesen werden. Wenn ich den Emergency Modus wieder verlasse, dann geht eine Anmeldung wieder nicht. Gleicher Wawi Anmeldefehler wie oben abgebildet.


Wenn ich via SQL Management die DB repariere bekomme ich dasErgebnis:
Repairing process started on Thursday, June 08, 2023, 12:46:14 PM
Detected database version : MSSQL Server 2017
Detected database collation : Latin1_General_CI_AS
Detected database size : 3.22 GB

Selected MDF file name: C:\Program Files\Microsoft SQL Server\MSSQL14.JTLWAWI\MSSQL\DATA\eazybusiness.mdf
Repairing file... Completed

Reading database structures... Completed
Saving scan informations... Completed
Building tree view... Completed
Repairing process completed on Thursday, June 08, 2023, 12:53:02 PM



Mit DBCheck gab es folgendes Ergebnis:
DBCC-Ergebnis für "eazybusiness".
Dateiaktivierungsfehler. Der physische Dateiname "C:\Program Files\Microsoft SQL Server\MSSQL14.JTLWAWI\MSSQL\DATA\eazybusiness_log.ldf" ist möglicherweise falsch.
Das Protokoll kann nicht neu erstellt werden, da beim Herunterfahren der Datenbank Transaktionen/Benutzer geöffnet waren, kein Prüfpunkt für die Datenbank verwendet wurde oder die Datenbank schreibgeschützt war. Dieser Fehler kann auftreten, wenn die Transaktionsprotokolldatei manuell gelöscht wurde oder aufgrund eines Hardwarefehlers oder externen Fehlers verloren gegangen ist.
Service Broker wird in der eazybusiness-Datenbank deaktiviert, weil der Service Broker-GUID in der Datenbank (E80E8D1C-454F-4A45-B43F-10F7A88F07FE) nicht demjenigen in "sys.databases" (FF749AB2-27F9-40CE-B469-B7FB784D255E) entspricht.

Warnung: Das Protokoll für die eazybusiness-Datenbank wurde neu erstellt. Die Transaktionskonsistenz ist verloren gegangen. Die RESTORE-Kette wurde unterbrochen, und der Server besitzt keinen Kontext für die vorherigen Protokolldateien mehr, sodass Sie sie selbst auffinden müssen. Führen Sie DBCC CHECKDB zum Überprüfen der physischen Konsistenz aus. Die Datenbank wurde in den Nur-dbo-Modus versetzt. Um die Datenbank verfügbar zu machen, müssen Sie die Datenbankoptionen zurücksetzen und ggf. alle zusätzlichen Protokolldateien löschen.

Kann mir hierbei jemand helfen und Lösungsansätze oder Vorschläge geben? Was mache ich falsch oder sehe ich den Wald vor lauter Bäumen nicht? Oder bin ich zuviel Laie um das alles umzusetzen?
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.657
2.708
Berlin
Firma
css-umsetzung
Du hast die wawi installiert und auch die Initiale easzy Datenbank erstellt?
Danach hast du dann den sql server deaktiviert und die Datei ausgetauscht und den Server dann wieder gestartet?

Du hast auch die gleiche SQL Version verwendet wie die die du vorher hattest?
 

recent.digital

Offizieller Service Partner
SPBanner
8. Juli 2015
2.383
819
Wuppertal
Not-Support für unsere Kunden wäre greifbar. Den können wir hier aber nicht aktivieren.

Aber Du bist ja da - das kann schon einen Unterschied machen.

Grüße nach Berlin
 

OlliK

Aktives Mitglied
23. März 2020
4
0
Du hast die wawi installiert und auch die Initiale easzy Datenbank erstellt?
Danach hast du dann den sql server deaktiviert und die Datei ausgetauscht und den Server dann wieder gestartet?

Du hast auch die gleiche SQL Version verwendet wie die die du vorher hattest?
Genau so habe ich das gemacht. Kann man dabei etwas falsch machen? Die gleiche SQL Version wie zuvor.

Dann kommt folgender Hinweis:
Screenshot 2023-06-14 000825.png

Im SQL Managment kommt folgender Fehler:
Screenshot 2023-06-14 001308.png
Eine Wiederherstellung mittels Sicherung ist ja nicht möglich. Wie kann man das Protokoll neu erstellen?
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.657
2.708
Berlin
Firma
css-umsetzung
Da sollte jemand direkt draufschauen, das von außen zu bewerten ist nicht wirklich möglich denke ich.
 

recent.digital

Offizieller Service Partner
SPBanner
8. Juli 2015
2.383
819
Wuppertal
Hast du einen JTL Supportzugang? ggf. können die dir helfen oder dein Servicepartner, falls du einen hast. Oder du könntest die Anfrage in der Projektbörse von JTL veröffentlichen. Meist können auch Hoster helfen, wenn diese einen JTL Spezialisierung haben.
 

Ähnliche Themen