Neu Merkmale werden nicht übertragen. Artikel werden nicht den Merkmalen zugeordneten.

  • Wichtiger Hinweis Liebe Kunden, solltet Ihr den DATEV Rechnungsdatenservice 2.0 nutzen, dann müsst Ihr bis zum 30.06.2024 JTL-Wawi 1.9 installieren. Danach wird die Schnittstelle für ältere Versionen nicht mehr unterstützt.
  • JTL-Connect 2024: Ihr habt noch kein Ticket? Jetzt Early Bird Ticket zum Vorzugspreis sichern! HIER geht es zum Ticketverkauf

warehouse

Gut bekanntes Mitglied
26. März 2021
162
8
Hallo,

Ich nutze derzeit die Connector Version 2.0.1 und die aktuellste wawi Version.

Ich habe folgende Probleme:

1. Merkmale werden nicht übertragen.
Mit der neusten Connector Version erhalte ich diese Meldung sobald es an die Übertragung der Merkmale geht

Exception: Controller = Specific | Action = push | JTL-Wawi PK = 5812 | Name = Geschmack | Call to undefined method Jtl\ Connector\Core\Model\SpecificValue::getSpecificId()


2. Die Produkte werden nicht den Merkmalen zugeordnet.
Ich Konnte die Merkmale mit der Version 1.4.42 übertragen, jedoch werden die Produkte nicht den Merkmalen in woocommerce zugeordnet. Die Anzahl der Produkte bleibt hier 0. Alle Merkmale sind aber Produkten in der Wawi zugeordnet und werden dort auch angezeigt.



Hat noch jemand diese Probleme?
Kann mir jemand helfen und mir sagen woran es liegt?

Beste Grüße
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
100
25
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Hallo,

Ich nutze derzeit die Connector Version 2.0.1 und die aktuellste wawi Version.

Ich habe folgende Probleme:

1. Merkmale werden nicht übertragen.
Mit der neusten Connector Version erhalte ich diese Meldung sobald es an die Übertragung der Merkmale geht

Exception: Controller = Specific | Action = push | JTL-Wawi PK = 5812 | Name = Geschmack | Call to undefined method Jtl\ Connector\Core\Model\SpecificValue::getSpecificId()


2. Die Produkte werden nicht den Merkmalen zugeordnet.
Ich Konnte die Merkmale mit der Version 1.4.42 übertragen, jedoch werden die Produkte nicht den Merkmalen in woocommerce zugeordnet. Die Anzahl der Produkte bleibt hier 0. Alle Merkmale sind aber Produkten in der Wawi zugeordnet und werden dort auch angezeigt.



Hat noch jemand diese Probleme?
Kann mir jemand helfen und mir sagen woran es liegt?

Beste Grüße
Hallo warehouse

Habe es schnell ausprobiert, kann bei mir noch kein generelles Fehlverhalten oder obiger Laufzeitfehler betreff Merkmale feststellen:

zu 1) Artikel gelöscht, nochmals übertragen --> alle Merkmale sind als Attribut im Produkt aufgeführt
zu 2) Meinst Du nicht Schlagwörter? Soviel ich weiss, werden Merkmale von der Wawi wie Attribute behandelt, oder verstehe ich da was nicht?
3) Habs mit Schlagwörter (Artikel/Sonstiges/Suchbegriffe für Online- Shop) auch ausprobiert, funktioniert auch, werden auch Produkteanzahl zugewiesen.

Gruss Armin
 

warehouse

Gut bekanntes Mitglied
26. März 2021
162
8
Hallo warehouse

Habe es schnell ausprobiert, kann bei mir noch kein generelles Fehlverhalten oder obiger Laufzeitfehler betreff Merkmale feststellen:

zu 1) Artikel gelöscht, nochmals übertragen --> alle Merkmale sind als Attribut im Produkt aufgeführt
zu 2) Meinst Du nicht Schlagwörter? Soviel ich weiss, werden Merkmale von der Wawi wie Attribute behandelt, oder verstehe ich da was nicht?
3) Habs mit Schlagwörter (Artikel/Sonstiges/Suchbegriffe für Online- Shop) auch ausprobiert, funktioniert auch, werden auch Produkteanzahl zugewiesen.

Gruss Armin
Hallo Armin,

Danke für deine Antwort.

Ich habe mich vllt etwas missverständlich ausgedrückt.

Es geht mir hier Tatsächlich um die Merkmale der Produkte. Nicht Attribute oder Schlagworte.

Wobei du mit deiner Vermutung das die Merkmale wie Attribute behandelt werden glaube ich richtig liegst.
Die im Produkt hinterlegten Merkmale in der wawi werden als diese übertragen. Jedoch werden die Produkte den Merkmalen nicht zugeordnet. Dies ist zu erkennen in WordPress unter dem Reiter Produkte--Eigenschaften. Dort sehe ich die Merkmalgruppe und die einzelnen Merkmalwerte in der Gruppe. Hier sind aber keine Produkte in den Einzelnen Werten zu finden. Alle Werte haben 0 Produkte obwohl sie in der Wawi alle Produkten zugeordnet sind.

Da ich aber auch nicht alle Produkte aus dem Shop lösche und neu importieren kann ich deine Testumgebung nicht nachstellen. Ich gehe hier lediglich mit einem Update der Produkte vor mit einem Komplettabgleich.


Eigentlich wäre es auch gut wenn ich diese Informationen, über Attribute hinzufügen kann. Hier soll ja eigentlich Germanized jetzt komplett unterstützt werden und auch Nährwerte und Allergene usw. hinzugefügt werden können. Leider habe ich aber auch diese Möglichkeit nicht gefunden, wie ich dies über Attribute lösen kann.
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
100
25
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Hallo Armin,

Danke für deine Antwort.

Ich habe mich vllt etwas missverständlich ausgedrückt.

Es geht mir hier Tatsächlich um die Merkmale der Produkte. Nicht Attribute oder Schlagworte.

Wobei du mit deiner Vermutung das die Merkmale wie Attribute behandelt werden glaube ich richtig liegst.
Die im Produkt hinterlegten Merkmale in der wawi werden als diese übertragen. Jedoch werden die Produkte den Merkmalen nicht zugeordnet. Dies ist zu erkennen in WordPress unter dem Reiter Produkte--Eigenschaften. Dort sehe ich die Merkmalgruppe und die einzelnen Merkmalwerte in der Gruppe. Hier sind aber keine Produkte in den Einzelnen Werten zu finden. Alle Werte haben 0 Produkte obwohl sie in der Wawi alle Produkten zugeordnet sind.

Da ich aber auch nicht alle Produkte aus dem Shop lösche und neu importieren kann ich deine Testumgebung nicht nachstellen. Ich gehe hier lediglich mit einem Update der Produkte vor mit einem Komplettabgleich.


Eigentlich wäre es auch gut wenn ich diese Informationen, über Attribute hinzufügen kann. Hier soll ja eigentlich Germanized jetzt komplett unterstützt werden und auch Nährwerte und Allergene usw. hinzugefügt werden können. Leider habe ich aber auch diese Möglichkeit nicht gefunden, wie ich dies über Attribute lösen kann.
Ok, habe es jetzt auch gefunden.
Auch hier wurden bei uns die Daten richtig eingetragen, sogar mit der richtigen Anzahl Produkten, welches diese Attributwert haben. Wenn man dann die Zahl anwählt, kommen alle Produkte, welche dieses Merkmal/Attribut gesetzt haben.
Kann auch hier kein Fehlverhalten feststellen. Sorry.

Habe auch keine Anleitung zum Germanized Pro gefunden, wie man die Felder als Attribute benennen muss, dass die Werte übertragen werden. Frag doch bei JTL nach.
 

warehouse

Gut bekanntes Mitglied
26. März 2021
162
8
Ich danke dir. Ich werde mich weiter versuchen und hoffen, dass es einfach aus dem Nichts funktioniert. Scheint ja ein lokales Problem zu sein.
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
100
25
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Solche Fehlermeldungen deuten eher auf einen "schlafenden" Softwarefehler hin, der nur auftritt, wenn der Code in bestimmten Fällen dort durchlaufen wird.
Sollte von den Entwicklern geprüft und behoben werden.
 
  • Gefällt mir
Reaktionen: warehouse

warehouse

Gut bekanntes Mitglied
26. März 2021
162
8
Hier liegt der Fehler wohl daran das alle Merkmale in den Kindartikel hinterlegt sind und nicht auf den Vater übertragen werden. In woocommerce werden diese Merkmale nicht bei den Kindartikel angezeigt und daher wohl auch nicht in diese Liste mit eingepflegt. Was zur Folge hat, dass ich diese Merkmale nicht für einen Filter abfragen kann da sie nicht erkannt werden

Es sieht wohl so aus, dass ich alle Merkmale der Kindartikel auch im Vater hinterlegen nuss um diese dann für einen Filter benutzen zu können.

Wenn jemand eine andere Lösung für mich hat wäre ich sehr dankbar.
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
100
25
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Ja, dies ist korrekt.

Das ist die Struktur von Woocommerce: Varianten/Eigenschaften und daraus Filtern werden nur im Vaterartikel hinterlegt. Auf der Ebene der Kinderartikel gehen nur wenige Felder (zB: auch Beschreibung).
Das sieht man gut, wenn man im Administrator ein Varianten-Produkt anschaut.

Möchtest Du aber weitere Felder bei den Kindartikel hinterlegen, ist dies mit dem ACF (Advanced Custom Fields, https://www.advancedcustomfields.com/ Plugin möglich.
Der Connector unterstützt ja neu auch das ACF-Plugin.
 
  • Gefällt mir
Reaktionen: warehouse

warehouse

Gut bekanntes Mitglied
26. März 2021
162
8
Das ist ein guter Hinweis und könnte die Lösung für mein Problem sein. Ich werde es so versuchen.
Ich danke dir.
 

buyhigh

Aktives Mitglied
19. August 2017
25
0
Ich habe bei uns im neuen Shop das gleiche Problem.

Woocommerce 8.8.3
Connector: 2.0.0 (Fehler ist auch mit 2.0.1 aufgetreten)
Wawi: 1.9.4.1 (ist auch zuvor mit einer 1.8 aufgetreten)

Folgende Fehlermeldung erhalte ich:


Unbehandelte Ausnahme #959190594F6282F vom Typ System.Exception in
System.Exception: Exception: Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()
Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()


Unbehandelte Ausnahme #959190594F6282F vom Typ System.Exception in : Merkmale-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei specific.push: Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()

Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()

Response: {"jtlrpc":"2.0","id":"2698e59ae9a4437f9816d3bbae134b2b","result":null,"error":{"code":0,"message":"Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\\Connector\\Core\\Model\\SpecificValue::getSpecificId()","data":"Error (Code: 0) in ...\/SpecificController.php:213"}}
Exception bei specific.push: Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()

Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()

Response: {"jtlrpc":"2.0","id":"cab856e7e132459788e66d344d2cc5e1","result":null,"error":{"code":0,"message":"Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Hersteller | Call to undefined method Jtl\\Connector\\Core\\Model\\SpecificValue::getSpecificId()","data":"Error (Code: 0) in ...\/SpecificController.php:213"}}
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.bjuttSCGB3X(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.uijttHU1hR0(String , Object , Boolean , NetworkCredential , Boolean )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.bjuttSCGB3X(String , Object , Boolean , NetworkCredential )




2024-05-19T00:17:28 DEBUG - SELECT [tUserSession].[kUserSession]
,[tUserSession].[kOwnerUserSession]
,[tUserSession].[kBenutzer]
,[tUserSession].[kMandant]
,[tUserSession].[iApplicationId]
,[tUserSession].[cCustomIdentifier]
,[tUserSession].[cHostname]
,[tUserSession].[nProcessId]
,[tUserSession].[dLoggedIn]
,[tUserSession].[dLastHeartbeat]
,[tUserSession].[nIsSessionInterruptible]
,[tUserSession].[nSessionInterruptRequested]
,[tUserSession].[dSessionInterruptRequestTimestamp]
,[tUserSession].[cSessionInterruptHostname]
,[tUserSession].[kSessionInterruptBenutzer]
,[tUserSession].[iSessionInterruptMessage]
,[tUser].[cName] AS [cBenutzerName]
,[tMandant].[cName] AS [cMandantName]
,[tUserInterrupt].[cName] AS [cBenutzerNameInterrupt]
FROM [eazybusiness].[dbo].[tUserSession]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUser ON [tUserSession].[kBenutzer] = [tUser].[kBenutzer]
LEFT JOIN [eazybusiness].[dbo].[tMandant] ON [tUserSession].[kMandant] = [tMandant].[kMandant]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUserInterrupt ON [tUserSession].[kSessionInterruptBenutzer] = [tUserInterrupt].[kBenutzer]
WHERE [tUserSession].[kUserSession] = @kUserSession AND dSessionInvalidated IS NULL
@kUserSession = 549
2024-05-19T00:17:28 DEBUG - Dauer: 0ms, (bis zum Reader)(A)
2024-05-19T00:17:28 DEBUG - Dauer: 1 ms, 1 Zeilen
2024-05-19T00:17:28 DEBUG - UPDATE [eazybusiness].[dbo].[tUserSession] SET dLastHeartbeat = @dLastHeartbeat_0 WHERE kUserSession = @kUserSession_0;

@dLastHeartbeat_0 = 05/19/2024 00:17:28 +02:00
@kUserSession_0 = 549
2024-05-19T00:17:28 DEBUG - Dauer: 1ms, AffectedRows: 1
2024-05-19T00:18:28 DEBUG - SELECT [tUserSession].[kUserSession]
,[tUserSession].[kOwnerUserSession]
,[tUserSession].[kBenutzer]
,[tUserSession].[kMandant]
,[tUserSession].[iApplicationId]
,[tUserSession].[cCustomIdentifier]
,[tUserSession].[cHostname]
,[tUserSession].[nProcessId]
,[tUserSession].[dLoggedIn]
,[tUserSession].[dLastHeartbeat]
,[tUserSession].[nIsSessionInterruptible]
,[tUserSession].[nSessionInterruptRequested]
,[tUserSession].[dSessionInterruptRequestTimestamp]
,[tUserSession].[cSessionInterruptHostname]
,[tUserSession].[kSessionInterruptBenutzer]
,[tUserSession].[iSessionInterruptMessage]
,[tUser].[cName] AS [cBenutzerName]
,[tMandant].[cName] AS [cMandantName]
,[tUserInterrupt].[cName] AS [cBenutzerNameInterrupt]
FROM [eazybusiness].[dbo].[tUserSession]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUser ON [tUserSession].[kBenutzer] = [tUser].[kBenutzer]
LEFT JOIN [eazybusiness].[dbo].[tMandant] ON [tUserSession].[kMandant] = [tMandant].[kMandant]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUserInterrupt ON [tUserSession].[kSessionInterruptBenutzer] = [tUserInterrupt].[kBenutzer]
WHERE [tUserSession].[kUserSession] = @kUserSession AND dSessionInvalidated IS NULL
@kUserSession = 549
2024-05-19T00:18:28 DEBUG - Dauer: 0ms, (bis zum Reader)(A)
2024-05-19T00:18:28 DEBUG - Dauer: 1 ms, 1 Zeilen
2024-05-19T00:18:28 DEBUG - UPDATE [eazybusiness].[dbo].[tUserSession] SET dLastHeartbeat = @dLastHeartbeat_0 WHERE kUserSession = @kUserSession_0;

@dLastHeartbeat_0 = 05/19/2024 00:18:28 +02:00
@kUserSession_0 = 549
2024-05-19T00:18:28 DEBUG - Dauer: 0ms, AffectedRows: 1
2024-05-19T00:19:28 DEBUG - SELECT [tUserSession].[kUserSession]
,[tUserSession].[kOwnerUserSession]
,[tUserSession].[kBenutzer]
,[tUserSession].[kMandant]
,[tUserSession].[iApplicationId]
,[tUserSession].[cCustomIdentifier]
,[tUserSession].[cHostname]
,[tUserSession].[nProcessId]
,[tUserSession].[dLoggedIn]
,[tUserSession].[dLastHeartbeat]
,[tUserSession].[nIsSessionInterruptible]
,[tUserSession].[nSessionInterruptRequested]
,[tUserSession].[dSessionInterruptRequestTimestamp]
,[tUserSession].[cSessionInterruptHostname]
,[tUserSession].[kSessionInterruptBenutzer]
,[tUserSession].[iSessionInterruptMessage]
,[tUser].[cName] AS [cBenutzerName]
,[tMandant].[cName] AS [cMandantName]
,[tUserInterrupt].[cName] AS [cBenutzerNameInterrupt]
FROM [eazybusiness].[dbo].[tUserSession]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUser ON [tUserSession].[kBenutzer] = [tUser].[kBenutzer]
LEFT JOIN [eazybusiness].[dbo].[tMandant] ON [tUserSession].[kMandant] = [tMandant].[kMandant]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUserInterrupt ON [tUserSession].[kSessionInterruptBenutzer] = [tUserInterrupt].[kBenutzer]
WHERE [tUserSession].[kUserSession] = @kUserSession AND dSessionInvalidated IS NULL
@kUserSession = 549
2024-05-19T00:19:28 DEBUG - Dauer: 0ms, (bis zum Reader)(A)
2024-05-19T00:19:28 DEBUG - Dauer: 1 ms, 1 Zeilen
2024-05-19T00:19:28 DEBUG - UPDATE [eazybusiness].[dbo].[tUserSession] SET dLastHeartbeat = @dLastHeartbeat_0 WHERE kUserSession = @kUserSession_0;

@dLastHeartbeat_0 = 05/19/2024 00:19:28 +02:00
@kUserSession_0 = 549
2024-05-19T00:19:28 DEBUG - Dauer: 1ms, AffectedRows: 1
2024-05-19T00:20:28 DEBUG - SELECT [tUserSession].[kUserSession]
,[tUserSession].[kOwnerUserSession]
,[tUserSession].[kBenutzer]
,[tUserSession].[kMandant]
,[tUserSession].[iApplicationId]
,[tUserSession].[cCustomIdentifier]
,[tUserSession].[cHostname]
,[tUserSession].[nProcessId]
,[tUserSession].[dLoggedIn]
,[tUserSession].[dLastHeartbeat]
,[tUserSession].[nIsSessionInterruptible]
,[tUserSession].[nSessionInterruptRequested]
,[tUserSession].[dSessionInterruptRequestTimestamp]
,[tUserSession].[cSessionInterruptHostname]
,[tUserSession].[kSessionInterruptBenutzer]
,[tUserSession].[iSessionInterruptMessage]
,[tUser].[cName] AS [cBenutzerName]
,[tMandant].[cName] AS [cMandantName]
,[tUserInterrupt].[cName] AS [cBenutzerNameInterrupt]
FROM [eazybusiness].[dbo].[tUserSession]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUser ON [tUserSession].[kBenutzer] = [tUser].[kBenutzer]
LEFT JOIN [eazybusiness].[dbo].[tMandant] ON [tUserSession].[kMandant] = [tMandant].[kMandant]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUserInterrupt ON [tUserSession].[kSessionInterruptBenutzer] = [tUserInterrupt].[kBenutzer]
WHERE [tUserSession].[kUserSession] = @kUserSession AND dSessionInvalidated IS NULL
@kUserSession = 549
2024-05-19T00:20:28 DEBUG - Dauer: 0ms, (bis zum Reader)(A)
2024-05-19T00:20:28 DEBUG - Dauer: 1 ms, 1 Zeilen
2024-05-19T00:20:28 DEBUG - UPDATE [eazybusiness].[dbo].[tUserSession] SET dLastHeartbeat = @dLastHeartbeat_0 WHERE kUserSession = @kUserSession_0;

@dLastHeartbeat_0 = 05/19/2024 00:20:28 +02:00
@kUserSession_0 = 549
2024-05-19T00:20:28 DEBUG - Dauer: 0ms, AffectedRows: 1
2024-05-19T00:21:28 DEBUG - SELECT [tUserSession].[kUserSession]
,[tUserSession].[kOwnerUserSession]
,[tUserSession].[kBenutzer]
,[tUserSession].[kMandant]
,[tUserSession].[iApplicationId]
,[tUserSession].[cCustomIdentifier]
,[tUserSession].[cHostname]
,[tUserSession].[nProcessId]
,[tUserSession].[dLoggedIn]
,[tUserSession].[dLastHeartbeat]
,[tUserSession].[nIsSessionInterruptible]
,[tUserSession].[nSessionInterruptRequested]
,[tUserSession].[dSessionInterruptRequestTimestamp]
,[tUserSession].[cSessionInterruptHostname]
,[tUserSession].[kSessionInterruptBenutzer]
,[tUserSession].[iSessionInterruptMessage]
,[tUser].[cName] AS [cBenutzerName]
,[tMandant].[cName] AS [cMandantName]
,[tUserInterrupt].[cName] AS [cBenutzerNameInterrupt]
FROM [eazybusiness].[dbo].[tUserSession]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUser ON [tUserSession].[kBenutzer] = [tUser].[kBenutzer]
LEFT JOIN [eazybusiness].[dbo].[tMandant] ON [tUserSession].[kMandant] = [tMandant].[kMandant]
LEFT JOIN [eazybusiness].[dbo].[tBenutzer] tUserInterrupt ON [tUserSession].[kSessionInterruptBenutzer] = [tUserInterrupt].[kBenutzer]
WHERE [tUserSession].[kUserSession] = @kUserSession AND dSessionInvalidated IS NULL
@kUserSession = 549
2024-05-19T00:21:28 DEBUG - Dauer: 0ms, (bis zum Reader)(A)
2024-05-19T00:21:28 DEBUG - Dauer: 1 ms, 1 Zeilen
2024-05-19T00:21:28 DEBUG - UPDATE [eazybusiness].[dbo].[tUserSession] SET dLastHeartbeat = @dLastHeartbeat_0 WHERE kUserSession = @kUserSession_0;

@dLastHeartbeat_0 = 05/19/2024 00:21:28 +02:00
@kUserSession_0 = 549
2024-05-19T00:21:28 DEBUG - Dauer: 0ms, AffectedRows: 1
Zeitstempel: 2024-05-19T00:22:27
Locale: German (Germany)
Locale: German (Germany)
Version: Der Wert wurde nicht erstellt.
Plattform: Wawi
WawiSeed: 2.8.93927.17401
Prozessname: JTL-Wawi
Physikalischer Speicher: 59895808 / Peak: 556363776
Basispriorität: 8
Prioritätsklasse: Normal
CPU-Zeit (User): 0:00:24,046875
CPU-Zeit (System): 0:00:03,09375
Page-Size (Sytem): 2406896 / Peak: 552603648
Page-Size: 520728576 / Peak: 552603648
Offene Handles: 2282
Database:
Build: 2405101350 6f8ca4fd990bee50026e3b6bc12bc2051fdca3b0

------

Es werden nur alle Hersteller sowie Maßeinheiten übertragen, aber keine weiteren Merkmale. Wir haben zusätzlich das Plugin Perfect Brands Woocommerce aktiv, aber auch da werden die Brands den Produkten nicht zugewiesen.

Woran kann das liegen?
 

BaTu Service GmbH

Neues Mitglied
18. Januar 2024
3
0
Wir haben hier ebenfalls einen ähnlichen Fehler siehe errorlog.
Jemand eine Idee?

JTl-Connector Version: 2.0.1
WaWi Version: 1.8.12.2
Woocommerce: 8.9.0

Liebe Grüße
 

Anhänge

  • errorlog_20240521092212.txt
    11,9 KB · Aufrufe: 2

Spielzeug-Fuchs

Aktives Mitglied
29. Oktober 2019
8
6
Stehe vor dem selben Problem, ein Rollback des Connectors auf 2.0.0 jat auch bei mir nichts geholfen:

Unbehandelte Ausnahme #959190594F6282F vom Typ System.Exception in
System.Exception: Exception: Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Marke | Call to undefined method Jtl\ Connector\Core\Model\SpecificValue::getSpecificId()
Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Marke | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()


Unbehandelte Ausnahme #959190594F6282F vom Typ System.Exception in : Merkmale-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei specific.push: Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Marke | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()

Controller = Specific | Action = push | JTL-Wawi PK = 1 | Name = Marke | Call to undefined method Jtl\Connector\Core\Model\SpecificValue::getSpecificId()

Ich hoffe es findet sich schnelle eine Lösung.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Merkmale Filter JTL Shop 5 benutzerdefiniert anzeigen Allgemeine Fragen zu JTL-Shop 0
Merkmale für "Verordnung über die allgemeine Produktsicherheit (EU)" Otto.de - Anbindung (SCX) 2
Neu Kind-Merkmale bei Vaterartikel JTL-Wawi - Fehler und Bugs 5
Neu Dotliquid Otto Merkmale aus eBay Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Wie werden Varianten ausgedruckt? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Artikel werden bei Hermes versendung bei ebay nicht als verschickt makiert JTL-ShippingLabels - Fehler und Bugs 1
Neu Warum werden bei gleichem Code Tabellen unterschiedlich eingerückt abgebildet / CSS Problem Templates für JTL-Shop 2
Neu Bilder werden nicht korrekt angezeigt Allgemeine Fragen zu JTL-Shop 0
Neu JTL WAWI RESTAPI Sales Order kann nicht erstellt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Manuell eingetragene Einkaufspreise aus Angebot werden bei Auftragserstellung nicht übernommen JTL-Wawi - Fehler und Bugs 0
Neu Connectorabgleich überschreibt Einträge in Linkertabelle - Var.Kombis werden nicht unter dem Vaterartikel angelegt PrestaShop-Connector 0
Beantwortet Retouren mit Stücklistenartikeln können nicht bearbeitet werden - Kaufland [WAWI-76637] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu WEBP Bilder werden nicht angezeigt JTL-Shop - Fehler und Bugs 1
Neu Nova einige Fontawaysome Icon werden nicht angezeigt wie Whatsapp oder Paypal Templates für JTL-Shop 0
Neu Rabattcodes (Coupons) werden im Lieferschein nicht angezeigt JTL-Wawi - Fehler und Bugs 0
Neu Wordpress Shortcodes werden falsch formatiert WooCommerce-Connector 3
Neu Bedingte Formatierungen werden nicht gespeichert JTL-Wawi - Fehler und Bugs 4
Neu JTL-WaWi 1.9.4.3 Aufträge werden nicht angezeigt JTL-Wawi - Fehler und Bugs 0
Gelöst JTL POS Sobald ein neuer Bon erstellt wird, soll auch ein Rabatt automatisch erzeugt werden Allgemeine Fragen zu JTL-POS 1
Neu artikel werden nicht zu woocommerce übertragen WooCommerce-Connector 0
Neu Zahlungen werden nicht alle an die WAWI übertragen. JTL-POS - Fehler und Bugs 0
Neu Artikel ohne Bestandsführung sollen im Shop angezeigt werden User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bug: Meta Informationen werden nicht übertragen durch veraltete Rank Math Bezeichnung (Lösung) WooCommerce-Connector 0
Neu Amazon Preisänderungen werden nicht übernommen (1.9.4.1) Amazon-Anbindung - Fehler und Bugs 0
Neu Webp Bilder werden nicht erstellt. Shop 5.3.1 Allgemeine Fragen zu JTL-Shop 2
JTL-APP Auftrag kann nicht Festgeschrieben werden. JTL-Wawi App 0
Neu Versandbenachrichtigungen werden seit Update auf 1.9 gesendet JTL-Wawi - Fehler und Bugs 1
Artikel werden automatisch gelistet?! kaufland.de - Anbindung (SCX) 0
Neu Rechnungen werden nicht an Amazon übertragen Amazon-Anbindung - Fehler und Bugs 2
Neu Bilder werden nicht an den Shopify-Shop übertragen Shopify-Connector 0
Neu Verfügbare Mengen bei Variationsartikeln werden falsch berechnet / nicht aktualisiert eBay-Anbindung - Fehler und Bugs 0
Gelöst DHL: Es kann kein Versandetikett erstellt werden Gelöste Themen in diesem Bereich 3
Neu Preise werden nicht übertragen Shopware-Connector 0
Neu Ausgeblendete Kategorie ohne Artikel werden gefunden - JTL-Search JTL-Search 9
Neu JTL-Shop oder Workflow: Artikel mit Menge > 1 sollen trotzdem als separate Einzelartikel im Auftrag aufgeführt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 Bilder werden nicht übertragen nach Update auf Wawi 1.7.15.6 Shopware-Connector 0
Neu Sitemap ist HTML - Sitemap kann gelesen werden, enthält aber Fehler / Google Web Master Tool Allgemeine Fragen zu JTL-Shop 6
Neu Bestseller auf Startseite werden willkürlich angezeigt Allgemeine Fragen zu JTL-Shop 3
Neu JTL PayPal: Plugin - Bestellungen werden nicht angezeigt. Fehlermeldung "Unable to load config 'file:.conf'" Plugins für JTL-Shop 2
Aufträge zusammenfassen - Bestellnummern des Kunden werden nicht übernommen JTL-Wawi 1.8 1
Neu Grundpreisangaben für geringe Gramm-Mengen werden nicht angezeigt Betrieb / Pflege von JTL-Shop 0
Neu Kampangen können nicht mehr aufgerufen werden JTL-Shop - Fehler und Bugs 0
Neu Autorisierte Zahlungen über mollie werden bei Rundungsdifferenz storniert. WooCommerce-Connector 0
Rechnungen werden nicht mehr erstellt seit Umstieg auf Fulfillment JTL-Wawi 1.8 0
Neu Es werden nur jpg Bilder angezeigt und keine webP Gelöste Themen in diesem Bereich 3
Neu Zahlungsabgleich: Lastschrift soll als Lastschrift verbucht werden Arbeitsabläufe in JTL-Wawi 3
Neu Woocomnerce Aufträge werden in WAWI erstellt aber nicht als bezahlt markiert Gelöste Themen in diesem Bereich 3
Neu Änderungen in einer Druckvorlage werden nicht gespeichert Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Auftrag verpacken druckt auf 2 Drucker RE aus / wo kann das eingestellt werden? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Versandkosten werden bei der Gewinnermittlung nicht breücksichtig (1.8.12.2) JTL-Wawi 1.8 1

Ähnliche Themen